summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-01-22 14:49:42 +0000
committerDaniel Bermond2019-01-22 14:49:42 +0000
commitc57e1a4d63a9f5973e3ce9f79840aec7ee7b09ef (patch)
tree9e8d1470962b0bfc93a787916c70ca34feff0a02
parent77db2c6891ce6ee6421d5209a97143c771665f64 (diff)
downloadaur-c57e1a4d63a9f5973e3ce9f79840aec7ee7b09ef.tar.gz
optdepends: add missing python2-gobject for gtk ui
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d62c69a2e9de..6ac8ea4686d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deluge-git
pkgdesc = A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)
pkgver = 2.0.0b2.dev313.gb2e19561e
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://deluge-torrent.org/
arch = any
@@ -29,6 +29,7 @@ pkgbase = deluge-git
depends = xdg-utils
optdepends = librsvg: gtk ui
optdepends = pygtk: gtk ui
+ optdepends = python2-gobject: gtk ui
optdepends = python2-mako: web ui
optdepends = python2-notify: libnotify notifications
optdepends = python2-pygame: audible notifications
diff --git a/PKGBUILD b/PKGBUILD
index e04bb5ccd375..caf4cc7b1c31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=deluge-git
_srcname=deluge
pkgver=2.0.0b2.dev313.gb2e19561e
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)"
arch=('any')
@@ -26,6 +26,7 @@ makedepends=(
)
optdepends=('librsvg: gtk ui'
'pygtk: gtk ui'
+ 'python2-gobject: gtk ui'
'python2-mako: web ui'
'python2-notify: libnotify notifications'
'python2-pygame: audible notifications'
@@ -64,7 +65,7 @@ build() {
package() {
cd "$_srcname"
- python2 setup.py install --prefix='/usr' --root="$pkgdir" --optimize='1'
+ python2 setup.py install --prefix='/usr' --root="$pkgdir" --skip-build --optimize='1'
install -D -m644 "${srcdir}/deluged.service" "${pkgdir}/usr/lib/systemd/system/deluged.service"
install -D -m644 "${srcdir}/deluge-web.service" "${pkgdir}/usr/lib/systemd/system/deluge-web.service"