summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-06-10 00:00:09 -0400
committerMario Finelli2015-06-10 00:00:09 -0400
commitceb85f2231d0872b7e1f528ab03dd7ca2585e1af (patch)
tree4bb303cb9acf4601853e112d702862b9db1f7e71
downloadaur-ceb85f2231d0872b7e1f528ab03dd7ca2585e1af.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore8
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD36
-rw-r--r--mp3tag16
-rw-r--r--mp3tag.desktop10
-rw-r--r--mp3tag.pngbin0 -> 3627 bytes
7 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29fdde58613e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mp3tag
+ pkgdesc = The universal tag editor.
+ pkgver = 2.70
+ pkgrel = 2
+ url = http://www.mp3tag.de/en/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = p7zip
+ depends = wine
+ options = !strip
+ source = mp3tag
+ source = LICENSE
+ source = mp3tag.desktop
+ source = mp3tag.png
+ source = http://download.mp3tag.de/mp3tagv270setup.exe
+ sha256sums = 3fdcabf91b5ec50373d3aaeaf653611613aed39d94d17af50bb6f5a85afff586
+ sha256sums = 18967b634e69d8ccb08383d42a49ced3c0b11c632649a15c3a6a55e3a27f62e9
+ sha256sums = bc0c7b8a7a9f9ee92dfe2f1880ef5d91920473713b5d60e4afa361d69a446798
+ sha256sums = a3e09f7cda34bc31b3b5b1d7cf2010c3b17847c141ef5a074472eb72f760f6bf
+ sha256sums = 1cd0d82d52d7ec2307673ef32cf269833a42123e4458281ff943ec55741b9529
+
+pkgname = mp3tag
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..685492178335
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!LICENSE
+!mp3tag
+!mp3tag.desktop
+!mp3tag.png
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..599b1a3df425
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+Mp3tag v2.66 Copyright ©1999-2014 Florian Heidenreich
+
+Mp3tag v2.66 is designed for private use and commercial use without sale ("Freeware"), if the following rules are respected:
+
+The author, Florian Heidenreich has no responsibility if errors occures in direct or indirect relation with the software.
+
+Mp3tag v2.66 cannot be used in a military domain or in a similar domain (Weapon creation, armament, etc.).
+
+Mp3tag v2.66 can be distributed through non-commercial channels, if the delivery happens in the form of the self-extracting setup file available from http://www.mp3tag.de.
+
+Mp3tag v2.66 can be distributed through commercial channels if the author, Florian Heidenreich, agrees this delivery and if the delivery happens in the form of the self-extracting setup file available from http://www.mp3tag.de.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5eb5b61afe1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Contributor: Hubert Maraszek <marach5 at gmail dot com>
+
+pkgname=mp3tag
+pkgver=2.70
+pkgrel=2
+pkgdesc="The universal tag editor."
+arch=('i686' 'x86_64')
+url="http://www.mp3tag.de/en/"
+license=('custom')
+depends=('wine')
+makedepends=('p7zip')
+source=(mp3tag
+ LICENSE
+ mp3tag.desktop
+ mp3tag.png
+ "http://download.mp3tag.de/mp3tagv${pkgver/./}setup.exe")
+sha256sums=('3fdcabf91b5ec50373d3aaeaf653611613aed39d94d17af50bb6f5a85afff586'
+ '18967b634e69d8ccb08383d42a49ced3c0b11c632649a15c3a6a55e3a27f62e9'
+ 'bc0c7b8a7a9f9ee92dfe2f1880ef5d91920473713b5d60e4afa361d69a446798'
+ 'a3e09f7cda34bc31b3b5b1d7cf2010c3b17847c141ef5a074472eb72f760f6bf'
+ '1cd0d82d52d7ec2307673ef32cf269833a42123e4458281ff943ec55741b9529')
+options=('!strip')
+
+package() {
+ install -d -m755 "$pkgdir/usr/share/$pkgname"
+ 7z -y -o"$pkgdir/usr/share/$pkgname" x "$srcdir/mp3tagv${pkgver/./}setup.exe"
+ rm -rf "$pkgdir/usr/share/mp3tag/\$PLUGINSDIR" "$pkgdir/usr/share/mp3tag/\$R0"
+ find "$pkgdir/usr/share/$pkgname" -type d -exec chmod 755 "{}" \;
+ find "$pkgdir/usr/share/$pkgname" -type f -exec chmod 644 "{}" \;
+
+ install -D -m755 mp3tag "$pkgdir/usr/bin/mp3tag"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 mp3tag.png "$pkgdir/usr/share/pixmaps/mp3tag.png"
+ install -D -m644 mp3tag.desktop "$pkgdir/usr/share/applications/mp3tag.desktop"
+}
diff --git a/mp3tag b/mp3tag
new file mode 100644
index 000000000000..cdb2ce1e84cc
--- /dev/null
+++ b/mp3tag
@@ -0,0 +1,16 @@
+#!/bin/bash
+unset WINEPREFIX
+if [ ! -d "$HOME"/.mp3tag ] ; then
+ mkdir -p "$HOME"/.mp3tag
+ touch "$HOME"/.mp3tag/mp3tag.cfg
+ ln -s /usr/share/mp3tag/data "$HOME"/.mp3tag/data
+ ln -s /usr/share/mp3tag/export "$HOME"/.mp3tag/export
+ ln -s /usr/share/mp3tag/lang "$HOME"/.mp3tag/lang
+ ln -s /usr/share/mp3tag/help "$HOME"/.mp3tag/help
+ ln -s /usr/share/mp3tag/Mp3tag.exe "$HOME"/.mp3tag/mp3tag
+ ln -s /usr/share/mp3tag/Mp3tagShell32.dll "$HOME"/.mp3tag/Mp3tagShell32.dll
+ ln -s /usr/share/mp3tag/Mp3tagShell64.dll "$HOME"/.mp3tag/Mp3tagShell64.dll
+ ln -s /usr/share/mp3tag/tak_deco_lib.dll "$HOME"/.mp3tag/tak_deco_lib.dll
+fi
+WINEDEBUG=-all wine "$HOME"/.mp3tag/mp3tag "$@"
+
diff --git a/mp3tag.desktop b/mp3tag.desktop
new file mode 100644
index 000000000000..fc1f5696744e
--- /dev/null
+++ b/mp3tag.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Categories=AudioVideo
+Name=Mp3tag
+Comment=The universal tag editor
+Icon=mp3tag
+Exec=mp3tag
+Terminal=false
+Type=Application
+
diff --git a/mp3tag.png b/mp3tag.png
new file mode 100644
index 000000000000..edd79a910aaf
--- /dev/null
+++ b/mp3tag.png
Binary files differ