summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2020-06-21 11:47:43 +0200
committerSimon Brulhart2020-06-21 11:47:43 +0200
commitcf321c13dea50a2f580a0b542090dec97252b3a6 (patch)
tree01c996d096980f3e73f63ef9725b2727bfd3d4a3
parent45811000088e512dd22fb5a1940d90bba289c22c (diff)
downloadaur-cf321c13dea50a2f580a0b542090dec97252b3a6.tar.gz
Update to v10.25
-rwxr-xr-x.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--revert_bulk_append.patch26
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f71626b73cd..4d0bce32ace3 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
- pkgver = 10.24
+ pkgver = 10.25
pkgrel = 1
url = https://freefilesync.org
arch = i686
@@ -10,16 +10,16 @@ pkgbase = freefilesync
depends = wxgtk
depends = curl
depends = lsb-release
- source = FreeFileSync_10.24_Source.zip::https://freefilesync.org/download/FreeFileSync_10.24_Source.zip
+ source = FreeFileSync_10.25_Source.zip::https://freefilesync.org/download/FreeFileSync_10.25_Source.zip
source = revert_xdg_config_path.patch
source = revert_bulk_append.patch
source = revert_linkflags.patch
source = FreeFileSync.desktop
source = RealTimeSync.desktop
source = dlagent
- sha256sums = fba28a46bcce434c8a9a171e1b3c954163bda8c28705249e9502aef668ca73dd
+ sha256sums = 9fe0eb72d7acf5921c94cd554ebdfecd8a2c1db5bc88d9126eda758a7eb232ef
sha256sums = 0f9a9a6b2c3c460bbde7425bd62273c925259db1cc9dc18c6013aae99fb15cd8
- sha256sums = 474088f1eb7c8a25230e3d4e2f5b0ae81a65f526cd17a1c1d42e732a89ec6953
+ sha256sums = 17e7db683662809882db6d6b3d855eb4372ca1bd05e15c4c490970a0b4b127c0
sha256sums = 2942c0e74be2b15cdd83e36fa524c3b6c68d4b4da2042f1b0cf7c13d3b806eac
sha256sums = 590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51
sha256sums = 82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830
diff --git a/PKGBUILD b/PKGBUILD
index 66889ba96dee..9dfd8081675f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Maintainer: jooch <jooch AT gmx DOT com>
pkgname=freefilesync
-pkgver=10.24
+pkgver=10.25
pkgrel=1
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
@@ -24,15 +24,15 @@ source=(
dlagent
)
-sha256sums=('fba28a46bcce434c8a9a171e1b3c954163bda8c28705249e9502aef668ca73dd'
+sha256sums=('9fe0eb72d7acf5921c94cd554ebdfecd8a2c1db5bc88d9126eda758a7eb232ef'
'0f9a9a6b2c3c460bbde7425bd62273c925259db1cc9dc18c6013aae99fb15cd8'
- '474088f1eb7c8a25230e3d4e2f5b0ae81a65f526cd17a1c1d42e732a89ec6953'
+ '17e7db683662809882db6d6b3d855eb4372ca1bd05e15c4c490970a0b4b127c0'
'2942c0e74be2b15cdd83e36fa524c3b6c68d4b4da2042f1b0cf7c13d3b806eac'
'590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51'
'82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830'
'1649e7ea66235c6f82daf9beb6b61b7765df54e9ef70f7f6fc1283f5c2b1e54a')
-DLAGENTS=("https::./dlagent $url %u %o")
+# DLAGENTS=("https::./dlagent $url %u %o")
prepare() {
# wxgtk < 3.1.0
diff --git a/revert_bulk_append.patch b/revert_bulk_append.patch
index b583f5be78e9..9782134ec6a0 100644
--- a/revert_bulk_append.patch
+++ b/revert_bulk_append.patch
@@ -1,6 +1,6 @@
diff -r -u a/FreeFileSync/Source/ui/command_box.cpp b/FreeFileSync/Source/ui/command_box.cpp
---- a/FreeFileSync/Source/ui/command_box.cpp 2020-05-17 19:15:19.000000000 +0200
-+++ b/FreeFileSync/Source/ui/command_box.cpp 2020-05-17 20:04:55.554045299 +0200
+--- a/FreeFileSync/Source/ui/command_box.cpp 2020-06-18 19:16:52.000000000 +0200
++++ b/FreeFileSync/Source/ui/command_box.cpp 2020-06-21 10:45:23.265579023 +0200
@@ -120,7 +120,8 @@
//this->Clear(); -> NO! emits yet another wxEVT_COMMAND_TEXT_UPDATED!!!
@@ -12,8 +12,8 @@ diff -r -u a/FreeFileSync/Source/ui/command_box.cpp b/FreeFileSync/Source/ui/com
//this->SetSelection(wxNOT_FOUND); //don't select anything
ChangeValue(value); //preserve main text!
diff -r -u a/FreeFileSync/Source/ui/folder_history_box.cpp b/FreeFileSync/Source/ui/folder_history_box.cpp
---- a/FreeFileSync/Source/ui/folder_history_box.cpp 2020-05-17 19:15:19.000000000 +0200
-+++ b/FreeFileSync/Source/ui/folder_history_box.cpp 2020-05-17 20:05:56.513333473 +0200
+--- a/FreeFileSync/Source/ui/folder_history_box.cpp 2020-06-18 19:16:52.000000000 +0200
++++ b/FreeFileSync/Source/ui/folder_history_box.cpp 2020-06-21 10:45:23.265579023 +0200
@@ -90,7 +90,8 @@
//this->Clear(); -> NO! emits yet another wxEVT_COMMAND_TEXT_UPDATED!!!
@@ -24,9 +24,23 @@ diff -r -u a/FreeFileSync/Source/ui/folder_history_box.cpp b/FreeFileSync/Source
//this->SetSelection(wxNOT_FOUND); //don't select anything
ChangeValue(folderPathPhrase); //preserve main text!
+diff -r -u a/FreeFileSync/Source/ui/small_dlgs.cpp b/FreeFileSync/Source/ui/small_dlgs.cpp
+--- a/FreeFileSync/Source/ui/small_dlgs.cpp 2020-06-18 19:16:52.000000000 +0200
++++ b/FreeFileSync/Source/ui/small_dlgs.cpp 2020-06-21 11:35:53.494412284 +0200
+@@ -293,7 +293,9 @@
+ {
+ showNotificationDialog(this, DialogInfoType::error, PopupDialogCfg().setDetailInstructions(e.toString()));
+ }
+- m_listBoxGdriveUsers->Append(gdriveAccounts);
++ for (auto const& account: gdriveAccounts) {
++ m_listBoxGdriveUsers->Append(account);
++ }
+
+ //set default values for Google Drive: use first item of m_listBoxGdriveUsers
+ if (!gdriveAccounts.empty() && !acceptsItemPathPhraseGdrive(folderPathPhrase))
diff -r -u a/wx+/choice_enum.h b/wx+/choice_enum.h
---- a/wx+/choice_enum.h 2020-05-17 19:15:18.000000000 +0200
-+++ b/wx+/choice_enum.h 2020-05-18 21:06:22.073914615 +0200
+--- a/wx+/choice_enum.h 2020-06-18 19:16:51.000000000 +0200
++++ b/wx+/choice_enum.h 2020-06-21 10:45:23.268912329 +0200
@@ -79,7 +79,10 @@
if (items != itemsSetLast)