summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2021-12-23 11:33:15 -0600
committerSam Burgos2021-12-23 11:33:15 -0600
commitcf476c6e2d9f68436891810ad3df778fcec6aa12 (patch)
treeda03af2b910654cb63aa1dbef56a729c6c55cdb1
parent66adc7ec8dcbe31026e27659561892f67e173a8c (diff)
downloadaur-cf476c6e2d9f68436891810ad3df778fcec6aa12.tar.gz
updated PKGBUILD with changes and adapted Manjaro options for make, depends and optdepends
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD219
2 files changed, 35 insertions, 207 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 812ba02ef41f..073b2c11503d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,27 @@
pkgbase = gtkhash
pkgdesc = A GTK+ utility for computing message digests or checksums
pkgver = 1.4
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/tristanheaven/gtkhash
- arch = i686
arch = x86_64
- arch = mips64el
license = GPL
+ makedepends = caja
makedepends = dconf
makedepends = gtk3
makedepends = intltool
+ makedepends = libnautilus-extension
makedepends = librsvg
+ makedepends = nemo
makedepends = nettle
+ makedepends = thunar
makedepends = xdg-utils
- makedepends = nemo
+ depends = dconf
+ depends = gtk3
+ depends = nettle
source = https://github.com/tristanheaven/gtkhash/releases/download/v1.4/gtkhash-1.4.tar.xz
sha256sums = 20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4
pkgname = gtkhash
- depends = dconf
- depends = gtk3
- depends = nettle
pkgname = gtkhash-caja
pkgdesc = A GTK+ utility for computing message digests or checksums (Caja filemanager plugin)
@@ -30,20 +31,14 @@ pkgname = gtkhash-caja
pkgname = gtkhash-nautilus
pkgdesc = A GTK+ utility for computing message digests or checksums (Nautilus filemanager plugin)
depends = gtkhash
- depends = libnautilus-extension
+ depends = nautilus
pkgname = gtkhash-nemo
pkgdesc = A GTK+ utility for computing message digests or checksums (Nemo filemanager plugin)
depends = gtkhash
depends = nemo
-pkgname = gtkhash-peony
- pkgdesc = A GTK+ utility for computing message digests or checksums (Peony filemanager plugin)
- depends = gtkhash
- depends = peony
-
pkgname = gtkhash-thunar
pkgdesc = A GTK+ utility for computing message digests or checksums (Thunar filemanager plugin)
depends = gtkhash
depends = thunar
-
diff --git a/PKGBUILD b/PKGBUILD
index 80f2c8be63f7..8bebad59110a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Co-Maintainer: Sam Burgos < santiago dot burgos1089 at gmail dot com >
+# Maintainer: Sam Burgos < santiago dot burgos1089 at gmail dot com >
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Jan Böhringer <janboe@gmail.com>
# Contributor: Frédérik Paradis <fredy_14@live.fr>
# Contributor: GI_Jack <GI_Jack@hushmail.com>
@@ -10,209 +10,54 @@ pkgname=(
gtkhash-caja
gtkhash-nautilus
gtkhash-nemo
- gtkhash-peony
gtkhash-thunar
)
pkgver=1.4
-pkgrel=2
+pkgrel=4
pkgdesc="A GTK+ utility for computing message digests or checksums"
-arch=('i686' 'x86_64' 'mips64el')
+arch=('x86_64')
url="https://github.com/tristanheaven/gtkhash"
license=('GPL')
-
-makedepends=(
+depends=(
'dconf'
'gtk3'
- 'intltool'
- 'librsvg'
'nettle'
- 'xdg-utils'
)
-#Add Caja support
-if [[ $(xdg-mime query default inode/directory) = caja-folder-handler.desktop ]]; then
-makedepends+=(
+makedepends=(
'caja'
-)
-
-#Add Nautilus support
-elif [[ $(xdg-mime query default inode/directory) = org.gnome.Nautilus.desktop ]]; then
-
-makedepends+=(
- 'libnautilus-extension'
-)
-
-#Add Nemo support
-elif [[ $(xdg-mime query default inode/directory) = nemo.desktop ]]; then
-
-makedepends+=(
- 'nemo'
-)
-
-#Add Peony support
-elif [[ $(xdg-mime query default inode/directory) = peony.desktop ]]; then
-
-makedepends+=(
- 'peony'
-)
-
-#Add Thunar support
-elif [[ $(xdg-mime query default inode/directory) = thunar.desktop ]]; then
-
-makedepends+=(
+ 'dconf'
+ 'gtk3'
+ 'intltool'
+ 'libnautilus-extension'
+ 'librsvg'
+ 'nemo'
+ 'nettle'
'thunar'
+ 'xdg-utils'
)
-
-#All file managers must be installed
-else
- makedepends+=(
- 'caja'
- 'libnautilus-extension'
- 'nemo'
- 'peony'
- 'thunar'
-)
-fi
-
source=("${url}/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
sha256sums=('20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4')
build() {
cd gtkhash-$pkgver
- echo "${pkgname[@]}"
-
-#build with Caja support only
-if [[ $(xdg-mime query default inode/directory) = caja-folder-handler.desktop ]]; then
-
-#makedepends+=(
-# 'caja'
-#)
-
- ./configure \
- --prefix=/usr \
- --disable-schemas-compile \
- --enable-gtkhash \
- --enable-linux-crypto \
- --enable-nettle \
- --disable-blake2 \
- --with-gtk=3.0 \
- --enable-caja
-
-#build with Nautilus support only
-elif [[ $(xdg-mime query default inode/directory) = org.gnome.Nautilus.desktop ]]; then
-
-#makedepends+=(
-# 'libnautilus-extension'
-#)
-
-
- ./configure \
- --prefix=/usr \
- --disable-schemas-compile \
- --enable-gtkhash \
- --enable-linux-crypto \
- --enable-nettle \
- --disable-blake2 \
- --with-gtk=3.0 \
- --enable-nautilus
-
-#build with Nemo support only
-elif [[ $(xdg-mime query default inode/directory) = nemo.desktop ]]; then
-
-#makedepends+=(
-# 'nemo'
-#)
-
-
- ./configure \
- --prefix=/usr \
- --disable-schemas-compile \
- --enable-gtkhash \
- --enable-linux-crypto \
- --enable-nettle \
- --disable-blake2 \
- --with-gtk=3.0 \
- --enable-nemo
-
-#build with Peony support only
-elif [[ $(xdg-mime query default inode/directory) = peony.desktop ]]; then
-
-#makedepends+=(
-# 'peony'
-#)
-
-
- ./configure \
- --prefix=/usr \
- --disable-schemas-compile \
- --enable-gtkhash \
- --enable-linux-crypto \
- --enable-nettle \
- --disable-blake2 \
- --with-gtk=3.0 \
- --enable-peony
-
-#build with Thunar support only
-elif [[ $(xdg-mime query default inode/directory) = thunar.desktop ]]; then
-
-#makedepends+=(
-# 'thunar'
-#)
-
-
- ./configure \
- --prefix=/usr \
- --disable-schemas-compile \
- --enable-gtkhash \
- --enable-linux-crypto \
- --enable-nettle \
- --disable-blake2 \
- --with-gtk=3.0 \
- --enable-thunar
-
-#build with all file manager support
-else
-# makedepends+=(
-# 'caja'
-# 'libnautilus-extension'
-# 'nemo'
-# 'peony'
-# 'thunar'
-#)
-
- ./configure \
- --prefix=/usr \
- --disable-schemas-compile \
- --enable-gtkhash \
- --enable-linux-crypto \
- --enable-nettle \
- --disable-blake2 \
- --with-gtk=3.0 \
- --enable-caja \
- --enable-nautilus \
- --enable-nemo \
- --enable-peony \
- --enable-thunar
-fi
-
+ ./configure --prefix=/usr \
+ --disable-schemas-compile \
+ --enable-gtkhash \
+ --enable-linux-crypto \
+ --enable-nettle \
+ --disable-blake2 \
+ --with-gtk=3.0 \
+ --enable-nemo \
+ --enable-nautilus \
+ --enable-thunar \
+ --enable-caja \
make
-
- #./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
- # --enable-linux-crypto --enable-nettle --disable-blake2 --with-gtk=3.0 \
- # --enable-nemo --enable-nautilus --enable-thunar --enable-caja # ← remove FMs here!
- #make
}
package_gtkhash() {
- depends=(
- 'dconf'
- 'gtk3'
- 'nettle'
- )
-
make -C gtkhash-$pkgver DESTDIR="$pkgdir/" install
-
# remove filemanager plugins
rm -rf "$pkgdir"/usr/lib
}
@@ -233,7 +78,7 @@ package_gtkhash-nautilus() {
pkgdesc+=' (Nautilus filemanager plugin)'
depends=(
'gtkhash'
- 'libnautilus-extension'
+ 'nautilus'
)
make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
@@ -253,18 +98,6 @@ package_gtkhash-nemo() {
rm -rf "$pkgdir"/usr/lib/{thunarx-{2,3},nautilus,caja}
}
-package_gtkhash-peony() {
- pkgdesc+=' (Peony filemanager plugin)'
- depends=(
- 'gtkhash'
- 'peony'
-)
-
- make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
- # remove other filemanager plugins
- rm -rf "$pkgdir"/usr/lib/{thunarx-{2,3},caja,nemo}
-}
-
package_gtkhash-thunar() {
pkgdesc+=' (Thunar filemanager plugin)'
depends=(