summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2022-11-05 19:41:07 +0200
committerEugene Lamskoy2022-11-05 19:41:07 +0200
commitd0c51cee72473216f9b1cd83a8a0bb3b596ec81e (patch)
tree42002a7073e1ac7c2ffc44d9b20dc75344b60216
parentbbe208e1680c1e663773351cbbdae03fe498c2d0 (diff)
downloadaur-d0c51cee72473216f9b1cd83a8a0bb3b596ec81e.tar.gz
Fixed issue with openssl 3 build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--openssl-sslv3-consts.patch12
3 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cbd93d2573d..6961a42299ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 6.0.2
-# Sat Nov 5 17:20:44 UTC 2022
+# Sat Nov 5 17:36:44 UTC 2022
pkgbase = php74
pkgdesc = PHP 7.4.33 compiled as to not conflict with mainline php
pkgver = 7.4.33
- pkgrel = 1
+ pkgrel = 2
url = http://www.php.net
arch = x86_64
license = PHP
@@ -70,6 +70,7 @@ pkgbase = php74
source = php-makefile-patcher.php
source = php-apache.conf
source = https://php.net/distributions/php-7.4.33.tar.xz
+ source = openssl-sslv3-consts.patch
source = mysql-socket-php7.1.patch
source = php74-enchant.patch
source = debian-php-7.4.patch
@@ -81,6 +82,7 @@ pkgbase = php74
sha256sums = ba72fc64f77822755a469314160d5889d5298f4eb5758dd7939dac9b811afe52
sha256sums = 6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91
sha256sums = 924846abf93bc613815c55dd3f5809377813ac62a9ec4eb3778675b82a27b927
+ sha256sums = aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6
sha256sums = 0a3a6e8ff04ff1e0869befcf2c7bca4e886d94065da6d7a10b809a4750b961a0
sha256sums = 8fb103438fe12875dbe7c1f5b0899a81a76b4ce1456f16960e23e287d273df14
sha256sums = ccaad50d9e855bebd9d98bec4db6085dde3446ecd68bdbb58c1d450e1f5aeab9
diff --git a/PKGBUILD b/PKGBUILD
index ee7153c3df0f..a71f6f957f96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
_phpbase="74"
_suffix=""
pkgver="7.4.33"
-pkgrel="1"
+pkgrel="2"
pkgbase="php74"
pkgdesc="PHP 7.4.33 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
@@ -130,6 +130,7 @@ source=(
"php-makefile-patcher.php"
"php-apache.conf"
"https://php.net/distributions/php-${pkgver}.tar.xz"
+ "openssl-sslv3-consts.patch"
"mysql-socket-php7.1.patch"
"php74-enchant.patch"
"debian-php-7.4.patch"
@@ -201,6 +202,7 @@ makedepends=(
arch=(
)
_patches=(
+ "openssl-sslv3-consts.patch"
"mysql-socket-php7.1.patch"
"php74-enchant.patch"
"debian-php-7.4.patch"
@@ -1528,6 +1530,7 @@ sha256sums=('e6b8530d747000eebb0089249ec70a3b14add7b501337046700544883f62b17b'
'ba72fc64f77822755a469314160d5889d5298f4eb5758dd7939dac9b811afe52'
'6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91'
'924846abf93bc613815c55dd3f5809377813ac62a9ec4eb3778675b82a27b927'
+ 'aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6'
'0a3a6e8ff04ff1e0869befcf2c7bca4e886d94065da6d7a10b809a4750b961a0'
'8fb103438fe12875dbe7c1f5b0899a81a76b4ce1456f16960e23e287d273df14'
'ccaad50d9e855bebd9d98bec4db6085dde3446ecd68bdbb58c1d450e1f5aeab9'
diff --git a/openssl-sslv3-consts.patch b/openssl-sslv3-consts.patch
new file mode 100644
index 000000000000..f8075216683b
--- /dev/null
+++ b/openssl-sslv3-consts.patch
@@ -0,0 +1,12 @@
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -1482,7 +1482,9 @@
+ REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
+
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
++#ifdef RSA_SSLV23_PADDING
+ REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
++#endif
+ REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
+