summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2016-10-07 13:53:40 -0300
committerRafael Fontenelle2016-10-07 14:14:43 -0300
commitd27d43a778ef56db738c48053685e07456dad773 (patch)
tree37bb72d00313d17bd2ac4b570e173fc691157ef5
parent63b518ff7db83b50a7d1b2005a05cffb8b59115c (diff)
downloadaur-d27d43a778ef56db738c48053685e07456dad773.tar.gz
Fix source filename and fix i686 md5sum
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d8a0af6eab6..59fe739156d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jul 7 23:36:22 UTC 2016
+# Fri Oct 7 17:14:31 UTC 2016
pkgbase = teighaviewer-qt5
pkgdesc = Application for the visualization of CAD drawing files, QT5 version
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.opendesign.com/guestfiles/teigha_viewer
arch = i686
arch = x86_64
@@ -18,8 +18,8 @@ pkgbase = teighaviewer-qt5
source = license
md5sums = 62b5539acd57c50855e29d1157c10697
source_i686 = teighaviewer-qt5-i686-4.02.0.0.deb::https://download.opendesign.com/guestfiles/TeighaViewer/TeighaViewer_QT5_lnxX86_4.7dll.deb
- md5sums_i686 = dc13e90b7e43c0fa09b2a4bda70d29a2
- source_x86_64 = teighaviewer-qt5-i686-4.02.0.0.deb::https://download.opendesign.com/guestfiles/TeighaViewer/TeighaViewer_QT5_lnxX64_4.7dll.deb
+ md5sums_i686 = e4faa37171e02f48f6655529a07dba29
+ source_x86_64 = teighaviewer-qt5-x86_64-4.02.0.0.deb::https://download.opendesign.com/guestfiles/TeighaViewer/TeighaViewer_QT5_lnxX64_4.7dll.deb
md5sums_x86_64 = 5e0167db8629ab5ac60a285af7f10c84
pkgname = teighaviewer-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 3e4cc5ad2eab..8044e43f0741 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: rafaelff <rafaelff@gnome.org>
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
# NOTE about libgl dependency
# if you have and use 'mesa', install 'mesa-libgl'
@@ -10,7 +10,7 @@ pkgname=teighaviewer-qt5
_altname=teighaviewer
pkgver=4.2.0
_version=4.02.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Application for the visualization of CAD drawing files, QT5 version"
arch=('i686' 'x86_64')
url="https://www.opendesign.com/guestfiles/teigha_viewer"
@@ -18,13 +18,13 @@ license=('custom')
conflicts=('teighaviewer-qt4')
depends=('qt5-base' 'libxfixes' 'libgl' 'libxkbcommon-x11' 'bash' 'hicolor-icon-theme')
source=('license')
-source_i686=($pkgname-$arch-$_version.deb::https://download.opendesign.com/guestfiles/TeighaViewer/TeighaViewer_QT5_lnxX86_4.7dll.deb)
-source_x86_64=($pkgname-$arch-$_version.deb::https://download.opendesign.com/guestfiles/TeighaViewer/TeighaViewer_QT5_lnxX64_4.7dll.deb)
+source_i686=(${pkgname}-i686-${_version}.deb::https://download.opendesign.com/guestfiles/TeighaViewer/TeighaViewer_QT5_lnxX86_4.7dll.deb)
+source_x86_64=(${pkgname}-x86_64-${_version}.deb::https://download.opendesign.com/guestfiles/TeighaViewer/TeighaViewer_QT5_lnxX64_4.7dll.deb)
md5sums=('62b5539acd57c50855e29d1157c10697')
-md5sums_i686=('dc13e90b7e43c0fa09b2a4bda70d29a2')
+md5sums_i686=('e4faa37171e02f48f6655529a07dba29')
md5sums_x86_64=('5e0167db8629ab5ac60a285af7f10c84')
-build() {
+prepare() {
rm -rf ${_altname}-${_version}
mkdir ${_altname}-${_version}
tar xf data.tar.gz -C ${_altname}-${_version}
@@ -61,5 +61,4 @@ package() {
"${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
install -Dm644 "$srcdir"/license \
"${pkgdir}/usr/share/licenses/${pkgname}/license"
-
}