summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Lubineau2011-04-15 00:12:07 +0200
committerAntoine Lubineau2011-04-15 00:12:07 +0200
commitd27ef6192d81e974327b5d04e8d03fae29eb4c78 (patch)
tree41a7076fc045cf73f197cd43c940ddeb03775966
downloadaur-d27ef6192d81e974327b5d04e8d03fae29eb4c78.tar.gz
Tools for the TLA+2 language (SANY, TLC, PlusCal translator and TLATeX)
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD39
-rw-r--r--pcal2tla2
-rw-r--r--sany2
-rwxr-xr-xtla2tex2
-rw-r--r--tlc2
7 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eaf7110720c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tla-tools
+ pkgdesc = Tools for the TLA+2 language (SANY, TLC, PlusCal translator and TLATeX)
+ pkgver = 2
+ pkgrel = 1
+ url = http://research.microsoft.com/en-us/um/people/lamport/tla/tools.html
+ arch = any
+ license = custom:MSR-EULA
+ depends = jre
+ options = !strip
+ source = http://ftp.research.microsoft.com/downloads/41b4a0aa-5fad-4118-916a-45ed9fd48bf0/tla.zip
+ source = pcal2tla
+ source = sany
+ source = tla2tex
+ source = tlc
+ md5sums = c5931a7ec9426dd17795543a1d911a48
+ md5sums = 389c14cadf763d5ae2b5b9719b19e5ba
+ md5sums = 142d348ca24b7a7b0999d670908030a7
+ md5sums = cdb96d780f764111ec60cf67d1d158f2
+ md5sums = b89d785e2b264d0f32a69adcabb4e7d8
+
+pkgname = tla-tools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3829dcfe5810
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+
+pkgname=tla-tools
+pkgver=2
+pkgrel=1
+pkgdesc="Tools for the TLA+2 language (SANY, TLC, PlusCal translator and TLATeX)"
+arch=('any')
+url="http://research.microsoft.com/en-us/um/people/lamport/tla/tools.html"
+license=('custom:MSR-EULA')
+depends=('jre')
+options=(!strip)
+source=(
+ 'http://ftp.research.microsoft.com/downloads/41b4a0aa-5fad-4118-916a-45ed9fd48bf0/tla.zip'
+ 'pcal2tla'
+ 'sany'
+ 'tla2tex'
+ 'tlc'
+)
+md5sums=(
+ 'c5931a7ec9426dd17795543a1d911a48'
+ '389c14cadf763d5ae2b5b9719b19e5ba'
+ '142d348ca24b7a7b0999d670908030a7'
+ 'cdb96d780f764111ec60cf67d1d158f2'
+ 'b89d785e2b264d0f32a69adcabb4e7d8'
+)
+
+#build() {
+# cd "$srcdir/tla"
+# find -name *.java -exec rm {} \;
+#}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/java" "$pkgdir/usr/bin" "$pkgdir/usr/share/licences/$pkgname"
+ cp -a "$srcdir/tla" "$pkgdir/usr/share/java/$pkgname"
+ install -D -m 0755 {pcal2tla,sany,tla2tex,tlc} "$pkgdir/usr/bin"
+ install -D -m 0644 "$srcdir/tla/License.txt" "$pkgdir/usr/share/licences/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/pcal2tla b/pcal2tla
new file mode 100644
index 000000000000..7b7cc3143610
--- /dev/null
+++ b/pcal2tla
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -classpath /usr/share/java/tla-tools pcal.trans $@
diff --git a/sany b/sany
new file mode 100644
index 000000000000..5ed23f9eacec
--- /dev/null
+++ b/sany
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -classpath /usr/share/java/tla-tools tla2sany.SANY $@
diff --git a/tla2tex b/tla2tex
new file mode 100755
index 000000000000..15f58e828ab2
--- /dev/null
+++ b/tla2tex
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -classpath /usr/share/java/tla-tools tla2tex.TLA $@
diff --git a/tlc b/tlc
new file mode 100644
index 000000000000..163bcd052919
--- /dev/null
+++ b/tlc
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -classpath /usr/share/java/tla-tools tlc2.TLC $@