summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Bart2020-05-12 09:09:28 -0300
committerEduardo Bart2020-05-12 09:09:28 -0300
commitd4181b3646c4c43540331aa82e29105717ac2215 (patch)
tree40243a0746da36d1cd5ebcbc742e6e17f3502869
parent1505ced5ef9d8186a439215a1c85df1a61bee1c8 (diff)
downloadaur-d4181b3646c4c43540331aa82e29105717ac2215.tar.gz
Fix linkage with latest mingw environment
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc8bdcac2d87..57ae2cb9cb7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-sdl2_mixer
pkgdesc = A simple multi-channel audio mixer (mingw-w64)
pkgver = 2.0.4
- pkgrel = 2
+ pkgrel = 3
url = http://www.libsdl.org/projects/SDL_mixer
arch = any
license = zlib
diff --git a/PKGBUILD b/PKGBUILD
index 30d90003b4c7..90ddfcd32763 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
-# Maintainer: Linus Probert <linus dot probert at gmail dot com>
pkgname=mingw-w64-sdl2_mixer
pkgver=2.0.4
-pkgrel=2
+pkgrel=3
pkgdesc="A simple multi-channel audio mixer (mingw-w64)"
arch=(any)
url="http://www.libsdl.org/projects/SDL_mixer"
@@ -16,6 +15,10 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/SDL2_mixer-${pkgver}"
+
+ # link ssp (needed because mingw env's -fstack-protection)
+ export LDFLAGS="-lssp"
+
sed -i 's/"modplug\.h"/"libmodplug\/modplug.h"/' music_modplug.h
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}