summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorØystein Sture2023-05-04 09:47:47 +0200
committerØystein Sture2023-05-04 09:47:47 +0200
commitd4485bf448dd901ec83fa753f3a548d71f21922d (patch)
tree2bfc45e3672fdeacec7dcd9a910475a827ae880b
parent6af7f1d224de2f49a749b579fd9a806833565a70 (diff)
downloadaur-d4485bf448dd901ec83fa753f3a548d71f21922d.tar.gz
Switch to PEP517 build system
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 104631925c18..d15f7901e3af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = python-imageio-ffmpeg
pkgdesc = FFMPEG wrapper for Python
pkgver = 0.4.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/imageio/imageio-ffmpeg
arch = any
license = BSD
- makedepends = python-setuptools
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = ffmpeg
source = git+https://github.com/imageio/imageio-ffmpeg.git#tag=v0.4.8
diff --git a/PKGBUILD b/PKGBUILD
index d51c19b888e3..9c2f4d74621c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=python-imageio-ffmpeg
pkgver=0.4.8
-pkgrel=1
+pkgrel=2
pkgdesc="FFMPEG wrapper for Python"
arch=("any")
license=("BSD")
url="https://github.com/imageio/imageio-ffmpeg"
depends=('python' 'ffmpeg')
-makedepends=('python-setuptools' 'git')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
source=("git+https://github.com/imageio/imageio-ffmpeg.git#tag=v${pkgver}"
"pip_requirement.patch")
sha256sums=('SKIP'
@@ -22,11 +22,11 @@ prepare() {
build() {
cd "imageio-ffmpeg"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "imageio-ffmpeg"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-imageio-ffmpeg/LICENSE"
}