summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2024-01-21 20:13:51 -0300
committerTércio Martins2024-01-21 20:13:51 -0300
commitd59e8431a19302f1086c2b4548e029c7a9c4a626 (patch)
tree4e5a36e5b8d2e9bbb8005586e6b15cdbe4c75d9a
parent14a91267dcf1f091f319a49f31c843913de0caee (diff)
downloadaur-d59e8431a19302f1086c2b4548e029c7a9c4a626.tar.gz
Add support for OpenColorIO version 2.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
-rw-r--r--support_ocio_2_3.patch25
3 files changed, 42 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5533447f02c2..d223d85b9f28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = olive-git
pkgdesc = Free non-linear video editor
- pkgver = continuous.r2611.g70690c5b5
+ pkgver = continuous.r2626.gbfc0d3191
pkgrel = 1
url = https://www.olivevideoeditor.org/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = cmake
makedepends = git
makedepends = ninja
@@ -12,16 +12,16 @@ pkgbase = olive-git
makedepends = qt5-tools
depends = ffmpeg
depends = openimageio
- depends = opentimelineio0.14
+ depends = opentimelineio
depends = portaudio
depends = qt5-x11extras
provides = olive
conflicts = olive
source = git+https://github.com/olive-editor/olive.git
source = git+https://github.com/olive-editor/KDDockWidgets.git
- source = git+https://github.com/olive-editor/core.git
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ source = support_ocio_2_3.patch
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = 05d81f99409d78ae51a1200a14d07d29a830b53343d92d988e7ad8a2994b86d46f42ed0ec2c430829f8282e1284f067cc24ce78e8bd4233a40e09b5c179941df
pkgname = olive-git
diff --git a/PKGBUILD b/PKGBUILD
index 64f56f4d25dc..95435b1b7fe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=olive
pkgname=$_pkgname-git
-pkgver=continuous.r2611.g70690c5b5
+pkgver=continuous.r2626.gbfc0d3191
pkgrel=1
arch=('x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
-license=('GPL3')
-depends=('ffmpeg' 'openimageio' 'opentimelineio0.14' 'portaudio' 'qt5-x11extras')
+license=('GPL-3.0-or-later')
+depends=('ffmpeg' 'openimageio' 'opentimelineio' 'portaudio' 'qt5-x11extras')
makedepends=('cmake' 'git' 'ninja' 'qt5-svg' 'qt5-tools')
# Temporarily, the "olive-git" package is incompatible
@@ -20,11 +20,11 @@ makedepends=('cmake' 'git' 'ninja' 'qt5-svg' 'qt5-tools')
provides=('olive')
conflicts=('olive')
source=('git+https://github.com/olive-editor/olive.git'
- 'git+https://github.com/olive-editor/KDDockWidgets.git'
- 'git+https://github.com/olive-editor/core.git')
-sha512sums=('SKIP'
- 'SKIP'
- 'SKIP')
+ 'git+https://github.com/olive-editor/KDDockWidgets.git'
+ 'support_ocio_2_3.patch')
+b2sums=('SKIP'
+ 'SKIP'
+ '05d81f99409d78ae51a1200a14d07d29a830b53343d92d988e7ad8a2994b86d46f42ed0ec2c430829f8282e1284f067cc24ce78e8bd4233a40e09b5c179941df')
pkgver() {
cd $_pkgname
@@ -34,9 +34,10 @@ pkgver() {
prepare(){
cd $_pkgname
git submodule init
- git config submodule.ext/core.url "$srcdir"/core
git config submodule.ext/KDDockWidgets.url "$srcdir"/KDDockWidgets
git -c protocol.file.allow=always submodule update
+
+ patch --forward --strip=1 --input="$srcdir"/support_ocio_2_3.patch
}
build() {
diff --git a/support_ocio_2_3.patch b/support_ocio_2_3.patch
new file mode 100644
index 000000000000..78b0f729f3e6
--- /dev/null
+++ b/support_ocio_2_3.patch
@@ -0,0 +1,25 @@
+# Add support for OpenColorIO version 2.3
+# https://github.com/olive-editor/olive/pull/2294
+
+diff --unified --recursive --text olive.orig/app/render/renderer.cpp olive.new/app/render/renderer.cpp
+--- olive.orig/app/render/renderer.cpp 2024-01-21 19:28:15.695687760 -0300
++++ olive.new/app/render/renderer.cpp 2024-01-21 19:29:56.017642758 -0300
+@@ -240,9 +240,17 @@
+ const char* sampler_name = nullptr;
+ unsigned int width = 0, height = 0;
+ OCIO::GpuShaderDesc::TextureType channel = OCIO::GpuShaderDesc::TEXTURE_RGB_CHANNEL;
++#if OCIO_VERSION_HEX >= 0x02030000
++ OCIO::GpuShaderDesc::TextureDimensions dimensions = OCIO::GpuShaderDesc::TEXTURE_2D;
++#endif
+ OCIO::Interpolation interpolation = OCIO::INTERP_LINEAR;
+
+- shader_desc->getTexture(i, tex_name, sampler_name, width, height, channel, interpolation);
++ shader_desc->getTexture(i, tex_name, sampler_name, width, height, channel,
++#if OCIO_VERSION_HEX >= 0x02030000
++ // OCIO::GpuShaderDesc::TextureDimensions
++ dimensions,
++#endif
++ interpolation);
+
+ if (!tex_name || !*tex_name
+ || !sampler_name || !*sampler_name