aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Fordham2020-11-08 20:47:20 +1100
committerChris Fordham2020-11-08 20:47:20 +1100
commitd6adcc8353a33b3bf3d6f2347d648902e638b406 (patch)
tree128ad7f1aa4964d5f093aa3ee8f20a65c96ed9d3
parentd9e1f33c3e20c10e651f334c9a3783230c035dad (diff)
downloadaur-d6adcc8353a33b3bf3d6f2347d648902e638b406.tar.gz
Export the local GOPATH in each stage function in-case needed or used.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b281331b702..8352d542812b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = docker-git
pkgdesc = Pack, ship and run any application as a lightweight container.
- pkgver = r35925.b8e87cfdad
+ pkgver = r39078.b5ea9abf25
pkgrel = 1
epoch = 1
url = https://github.com/docker/docker
diff --git a/PKGBUILD b/PKGBUILD
index 9d82f6c7558f..caa72f7b0603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgname=docker-git
_pkgname=docker
-pkgver=r35925.b8e87cfdad
+pkgver=r39078.b5ea9abf25
pkgrel=1
epoch=1
pkgdesc='Pack, ship and run any application as a lightweight container.'
@@ -75,6 +75,8 @@ prepare() {
}
build() {
+ export GOPATH="$srcdir/go"
+
# runc
msg2 'building runc'
ln -sf "$srcdir/runc" "$GOPATH/src/github.com/opencontainers/"
@@ -136,6 +138,8 @@ build() {
# }
package() {
+ export GOPATH="$srcdir/go"
+
msg2 'runc binary'
install -Dm755 "$GOPATH/src/github.com/opencontainers/runc/runc" "$pkgdir/usr/bin/runc"