summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2017-08-09 23:05:42 +0200
committerfunilrys2017-08-09 23:05:42 +0200
commitd6b8d5496f5aff6d89a40979544d425d9c304703 (patch)
tree2229450e767a916bbb755142b92afbd163bc8eb7
parentac19ad4086a13e64aa964bf99875a7284b541f0f (diff)
downloadaur-d6b8d5496f5aff6d89a40979544d425d9c304703.tar.gz
Merge https://git.io/v71b9 + Introduction of Ian Chou to contributors
-rwxr-xr-xPKGBUILD16
-rw-r--r--anti-flood.patch10
2 files changed, 22 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 946ad4170a74..0fc5a2e792bd 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,12 @@
# Contributor: J. W. Birdsong <jwbirdsong AT gmail DOT com>
# Contributor: Frikilinux <frikilinux at frikilinux.com.ar>
# Contributor: Adriano Foschi <adriano.src gmail com>
-# Contributor: Ismael Carnales <icarnales@gamail.com
+# Contributor: Ismael Carnales <icarnales@gamail.com>
+# Contributor: Ian Chou <forendef2846 at gmail dot com>
pkgname=pidgin-light
pkgver=2.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="A light pidgin version: msn, jabber, irc supported protocols without gstreamer, tcl, tk, xscreensaver support.No video/voice. Includes finch "
arch=('i686' 'x86_64')
url="http://pidgin.im/"
@@ -23,9 +24,16 @@ provides=('pidgin' 'finch' 'libpurple')
conflicts=('pidgin' 'pidgin-msn' 'pidin-light-msn' 'finch' 'libpurple')
options=('!libtool')
install='pidgin-light.install'
-source=("http://downloads.sourceforge.net/project/pidgin/Pidgin/${pkgver}/pidgin-${pkgver}.tar.bz2" )
+source=("http://downloads.sourceforge.net/project/pidgin/Pidgin/${pkgver}/pidgin-${pkgver}.tar.bz2"
+ 'anti-flood.patch')
-sha512sums=('e87b39888432982ee36332fd14b272f49f7974de9e8694f7fe3bec2821748d6e6026ac5a63615a93386a033d6ee7c4de5ae0a86b725f63b9cc55650f0ab94b06')
+sha512sums=('e87b39888432982ee36332fd14b272f49f7974de9e8694f7fe3bec2821748d6e6026ac5a63615a93386a033d6ee7c4de5ae0a86b725f63b9cc55650f0ab94b06'
+ 'eb36697f26d167412272f23d260178d9b8b48df4d4aeff0e7929b75a6ddddfa95212343348357a9b90a407eba0be4640d9a5a0b12fb28e4d4b43c0cfcb8883e8')
+
+prepare() {
+ cd "$srcdir/pidgin-$pkgver"
+ patch -p0 < ../anti-flood.patch
+}
build() {
diff --git a/anti-flood.patch b/anti-flood.patch
new file mode 100644
index 000000000000..c289ee346571
--- /dev/null
+++ b/anti-flood.patch
@@ -0,0 +1,10 @@
+--- libpurple/protocols/irc/irc.c 2016-06-03 01:44:50.000000000 +0800
++++ libpurple/protocols/irc/irc.c 2017-08-10 02:33:41.704448371 +0800
+@@ -744,6 +744,7 @@
+ struct irc_conn *irc = gc->proto_data;
+ const char *args[2];
+
++ g_usleep(500000);
+ args[0] = g_hash_table_lookup(data, "channel");
+ args[1] = g_hash_table_lookup(data, "password");
+ irc_cmd_join(irc, "join", NULL, args);