summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-06-02 22:57:01 +0200
committerBaptiste Jonglez2016-06-02 22:57:42 +0200
commitd7ccb85145de43e48f0d746a67d06b25be774042 (patch)
tree1c38c736d7598d62866322d5f1e787237c643fd0
parent349ea6f1e347f44e48445a691cf0acfb84b1a93b (diff)
downloadaur-d7ccb85145de43e48f0d746a67d06b25be774042.tar.gz
opendht: Build python bindings
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 175122c470f4..092de289c908 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 31 14:46:40 UTC 2016
+# Thu Jun 2 20:57:03 UTC 2016
pkgbase = opendht-git
pkgdesc = A C++11 implementation of the Kademlia DHT (Distributed Hash Table)
- pkgver = 20160530
+ pkgver = 20160602
pkgrel = 1
url = https://github.com/savoirfairelinux/opendht
arch = i686
@@ -11,9 +11,11 @@ pkgbase = opendht-git
makedepends = git
makedepends = msgpack-c
makedepends = cmake
+ makedepends = cython
depends = gnutls
depends = nettle
depends = readline
+ optdepends = python: to use the Python bindings
provides = opendht
conflicts = opendht
source = git://github.com/savoirfairelinux/opendht
diff --git a/PKGBUILD b/PKGBUILD
index 4928919b9c48..9198941c2597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=opendht-git
-pkgver=20160530
+pkgver=20160602
pkgrel=1
pkgdesc="A C++11 implementation of the Kademlia DHT (Distributed Hash Table)"
arch=('i686' 'x86_64')
depends=('gnutls' 'nettle' 'readline')
-makedepends=('git' 'msgpack-c' 'cmake')
+makedepends=('git' 'msgpack-c' 'cmake' 'cython')
+optdepends=('python: to use the Python bindings')
url="https://github.com/savoirfairelinux/opendht"
license=('GPL3')
source=("git://github.com/savoirfairelinux/opendht")
@@ -27,6 +28,7 @@ build() {
cd build
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
+ -DOPENDHT_PYTHON=ON \
-DCMAKE_INSTALL_PREFIX=/usr
make
}