summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2023-05-26 21:30:34 -0400
committerAlexandre Demers2023-05-26 21:30:34 -0400
commitd7ed7517c7b8adebdf63c6fd109828937c15a7e1 (patch)
tree2ce200a639be88c7cd9fba0b6553a44aa6329000
parent5c10a825dc26ea5b4d0f47ebbe856afc60f65dd7 (diff)
downloadaur-d7ed7517c7b8adebdf63c6fd109828937c15a7e1.tar.gz
Update to 0.164.r3095.baee400
Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c221f1ba7465..5d410a91a8e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-x264
pkgdesc = Open Source H264/AVC video encoder (32 bit)
- pkgver = 0.164.r3081.19856cc
+ pkgver = 0.164.r3095.baee400
pkgrel = 1
epoch = 3
url = https://www.videolan.org/developers/x264.html
@@ -8,9 +8,9 @@ pkgbase = lib32-x264
license = GPL
makedepends = git
makedepends = nasm
- makedepends = lib32-gcc-libs
- depends = x264>=3:0.164.r3081.19856cc
+ depends = x264>=3:0.164.r3095.baee400
depends = lib32-glibc
+ depends = lib32-gcc-libs
depends = lib32-l-smash
provides = lib32-libx264
provides = libx264.so
@@ -20,7 +20,7 @@ pkgbase = lib32-x264
replaces = lib32-libx264
replaces = lib32-libx264-10bit
replaces = lib32-libx264-all
- source = git+https://git.videolan.org/git/x264.git#commit=19856cc41ad11e434549fb3cc6a019e645ce1efe
+ source = git+https://git.videolan.org/git/x264.git#commit=baee400fa9ced6f5481a728138fed6e867b0ff7f
sha256sums = SKIP
pkgname = lib32-x264
diff --git a/PKGBUILD b/PKGBUILD
index 0303eda339b7..c58a9a9d0ecd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgbasename=x264
pkgname=lib32-x264
-pkgver=0.164.r3081.19856cc
+pkgver=0.164.r3095.baee400
pkgrel=1
epoch=3
pkgdesc='Open Source H264/AVC video encoder (32 bit)'
@@ -19,12 +19,12 @@ depends=(
# "x264"
"x264>=${epoch}:${pkgver}"
"lib32-glibc"
+ 'lib32-gcc-libs'
"lib32-l-smash"
)
makedepends=(
'git'
'nasm'
- 'lib32-gcc-libs'
)
provides=(
'lib32-libx264'
@@ -40,7 +40,7 @@ replaces=(
'lib32-libx264-10bit'
'lib32-libx264-all'
)
-_commit='19856cc41ad11e434549fb3cc6a019e645ce1efe'
+_commit=baee400fa9ced6f5481a728138fed6e867b0ff7f # master
source=("git+https://git.videolan.org/git/x264.git#commit=${_commit}")
sha256sums=('SKIP')
@@ -77,7 +77,7 @@ build() {
}
package() {
- make -C build DESTDIR="${pkgdir}" install-cli install-lib-shared
+ make -C build DESTDIR="${pkgdir}" BASHCOMPLETIONSDIR="/usr/share/bash-completion/completions" install-cli install-lib-shared install-bashcompletion
# Keep files in bin since this is not a library only package.
# Use the same naming scheme as proposed in Arch's wiki: https://wiki.archlinux.org/index.php/32-bit_package_guidelines
@@ -87,4 +87,5 @@ package() {
done
rm -rf "${pkgdir}"/usr/include
+ rm -rf "${pkgdir}"/usr/share/bash-completion/
}