summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2020-01-11 12:22:24 +0000
committerGergely Imreh2020-01-11 12:22:24 +0000
commitd960eadee4a30508aec2fed6a5931accc2cb8839 (patch)
tree877d5965209fd7860c1cf738d7c94255f65008c2
parent6cc131605695730f24d91574f12403b1ba60fb76 (diff)
downloadaur-d960eadee4a30508aec2fed6a5931accc2cb8839.tar.gz
Do proper submodule checkout and bump version.
Signed-off-by: Gergely Imreh <imrehg@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c91897e324d..2ba8a73871fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = go-filecoin-git
pkgdesc = A decentralized storage network, full node implementation in Go
- pkgver = nightly_17481_fc53b4_0_gfc53b48c
+ pkgver = nightly_33814_fb13ac_67_g66420554
pkgrel = 1
url = https://github.com/filecoin-project/go-filecoin
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index de8f5b9be569..27302191d436 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=go-filecoin
pkgname=$_pkgname-git
-pkgver=nightly_17481_fc53b4_0_gfc53b48c
+pkgver=nightly_33814_fb13ac_67_g66420554
pkgrel=1
pkgdesc='A decentralized storage network, full node implementation in Go'
_organization='filecoin-project'
@@ -30,6 +30,7 @@ pkgver() {
prepare() {
# Get all the submodules as well
cd "${srcdir}/${_pkgname}"
+ git submodule update --init --recursive
# Set up go build environment
local targetorg="${srcdir}/src/github.com/${_organization}"