summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpiros Georgaras2023-11-23 18:26:22 +0200
committerSpiros Georgaras2023-11-23 18:26:22 +0200
commitd9fd636d33e2df3e27e5fd6afcb04283f746cf53 (patch)
tree400001a9e745378cfbec140603bf9ca74c557842
parent7b3aec1ec10a90961a6b04297da05d386e882495 (diff)
downloadaur-d9fd636d33e2df3e27e5fd6afcb04283f746cf53.tar.gz
version 0.9.2.20
Updated to use the pyproject.toml installation method at https://wiki.archlinux.org/title/Python_package_guidelines\#Installation_methods
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b259b31162d4..9a40d2b3d58e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pyradio-git
pkgdesc = Internet radio player for the command line
- pkgver = 0.9.2.19
- pkgrel = 2
+ pkgver = 0.9.2.20
+ pkgrel = 1
url = http://www.coderholic.com/pyradio/
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 29fd95992607..a0ea3be81236 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: aksr <aksr at t-com dot me>
pkgname=pyradio-git
-pkgver=0.9.2.19.r0.gbf0fd80
+pkgver=0.9.2.20
pkgrel=1
pkgdesc="Internet radio player for the command line"
arch=('any')
@@ -12,7 +12,7 @@ url="http://www.coderholic.com/pyradio/"
license=('MIT')
depends=('python-dnspython' 'python-requests' 'python-psutil' 'python-netifaces' 'python-rich' 'python-dateutil')
optdepends=('mplayer: as backend' 'mpv: as backend' 'vlc: as backend' 'mkvtoolnix-cli: fix mplayer recordings, add chapters to recordings')
-makedepends=('git' 'python-pip' 'python-wheel')
+makedepends=('git' 'python-pip' 'python-build' 'python-installer' 'python-wheel')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=($pkgname::git+https://github.com/coderholic/pyradio.git)
@@ -21,10 +21,9 @@ sha256sums=('SKIP')
prepare() {
cd $pkgname
_descr="$(git describe --long --tags)"
- sed -i '/readme = / a \
-license = {file = "LICENCE"}' pyproject.toml
sed -i "s/git_description = ''/git_description = '$_descr'/" pyradio/config.py
sed -i 's/distro = None/distro = Arch Linux (AUR)/' pyradio/config
+ git -C "${srcdir}/${pkgname}" clean -dfx
}
pkgver() {
@@ -32,16 +31,18 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "$pkgname"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd $pkgname
-
- install -Dm644 LICENCE "$pkgdir/usr/share/licenses/pyradio/LICENSE"
- install -Dm644 ./*{html,md} -t "$pkgdir/usr/share/doc/pyradio"
- install -Dm644 pyradio{,_rb,_server,_rec}.1 -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/pyradio/LICENSE"
+ install -Dm644 ./docs/*{html,md} -t "$pkgdir/usr/share/doc/pyradio"
+ install -Dm644 ./docs/pyradio{,_rb,_server,_rec}.1 -t "$pkgdir/usr/share/man/man1"
install -Dm644 devel/pyradio.desktop -t "$pkgdir/usr/share/applications"
install -Dm644 devel/pyradio.png -t "$pkgdir/usr/share/icons"
-
-
- PIP_CONFIG_FILE=/dev/null python -m pip install --no-warn-script-location --isolated --root="$pkgdir" --ignore-installed --no-deps .
+ python -m installer --destdir="$pkgdir" dist/*.whl
}