summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-11-06 00:59:24 -0600
committerHurricanePootis2023-11-06 00:59:24 -0600
commitda8917e93f0fdb66fff630d06cc6b8ec8ad8a0af (patch)
tree42dc5f43f3cad734f32ed06d73fa3f9248023385
parent618be6d436c08a610c699fbdc0b0ae93b33d2462 (diff)
downloadaur-da8917e93f0fdb66fff630d06cc6b8ec8ad8a0af.tar.gz
Add faad2 and oaknut
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e51968bbeb9..ece2c08c9ed9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r9829.45ef11654
+ pkgver = r9848.9b2a5926a
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
@@ -64,8 +64,10 @@ pkgbase = citra-git
source = vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
source = git+https://github.com/yuzu-emu/sirit.git
+ source = git+https://github.com/knik0/faad2.git
source = library-headers::git+https://github.com/citra-emu/ext-library-headers.git
source = git+https://github.com/bylaws/libadrenotools.git
+ source = git+https://github.com/merryhime/oaknut.git
source = git+https://github.com/google/googletest
source = git+https://github.com/arsenm/sanitizers-cmake
source = zycore::git+https://github.com/zyantific/zycore-c
@@ -105,6 +107,8 @@ pkgbase = citra-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = citra-git
depends = ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index c6d26ba44ab1..7928a1b2d6d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r9829.45ef11654
+pkgver=r9848.9b2a5926a
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -55,8 +55,10 @@ source=("$_pkgbase::git+https://github.com/citra-emu/citra.git"
"vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
"git+https://github.com/yuzu-emu/sirit.git"
+ "git+https://github.com/knik0/faad2.git"
"library-headers::git+https://github.com/citra-emu/ext-library-headers.git"
"git+https://github.com/bylaws/libadrenotools.git"
+ "git+https://github.com/merryhime/oaknut.git"
# cubeb's submodule
"git+https://github.com/google/googletest"
"git+https://github.com/arsenm/sanitizers-cmake"
@@ -99,6 +101,8 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -108,7 +112,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgbase"
- for submodule in {boost,nihstro,soundtouch,catch2,dynarmic,xbyak,fmt,enet,libressl,cubeb,discord-rpc,cpp-jwt,teakra,zstd,libyuv,cryptopp-cmake,cryptopp,dds-ktx,sdl2,lodepng,libusb,inih,openal-soft,glslang,vma,vulkan-headers,sirit,library-headers,libadrenotools};
+ for submodule in {boost,nihstro,soundtouch,catch2,dynarmic,xbyak,fmt,enet,libressl,cubeb,discord-rpc,cpp-jwt,teakra,zstd,libyuv,cryptopp-cmake,cryptopp,dds-ktx,sdl2,lodepng,libusb,inih,openal-soft,glslang,vma,vulkan-headers,sirit,faad2,library-headers,libadrenotools,oaknut};
do
git config --file=.gitmodules submodule.${submodule}.url "$srcdir/${submodule}"
done