summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2017-12-09 08:34:26 -0500
committerJean Lucas2017-12-09 08:34:26 -0500
commitda9f7e1ba9495ef6f8be75e56170b7eee183a88e (patch)
tree12bed06f4fad01905fc400137ac8487d236ae1a9
parenta1649b822bd8c1150b2750733362e7da533a703d (diff)
downloadaur-da9f7e1ba9495ef6f8be75e56170b7eee183a88e.tar.gz
Version bump to 1.6.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD45
2 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5366f4c37628..bc472ad45cca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 16 10:03:52 UTC 2017
+# Sat Dec 9 13:34:17 UTC 2017
pkgbase = openfst
pkgdesc = Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)
- pkgver = 1.6.2
+ pkgver = 1.6.5
pkgrel = 1
url = http://www.openfst.org
arch = i686
@@ -12,8 +12,8 @@ pkgbase = openfst
depends = glibc
depends = python2
options = !libtool
- source = http://www.openfst.org/twiki/pub/FST/FstDownload/openfst-1.6.2.tar.gz
- sha256sums = 3f72e35097fdf1c1c41e15165c16696c223295b40b7b145b5466306db7972578
+ source = http://www.openfst.org/twiki/pub/FST/FstDownload/openfst-1.6.5.tar.gz
+ sha512sums = 68c1a96f3ecad7480b80dc124c5caedc2729ee1b94dd4a21373cce385ba616b028cd6627bcc01f6dffd6b050693cc52d79db166706f3571494c4d3a6ff40cd60
pkgname = openfst
diff --git a/PKGBUILD b/PKGBUILD
index 9fc541ed026b..16b125483e22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,41 +4,42 @@
# Contributor: Christoph Drexler <chrdr at gmx dot at>
pkgname=openfst
-pkgver=1.6.2
+pkgver=1.6.5
pkgrel=1
pkgdesc="Library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs)"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url="http://www.openfst.org"
-license=('Apache')
-depends=('gcc-libs' 'glibc' 'python2')
+license=(Apache)
+depends=(gcc-libs glibc python2)
options=(!libtool)
-source=("http://www.openfst.org/twiki/pub/FST/FstDownload/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('3f72e35097fdf1c1c41e15165c16696c223295b40b7b145b5466306db7972578')
+source=(http://www.openfst.org/twiki/pub/FST/FstDownload/$pkgname-$pkgver.tar.gz)
+sha512sums=(68c1a96f3ecad7480b80dc124c5caedc2729ee1b94dd4a21373cce385ba616b028cd6627bcc01f6dffd6b050693cc52d79db166706f3571494c4d3a6ff40cd60)
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $srcdir/$pkgname-$pkgver
# Options according to http://openfst.cs.nyu.edu/twiki/bin/view/FST/ReadMe
OPTIONS="--prefix=/usr --disable-dependency-tracking"
- OPTIONS+=" --enable-bin" # Enable fst::script and command-line binaries; Default: yes
- OPTIONS+=" --enable-compact-fsts" # Enable all CompactFst classes; Default: no
- OPTIONS+=" --enable-compress" # Enable compression extension; Default: no
- OPTIONS+=" --enable-const-fsts" # Enable all ConstFst classes; Default: no
- OPTIONS+=" --enable-far" # Enable FAR (FST Archive) extension; Default: no
- OPTIONS+=" --enable-linear-fsts" # Enable Linear{Tagger,Classifier}Fst extensions; Default: no
- OPTIONS+=" --enable-lookahead-fsts" # Enable LookAheadFst classes; Default: no
- OPTIONS+=" --enable-mpdt" # Enable MPDT extensions; Default: no
- OPTIONS+=" --enable-ngram-fsts" # Enable NGramFst extensions; Default: no
- OPTIONS+=" --enable-pdt" # Enable PDT extensions; Default: no
- OPTIONS+=" --enable-python PYTHON=python2" # Enable Python extensions; Default: no
+ OPTIONS+="--enable-bin" # Enable fst::script and command-line binaries; Default: yes
+ OPTIONS+="--enable-compact-fsts" # Enable all CompactFst classes; Default: no
+ OPTIONS+="--enable-compress" # Enable compression extension; Default: no
+ OPTIONS+="--enable-const-fsts" # Enable all ConstFst classes; Default: no
+ OPTIONS+="--enable-far" # Enable FAR (FST Archive) extension; Default: no
+ OPTIONS+="--enable-linear-fsts" # Enable Linear{Tagger,Classifier}Fst extensions; Default: no
+ OPTIONS+="--enable-lookahead-fsts" # Enable LookAheadFst classes; Default: no
+ OPTIONS+="--enable-mpdt" # Enable MPDT extensions; Default: no
+ OPTIONS+="--enable-ngram-fsts" # Enable NGramFst extensions; Default: no
+ OPTIONS+="--enable-pdt" # Enable PDT extensions; Default: no
+ OPTIONS+="--enable-python PYTHON=python2" # Enable Python extensions; Default: no
LIBS="-ldl" ./configure $OPTIONS
+
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
- install -d "${pkgdir}/etc/ld.so.conf.d/"
- echo '/usr/lib/fst' > "${pkgdir}/etc/ld.so.conf.d/openfst.conf"
+ install -d $pkgdir/etc/ld.so.conf.d/
+ echo /usr/lib/fst > $pkgdir/etc/ld.so.conf.d/openfst.conf
}