aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2019-12-27 20:36:45 -1000
committerGaetan Bisson2019-12-27 20:36:45 -1000
commitdb29ad2d19d31d9c00b7d10cfbed24b19ebf0cfb (patch)
tree6888488882914ab1db64df4ea908b7a907be906e
parent7ca192e6ab1b429ffe80dd92a51f6502c106dcac (diff)
downloadaur-db29ad2d19d31d9c00b7d10cfbed24b19ebf0cfb.tar.gz
overdue commit:
- new qemu syntax - assume zst compression - add some packages kicked out of base - update boot image generation
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rwxr-xr-xarch.build8
-rwxr-xr-xarch.install6
4 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f9dfaefe7a3..b3b8c7086bdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = buildstuff
pkgdesc = Stuff to build packages in virtual machines
- pkgver = 1.6
- pkgrel = 2
+ pkgver = 2.0
+ pkgrel = 1
url = http://arch.vesath.org/
arch = any
license = custom:ISC
@@ -16,8 +16,8 @@ pkgbase = buildstuff
source = arch.install
sha256sums = 6225e9cd7dbd46692d3b3ebde37a182c05863459879e99dbca5b3a4125e5eb1d
sha256sums = acf683446e1162104759b1a75d18859b1a36ac6f3eeabb241025d0e6c37c7960
- sha256sums = 12b438eaa95d48db7a9ff5a2c5e6af542548752e293fca6d824f2437a59fc5f2
- sha256sums = ec9d9974fc65a670754f66aa16b6f64394fbf089685acae32e31d3727263f3ee
+ sha256sums = 5c32ace856a43cfeb83821cab0b4ed83647098bb3a63d57316c939df8517464f
+ sha256sums = 8f33b668ab81dcefd62191c3a01d596d498b8ba1058368dbb1ca2a2a2bf89218
pkgname = buildstuff
diff --git a/PKGBUILD b/PKGBUILD
index 00ea8472c8d8..463d225da5b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
pkgname=buildstuff
-pkgver=1.6
-pkgrel=2
+pkgver=2.0
+pkgrel=1
pkgdesc='Stuff to build packages in virtual machines'
url='http://arch.vesath.org/'
arch=('any')
@@ -25,5 +25,5 @@ package() {
sha256sums=('6225e9cd7dbd46692d3b3ebde37a182c05863459879e99dbca5b3a4125e5eb1d'
'acf683446e1162104759b1a75d18859b1a36ac6f3eeabb241025d0e6c37c7960'
- '12b438eaa95d48db7a9ff5a2c5e6af542548752e293fca6d824f2437a59fc5f2'
- 'ec9d9974fc65a670754f66aa16b6f64394fbf089685acae32e31d3727263f3ee')
+ '5c32ace856a43cfeb83821cab0b4ed83647098bb3a63d57316c939df8517464f'
+ '8f33b668ab81dcefd62191c3a01d596d498b8ba1058368dbb1ca2a2a2bf89218')
diff --git a/arch.build b/arch.build
index 53f937ca78f3..f300436af7dc 100755
--- a/arch.build
+++ b/arch.build
@@ -23,8 +23,8 @@ vhost="
start_vm() {
qemu-system-x86_64 \
- -cpu $cpu -smp 4 -m 4G \
- -accel kvm:tcg,thread=multi \
+ -cpu $cpu -smp 4 -m 2G \
+ -machine accel=kvm:tcg \
-device virtio-net,netdev=vlan \
-netdev user,id=vlan,hostfwd=::$vport-:22 \
-drive file=$1 &
@@ -32,7 +32,7 @@ start_vm() {
ssh $vhost 'curl -o /dev/null -s vesath.org' &&
break
done
- cat /etc/pacman.d/mirrorlist |
+ sed 's/127.0.0.1/10.0.2.2/g' /etc/pacman.d/mirrorlist |
ssh $vhost 'sudo dd of=/etc/pacman.d/mirrorlist'
}
@@ -86,6 +86,6 @@ sftp $vhost <<<"put $HOME/.gnupg/pubring.kbx .gnupg/pubring.kbx"
sftp $vhost <<<'put -r . /build' # fake chroot build for db-update
ssh $vhost 'rm -fr /build/{src,pkg}' # fix source repo relocation
ssh $vhost 'cd /build; makepkg --log --noconfirm --syncdeps'
-sftp $vhost <<<'get /build/*.pkg.tar.xz'
+sftp $vhost <<<'get /build/*.pkg.tar.zst'
sftp $vhost <<<'get /build/*.log'
stop_vm
diff --git a/arch.install b/arch.install
index 862f4dfd7f1d..03381c4c301f 100755
--- a/arch.install
+++ b/arch.install
@@ -32,9 +32,9 @@ pushd ${mnt}
install -d boot
mount ${loop}p1 boot
-setarch ${arch} pacstrap -C /usr/share/devtools/pacman-extra.conf -c . base base-devel pacman-contrib haveged openssh sudo syslinux
-systemctl --root=. enable systemd-{networkd,resolved} haveged sshd
+setarch ${arch} pacstrap -C /usr/share/devtools/pacman-extra.conf -c . base base-devel syslinux mkinitcpio haveged openssh sudo pacman-contrib
+systemctl --root=. enable systemd-{networkd,resolved} haveged sshd
ln -sf ../run/systemd/resolve/resolv.conf etc/resolv.conf
install -d home/user/.ssh
@@ -76,8 +76,8 @@ DHCP=yes
EOF
setarch ${arch} arch-chroot . <<EOF
+sudo pacman --noconfirm -S linux
syslinux-install_update -i -m
-mkinitcpio -p linux
locale-gen
useradd -p 00as1wm0AZG56 user
chown -R user:users /home/user