summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2017-06-06 22:56:04 +0200
committerBruno Pagani2017-06-06 22:56:04 +0200
commitdb849e67c158944b2f778c349b8e6ebb1a984291 (patch)
tree5a012adedce6c600b0239cd72706adbe6d224963
parent38115a8e818cd9e6c829c7ec0099a96b130b357b (diff)
downloadaur-db849e67c158944b2f778c349b8e6ebb1a984291.tar.gz
upgpkg: scribus-devel 1.5.3-1
upstream release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
-rw-r--r--findOpenSSL.patch15
-rw-r--r--fix-qt-5.8-build.patch11
4 files changed, 34 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cb36523c09a..4d87e055348e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scribus-devel
pkgdesc = Desktop publishing software
- pkgver = 1.5.2
- pkgrel = 3
+ pkgver = 1.5.3
+ pkgrel = 1
url = https://www.scribus.net/
arch = i686
arch = x86_64
@@ -18,19 +18,21 @@ pkgbase = scribus-devel
depends = podofo
depends = poppler
depends = python2
- depends = qt5-declarative
+ depends = qt5-base
depends = hicolor-icon-theme
+ depends = harfbuzz-icu
optdepends = tk: scripts based on tkinter
optdepends = hyphen-lang: hyphenation patterns for desired languages
provides = scribus
conflicts = scribus
- source = https://downloads.sourceforge.net/scribus/scribus-1.5.2.tar.xz
- source = https://downloads.sourceforge.net/scribus/scribus-1.5.2.tar.xz.asc
- source = fix-qt-5.8-build.patch
+ source = https://downloads.sourceforge.net/scribus/scribus-1.5.3.tar.xz
+ source = https://downloads.sourceforge.net/scribus/scribus-1.5.3.tar.xz.asc
+ source = findOpenSSL.patch
validpgpkeys = 5086B8D68E70FDDF4C40045AEF7B95E7F60166DA
- sha256sums = ec5eec23aeda655d3a761cffb85853dcd2ede3973b9e62a1b3c28bd1093c74f5
+ validpgpkeys = 757F5E9B13DD648887AD50092D47C099E782504E
+ sha256sums = 73a30b4727e19f5d301a936d23a84275cc4f5613a92416cbd843f5167721d74f
sha256sums = SKIP
- sha256sums = 317e9bc8832b71accd9903cd97d9041cb39cd6afc304196fa2f84a9024dc34b6
+ sha256sums = d6d798a370442026e04d56769848761111d63af2ca69a6c2591233da3703dfb4
pkgname = scribus-devel
diff --git a/PKGBUILD b/PKGBUILD
index 457874fdcf1b..cd00379b2434 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,29 +7,30 @@
_pkgname=scribus
pkgname=${_pkgname}-devel
-pkgver=1.5.2
-pkgrel=3
+pkgver=1.5.3
+pkgrel=1
pkgdesc="Desktop publishing software"
arch=('i686' 'x86_64')
url="https://www.scribus.net/"
license=('GPL')
depends=('hunspell' 'libcdr' 'libmspub' 'libpagemaker' 'libvisio' 'podofo'
- 'poppler' 'python2' 'qt5-declarative' 'hicolor-icon-theme')
+ 'poppler' 'python2' 'qt5-base' 'hicolor-icon-theme' 'harfbuzz-icu')
makedepends=('cmake' 'boost' 'mesa' 'qt5-tools')
optdepends=('tk: scripts based on tkinter'
'hyphen-lang: hyphenation patterns for desired languages')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
source=("https://downloads.sourceforge.net/${_pkgname}/${_pkgname}-${pkgver}.tar.xz"{,.asc}
- "fix-qt-5.8-build.patch")
-sha256sums=('ec5eec23aeda655d3a761cffb85853dcd2ede3973b9e62a1b3c28bd1093c74f5' 'SKIP'
- '317e9bc8832b71accd9903cd97d9041cb39cd6afc304196fa2f84a9024dc34b6')
-validpgpkeys=('5086B8D68E70FDDF4C40045AEF7B95E7F60166DA') # Peter Linnell <plinnell@scribus.net>
+ 'findOpenSSL.patch')
+sha256sums=('73a30b4727e19f5d301a936d23a84275cc4f5613a92416cbd843f5167721d74f' 'SKIP'
+ 'd6d798a370442026e04d56769848761111d63af2ca69a6c2591233da3703dfb4')
+validpgpkeys=('5086B8D68E70FDDF4C40045AEF7B95E7F60166DA' # Peter Linnell <plinnell@scribus.net>
+ '757F5E9B13DD648887AD50092D47C099E782504E') # The Scribus Team (www.scribus.net) <the_scribus_team@scribus.net>
prepare() {
cd ${_pkgname}-${pkgver}
- patch -p1 -i ../fix-qt-5.8-build.patch
+ patch -p1 -i ../findOpenSSL.patch
sed \
-e 's|#!/usr/bin/python|#!/usr/bin/python2|' \
diff --git a/findOpenSSL.patch b/findOpenSSL.patch
new file mode 100644
index 000000000000..c2cb5e9dd58e
--- /dev/null
+++ b/findOpenSSL.patch
@@ -0,0 +1,15 @@
+Description: Fix case of "OpenSSL" to match the case of the file shipped by cmake
+Author: Mattia Rizzolo <mattia@debian.org>
+Last-Update: 2017-06-05
+
+--- a/cmake/modules/FindLIBPODOFO.cmake
++++ b/cmake/modules/FindLIBPODOFO.cmake
+@@ -45,7 +45,7 @@
+ #message(STATUS "PODOFO PATCH VERSION ${PODOFO_PATCH_VER}")
+ set(LIBPODOFO_VERSION "${PODOFO_MAJOR_VER}.${PODOFO_MINOR_VER}.${PODOFO_PATCH_VER}" CACHE STRING "PoDoFo version string")
+ if(LIBPODOFO_VERSION VERSION_GREATER "0.9.4")
+- find_package(OPENSSL)
++ find_package(OpenSSL)
+ if (OPENSSL_FOUND)
+ message("OpenSSL found OK for installed version of PoDoFo (>= 0.9.5) - Enabling support for PDF embedded in AI")
+ set(LIBPODOFO_FOUND TRUE CACHE BOOLEAN "Was libpodofo found")
diff --git a/fix-qt-5.8-build.patch b/fix-qt-5.8-build.patch
deleted file mode 100644
index 275fa95c882f..000000000000
--- a/fix-qt-5.8-build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/scribus/plugins/gettext/xtgim/xtgscanner.cpp
-+++ b/scribus/plugins/gettext/xtgim/xtgscanner.cpp
-@@ -1517,7 +1517,7 @@
- currentParagraphStyle.charStyle().setParent(CommonStrings::DefaultCharacterStyle);
- currentParagraphStyle.setLineSpacingMode(ParagraphStyle::AutomaticLineSpacing);
- currentCharStyle = currentParagraphStyle.charStyle();
-- while (lookAhead() != '\0')
-+ while (lookAhead() != QChar('\0'))
- {
- token = getToken();
- QHash<QString,void (XtgScanner::*)(void)> *temp = NULL;