summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Levesque2022-08-31 22:37:28 -0400
committerNick Levesque2022-08-31 22:37:28 -0400
commitdbe36b35421a6b03e97411c52e5236a69384497a (patch)
treea6304eece584e6dcd8c88a6b978d5deea9c1df91
parent65dc6f64e87b653bb649e396edcb0bd1f1eb4615 (diff)
downloadaur-dbe36b35421a6b03e97411c52e5236a69384497a.tar.gz
update dependencies & point at fwup-home repo
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d2cb0bc19a0..05704fdf3262 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fwup-git
pkgdesc = Configurable embedded Linux firmware update creator and runner (latest from git master)
- pkgver = v1.5.0.r1.gaee4cda
+ pkgver = e8b8629
pkgrel = 1
url = https://github.com/fhunleth/fwup
arch = any
@@ -15,10 +15,11 @@ pkgbase = fwup-git
depends = zip
depends = help2man
depends = autoconf
+ depends = xdelta3
+ depends = dosfstools
provides = fwup
conflicts = fwup
- source = git+https://github.com/fhunleth/fwup
+ source = git+https://github.com/fwup-home/fwup
md5sums = SKIP
pkgname = fwup-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8d58a03ffe46..57d301db3b4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: Nick Levesque <nick.levesque@gmail.com>
# Contributor: Kevin Hanselman <kevin-hanselman@gmail.com>
pkgname=fwup-git
-pkgver=v1.5.0.r1.gaee4cda
+pkgver=e8b8629
pkgrel=1
pkgdesc="Configurable embedded Linux firmware update creator and runner (latest from git master)"
arch=('any')
url="https://github.com/fhunleth/fwup"
license=('Apache v2.0')
groups=()
-#depends=('libsodium' 'libarchive' 'confuse')
-depends=('libsodium' 'libarchive' 'confuse' 'mtools' 'unzip' 'libtool' 'zip' 'help2man' 'autoconf')
+depends=('libsodium' 'libarchive' 'confuse' 'mtools' 'unzip' 'libtool' 'zip' 'help2man' 'autoconf' 'xdelta3' 'dosfstools')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -17,13 +16,13 @@ replaces=()
backup=()
options=()
install=
-source=('git+https://github.com/fhunleth/fwup')
+source=('git+https://github.com/fwup-home/fwup' )
noextract=()
md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+ printf "%s" "$(git rev-parse --short HEAD)"
}
build() {