summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMirco Tischler2017-03-06 23:56:34 +0100
committerMirco Tischler2017-03-06 23:56:34 +0100
commitdc92719dcd96ef911ccde46156067c44061ad889 (patch)
tree82e5d12ace8885f39ebe9d3ab32e95cf39694f3f
parent9714fe0477236e6340455662dfeac168791951f3 (diff)
downloadaur-dc92719dcd96ef911ccde46156067c44061ad889.tar.gz
fwupdate: update to version 9-1
Add one patch needed to get it to compile.
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-uninitialized-variable.patch37
-rw-r--r--PKGBUILD16
3 files changed, 56 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0685afaec299..dbd5e3a0f2e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Feb 11 14:07:05 UTC 2017
+# Mon Mar 6 22:56:22 UTC 2017
pkgbase = fwupdate
pkgdesc = Tools for using the ESRT and UpdateCapsule() to apply firmware updates
- pkgver = 8
- pkgrel = 2
+ pkgver = 9
+ pkgrel = 1
url = https://github.com/rhinstaller/fwupdate
install = fwupdate.install
arch = i686
@@ -14,8 +14,10 @@ pkgbase = fwupdate
depends = efivar
depends = libsmbios
depends = bash
- source = https://github.com/rhinstaller/fwupdate/releases/download/8/fwupdate-8.tar.bz2
- sha256sums = c8120f6ff0378d0f070373b6d46bfcaee18deeaf5a50c65d596c6df866980883
+ source = https://github.com/rhinstaller/fwupdate/releases/download/9/fwupdate-9.tar.bz2
+ source = 0001-Fix-uninitialized-variable.patch
+ sha256sums = e926a7b33a58f5dbf029a5a687375e88b18a41f0742ba871aff7d1d82d075c87
+ sha256sums = 56d27c36b7f1178c818c37153e3dbdd0a26036366b3dc935cd169b0c716cb610
pkgname = fwupdate
diff --git a/0001-Fix-uninitialized-variable.patch b/0001-Fix-uninitialized-variable.patch
new file mode 100644
index 000000000000..815e4e583322
--- /dev/null
+++ b/0001-Fix-uninitialized-variable.patch
@@ -0,0 +1,37 @@
+From a9bfbb4a082c2a7e8917865877976e8008712ca6 Mon Sep 17 00:00:00 2001
+From: Mirco Tischler <mt-ml@gmx.de>
+Date: Mon, 6 Mar 2017 23:45:46 +0100
+Subject: [PATCH] Fix uninitialized variable.
+
+If boot_order_size is 0, i was never set. On gcc-6.3.1, this broke the
+build if compiled with -O2 (-Werror=maybe_uninitialized). This is the
+error:
+
+libfwup.c: In function 'set_up_boot_next':
+libfwup.c:818:16: error: 'i' may be used uninitialized in this function [-Werror=maybe-uninitialized]
+ new_boot_order[i] = boot_entry;
+ ^
+libfwup.c:780:15: note: 'i' was declared here
+ unsigned int i;
+ ^
+cc1: all warnings being treated as errors
+---
+ linux/libfwup.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/linux/libfwup.c b/linux/libfwup.c
+index fe4ece4..2cc03c0 100644
+--- a/linux/libfwup.c
++++ b/linux/libfwup.c
+@@ -777,7 +777,7 @@ add_to_boot_order(uint16_t boot_entry)
+ size_t boot_order_size = 0;
+ uint32_t attr;
+ int rc;
+- unsigned int i;
++ unsigned int i = 0;
+
+ rc = efi_get_variable_size(efi_guid_global, "BootOrder",
+ &boot_order_size);
+--
+2.12.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 2fafc0b037a1..e29bbd34330b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,27 @@
# Maintainer: Mirco Tischler <mt-ml at gmx dot de>
pkgname=fwupdate
-pkgver=8
-pkgrel=2
+pkgver=9
+pkgrel=1
pkgdesc='Tools for using the ESRT and UpdateCapsule() to apply firmware updates'
arch=('i686' 'x86_64')
url='https://github.com/rhinstaller/fwupdate'
license=('GPL2')
depends=('efivar' 'libsmbios' 'bash')
makedepends=('pesign' 'gnu-efi-libs')
-source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('c8120f6ff0378d0f070373b6d46bfcaee18deeaf5a50c65d596c6df866980883')
+source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+ "0001-Fix-uninitialized-variable.patch")
+sha256sums=('e926a7b33a58f5dbf029a5a687375e88b18a41f0742ba871aff7d1d82d075c87'
+ '56d27c36b7f1178c818c37153e3dbdd0a26036366b3dc935cd169b0c716cb610')
install=fwupdate.install
_efidir=arch
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < "${srcdir}/${source[1]}"
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -32,4 +39,5 @@ package() {
rm -rf ${pkgdir}/boot
rm -rf ${pkgdir}/usr/src
rm -rf ${pkgdir}/usr/lib/debug
+ rmdir ${pkgdir}/usr/share/fwupdate
}