summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikołaj "D1SoveR" Banasik2021-11-04 10:08:42 +0000
committerMikołaj "D1SoveR" Banasik2021-11-04 10:08:42 +0000
commitdca5a1d8303035592931086a17ed619bea27979d (patch)
tree9293c8febd3265a39f90bb4ada0f6ea990c8a1b8
parente855b5b26dadbf08a2582276b129a9ea5a60dc86 (diff)
downloadaur-dca5a1d8303035592931086a17ed619bea27979d.tar.gz
Testing reproducible builds again.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--reproducible-build.patch20
3 files changed, 27 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e446e6e620da..584627663707 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxtorpeda-git
pkgdesc = Steam Play compatibility tool to run games using native Linux engines
pkgver = 45.0.0.r320.5f2e835
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/luxtorpeda-dev/luxtorpeda
arch = x86_64
arch = i686
@@ -15,8 +15,10 @@ pkgbase = luxtorpeda-git
provides = luxtorpeda
conflicts = luxtorpeda
source = git+https://github.com/luxtorpeda-dev/luxtorpeda.git
+ source = reproducible-build.patch
source = size-optimisations.patch
sha256sums = SKIP
+ sha256sums = e97cf95dedcf60c97edb3a693052964e4ce6da795631ca5c9f04182462f67895
sha256sums = 1aea00fecd857e8d7b8a3d4c3a5d2f9ef18007bb9366461b4f16878d64a7bf40
pkgname = luxtorpeda-git
diff --git a/PKGBUILD b/PKGBUILD
index 1f32e6089975..bd6c535cf103 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mikołaj "D1SoveR" Banasik <d1sover@gmail.com>
pkgname='luxtorpeda-git'
pkgver=45.0.0.r320.5f2e835
-pkgrel=1
+pkgrel=2
pkgdesc='Steam Play compatibility tool to run games using native Linux engines'
arch=('x86_64' 'i686')
url='https://github.com/luxtorpeda-dev/luxtorpeda'
@@ -13,8 +13,10 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+${url}.git"
+ 'reproducible-build.patch'
'size-optimisations.patch')
sha256sums=('SKIP'
+ 'e97cf95dedcf60c97edb3a693052964e4ce6da795631ca5c9f04182462f67895'
'1aea00fecd857e8d7b8a3d4c3a5d2f9ef18007bb9366461b4f16878d64a7bf40')
pkgver() {
@@ -27,6 +29,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
+ patch -Np1 -i "$srcdir/reproducible-build.patch"
patch -Np1 -i "$srcdir/size-optimisations.patch"
}
diff --git a/reproducible-build.patch b/reproducible-build.patch
new file mode 100644
index 000000000000..1ec6caeec3ea
--- /dev/null
+++ b/reproducible-build.patch
@@ -0,0 +1,20 @@
+diff --git a/Makefile b/Makefile
+index 475c85b..2800d44 100644
+--- a/Makefile
++++ b/Makefile
+@@ -37,13 +37,13 @@ build:
+ cargo build
+
+ release:
+- cargo build --release
++ cargo build --release --locked
+
+ lint:
+ cargo clippy -- -D warnings
+
+ test:
+- cargo test
++ cargo test --release --locked
+
+ clean:
+ cargo clean