summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-09-08 17:23:30 -0500
committerHurricanePootis2023-09-08 17:23:30 -0500
commitdcc9e965f26424a7915c793811c57b4a6923f375 (patch)
tree97fc23048549f437bff854fab36cf195c5ee465e
parentb2376037510b7afb60b87eb85a64a9d0bc660926 (diff)
downloadaur-dcc9e965f26424a7915c793811c57b4a6923f375.tar.gz
Update cmake flags and add new submodule thingy
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7934450d4db5..1c587a4ba391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r9737.66404a669
+ pkgver = r9765.3e254d01e
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index a755181ee1d3..2207451a3c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r9737.66404a669
+pkgver=r9765.3e254d01e
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -120,6 +120,10 @@ prepare() {
git config --file=.gitmodules submodule.externals/SPIRV-Headers.url "$srcdir/SPIRV-Headers"
git -c protocol.file.allow=always submodule update --init
+ cd "$srcdir/$_pkgbase/externals/dynarmic/externals/zydis"
+ git config --file=.gitmodules submodule.dependencies/zycore.url "$srcdir/zycore"
+ git -c protocol.file.allow=always submodule update --init
+
}
@@ -146,8 +150,6 @@ build() {
-DCITRA_ENABLE_COMPATIBILITY_REPORTING=ON \
-DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
-DUSE_DISCORD_PRESENCE=ON \
- -DENABLE_FFMPEG_VIDEO_DUMPER=ON \
- -DENABLE_FFMPEG_AUDIO_DECODER=ON \
-DUSE_SYSTEM_BOOST=OFF \
-DUSE_SYSTEM_SDL2=ON \
-DCMAKE_C_COMPILER=gcc \