summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsatcom8862020-06-29 23:08:53 +0200
committersatcom8862020-06-29 23:08:53 +0200
commitded128788d83e88c344f264e6065379bfa17bfe4 (patch)
tree7df2379bf2510474345282324709566e27526aed
parentd098ece6ab6c89b8c67e158fe3e94815dbb5bbb2 (diff)
downloadaur-ded128788d83e88c344f264e6065379bfa17bfe4.tar.gz
Changed to git and hopefully made it work properly
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
-rw-r--r--VC4CL.icd1
-rw-r--r--auto_dummy.patch12
4 files changed, 20 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c98b6015fec..a4cbb0706ab6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = vc4cl-git
pkgdesc = VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU.
- pkgver = 1
- pkgrel = 3
+ pkgver = 0
+ pkgrel = 4
url = https://github.com/doe300/VC4CL
arch = any
license = MIT
makedepends = make
- makedepends = wget
+ makedepends = git
makedepends = gcc
makedepends = cmake
- makedepends = clang
+ makedepends = llvm
makedepends = opencl-headers
- depends = llvm
+ depends = clang
depends = clinfo
depends = ocl-icd
depends = vc4c-git
@@ -20,7 +20,9 @@ pkgbase = vc4cl-git
provides = opencl-driver
provides = vc4-opencl
provides = vc4cl
- source = VC4CL.tar.gz::https://github.com/doe300/VC4CL/archive/master.tar.gz
+ source = VC4CL::git+https://github.com/doe300/VC4CL
+ source = VC4CL.icd
+ md5sums = SKIP
md5sums = SKIP
pkgname = vc4cl-git
diff --git a/PKGBUILD b/PKGBUILD
index c5494e89450b..fca19d38afe2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: satcom886 <rostik.medved@gmail.com>
pkgname=vc4cl-git
-pkgver=1
-pkgrel=3
+pkgver=0
+pkgrel=4
pkgdesc="VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU."
arch=('any')
url="https://github.com/doe300/VC4CL"
license=('MIT')
groups=()
-depends=('llvm' 'clinfo' 'ocl-icd' 'vc4c-git')
-makedepends=('make' 'wget' 'gcc' 'cmake' 'clang' 'opencl-headers')
+depends=('clang' 'clinfo' 'ocl-icd' 'vc4c-git')
+makedepends=('make' 'git' 'gcc' 'cmake' 'llvm' 'opencl-headers')
optdepends=()
provides=('opencl-pi' 'opencl-vc4' 'opencl-driver' 'vc4-opencl' 'vc4cl')
-source=("VC4CL.tar.gz::https://github.com/doe300/VC4CL/archive/master.tar.gz")
-md5sums=('SKIP')
+source=("VC4CL::git+https://github.com/doe300/VC4CL" "VC4CL.icd")
+md5sums=('SKIP' 'SKIP')
build() {
- mkdir -p $srcdir/VC4CL-master/build
- cd $srcdir/VC4CL-master/build
- cmake "$srcdir/VC4CL-master" -DCMAKE_BUILD_TYPE=Release -DMULTI_THREADED=true -DCLANG_FOUND=/usr/bin/clang -DVC4CL_STDLIB_DIR=/usr/local/include/vc4cl-stdlib
+ mkdir -p $srcdir/VC4CL/build
+ cd $srcdir/VC4CL/build
+ cmake "$srcdir/VC4CL" -DCMAKE_BUILD_TYPE=Release -DMULTI_THREADED=true -DCLANG_FOUND=/usr/bin/clang -DVC4CL_STDLIB_DIR=/usr/local/include/vc4cl-stdlib
make
}
package() {
- cd $srcdir/VC4CL-master/build
+ install -m 644 "$srcdir/VC4CL.icd" $pkgdir/etc/OpenCL/vendors/
+ cd $srcdir/VC4CL/build
make DESTDIR="$pkgdir"/ install
}
diff --git a/VC4CL.icd b/VC4CL.icd
new file mode 100644
index 000000000000..2b723f5ddf22
--- /dev/null
+++ b/VC4CL.icd
@@ -0,0 +1 @@
+/usr/lib/ \ No newline at end of file
diff --git a/auto_dummy.patch b/auto_dummy.patch
deleted file mode 100644
index fce18d1d464b..000000000000
--- a/auto_dummy.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- ProcessUtil.cpp 2020-06-21 22:41:53.008149222 +0200
-+++ ProcessUtil.cpp.bak 2020-06-21 22:40:22.793443863 +0200
-@@ -247,8 +247,7 @@
- {
- in.read(buffer.data(), buffer.size());
- numBytes = in.gcount();
-- auto dummy = write(pipes[STD_IN][WRITE], buffer.data(), static_cast<std::size_t>(in.gcount()));
-- (void)dummy;
-+ write(pipes[STD_IN][WRITE], buffer.data(), static_cast<std::size_t>(in.gcount()));
- if(numBytes != buffer.size())
- break;
- }