summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristophe LAVIE2021-06-30 11:47:44 +0200
committerChristophe LAVIE2021-06-30 11:47:44 +0200
commitdedcccf345f2b12ab3b5ee8217a616e9a1ada682 (patch)
tree4a8a0b1a49f2ac4dba1ae6283318fd4e27253016
parenteb0e226f1d764d8ba831c072c2af078d356f3c67 (diff)
downloadaur-dedcccf345f2b12ab3b5ee8217a616e9a1ada682.tar.gz
version 5.1.6.2-2 : dependencies update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef4aa4b99086..dde99e9ec7c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = devolo-dlan-cockpit
pkgdesc = Display and configure settings of your devolo device
pkgver = 5.1.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.devolo.com/support/downloads/download/devolo-cockpit.html
install = devolo-dlan-cockpit.install
arch = i686
arch = x86_64
license = nonfree
- depends = lib32-glibc
- depends = gtk2
- depends = libgnome-keyring
+ depends = lib32-gtk2
+ depends = lib32-curl
+ depends = lib32-libxt
+ depends = lib32-libxslt
+ depends = lib32-nss
source = https://www.devolo.fr/fileadmin/Web-Content/DE/products/hnw/devolo-cockpit/software/devolo-cockpit-v5-1-6-2-linux.run
source = devolonetsvc.service
sha256sums = 026f79c688ef68a75ced4b76269f5dd6c99d0929a78465937a9be9ad7f529049
diff --git a/PKGBUILD b/PKGBUILD
index 6f28f2abfc4a..fcd70547aa3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Christophe LAVIE <christophe.lavie@laposte.net>
-# Contributor: Christophe LAVIE <christophe.lavie@laposte.net> 29/06/2021
+# Contributor: Christophe LAVIE <christophe.lavie@laposte.net> 30/06/2021
pkgname=devolo-dlan-cockpit
pkgver=5.1.6.2
-pkgrel=1
-name=devolo-cockpit-v${pkgver//./-}-linux.run
+pkgrel=2
+_name=devolo-cockpit-v${pkgver//./-}-linux.run
install=${pkgname}.install
pkgdesc="Display and configure settings of your devolo device"
arch=('i686' 'x86_64')
url="https://www.devolo.com/support/downloads/download/devolo-cockpit.html"
license=('nonfree')
-depends=( 'lib32-glibc' 'gtk2' 'libgnome-keyring')
+depends=( 'lib32-gtk2' 'lib32-curl' 'lib32-libxt' 'lib32-libxslt' 'lib32-nss' )
if [ "${CARCH}" = "x86_64" ]; then
_arch="amd64"
@@ -19,12 +19,12 @@ else
_arch="i386"
fi
-source=("https://www.devolo.fr/fileadmin/Web-Content/DE/products/hnw/devolo-cockpit/software/$name" 'devolonetsvc.service')
+source=("https://www.devolo.fr/fileadmin/Web-Content/DE/products/hnw/devolo-cockpit/software/$_name" 'devolonetsvc.service')
build() {
cd $srcdir
- skip=$(grep -a -m1 -n "HERE_BE_DRAG[O]NS" $name | cut -d: -f1)
- tail $name -n +$((skip+1)) | tar -x -C .
+ skip=$(grep -a -m1 -n "HERE_BE_DRAG[O]NS" $_name | cut -d: -f1)
+ tail $_name -n +$((skip+1)) | tar -x -C .
ar x "devolo-dlan-cockpit_${pkgver}-0_${_arch}.deb"
find . -name "adobeair*${_arch}.deb" -print | xargs ar x
tar xJf data.tar.xz