summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2023-08-06 11:15:09 +0200
committerMagnus Boman2023-08-06 11:15:09 +0200
commitdf6238679b36d5448a3c75f4afba5963ec599150 (patch)
tree13090edecb7c53c8f525781cc4bda22786e80f2e
parentfd40d9c68a3064844a001bf96c21b618964bffc9 (diff)
downloadaur-df6238679b36d5448a3c75f4afba5963ec599150.tar.gz
upgpkg: ffmpeg-headless 1:6.0-2
Fix build and sync with repos
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 624d266bcfaf..bd60198e761b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-headless
pkgdesc = Complete solution to record, convert and stream audio and video; optimised for server (headless) systems
pkgver = 6.0
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://ffmpeg.org/
arch = i686
@@ -35,8 +35,10 @@ pkgbase = ffmpeg-headless
depends = libdrm
depends = libfreetype.so
depends = libiec61883
+ depends = libjxl.so
depends = libmfx
depends = libmodplug
+ depends = libopenmpt.so
depends = librav1e.so
depends = libraw1394
depends = librsvg-2.so
@@ -49,7 +51,6 @@ pkgbase = ffmpeg-headless
depends = libvorbis.so
depends = libvorbisenc.so
depends = libvpx.so
- depends = libvulkan.so
depends = libwebp
depends = libx264.so
depends = libx265.so
@@ -65,6 +66,7 @@ pkgbase = ffmpeg-headless
depends = svt-av1
depends = v4l-utils
depends = vmaf
+ depends = vulkan-icd-loader
depends = xz
depends = zlib
optdepends = avisynthplus: AviSynthPlus support
diff --git a/PKGBUILD b/PKGBUILD
index 79215de24d92..89b1d64b4239 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=ffmpeg-headless
pkgver=6.0
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video; optimised for server (headless) systems'
arch=(i686 x86_64 armv7h armv6h aarch64)
@@ -30,8 +30,10 @@ depends=(
libdrm
libfreetype.so
libiec61883
+ libjxl.so
libmfx
libmodplug
+ libopenmpt.so
librav1e.so
libraw1394
librsvg-2.so
@@ -44,7 +46,6 @@ depends=(
libvorbis.so
libvorbisenc.so
libvpx.so
- libvulkan.so
libwebp
libx264.so
libx265.so
@@ -60,6 +61,7 @@ depends=(
svt-av1
v4l-utils
vmaf
+ vulkan-icd-loader
xz
zlib
)
@@ -100,6 +102,10 @@ pkgver() {
git -C "${pkgname%-headless}" describe --tags | sed 's/^n//'
}
+prepare() {
+ git -C "${pkgname%-headless}" cherry-pick -n effadce6c756247ea8bae32dc13bb3e6f464f0eb # Fix assembling with binutil as >= 2.41
+}
+
build() {
cd ${pkgname%-headless}
./configure \
@@ -127,12 +133,14 @@ build() {
--enable-libgsm \
--enable-libiec61883 \
--disable-libjack \
+ --enable-libjxl \
--enable-libmfx \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
--enable-libopencore_amrwb \
--enable-libopenjpeg \
+ --enable-libopenmpt \
--enable-libopus \
--disable-libpulse \
--enable-librav1e \