aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorremspoor2016-10-17 00:40:47 +0200
committerremspoor2016-10-17 00:40:47 +0200
commitdf71dd3a28e32bcd96945697f3b29d09f60fca92 (patch)
tree689f5ea44c3c12952543b4baa84381b3bdfdd70d
downloadaur-df71dd3a28e32bcd96945697f3b29d09f60fca92.tar.gz
Initial commit of package next
- Added all needed files to build package neXt, a helicopter simulation program made by CGM: http://www.rc-aerobatics.eu/index_e.html - Added *.xz (built package) to .gitignore
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD139
-rw-r--r--README.md2
-rw-r--r--next-128x128.pngbin0 -> 12194 bytes
-rw-r--r--next-16x16.pngbin0 -> 782 bytes
-rw-r--r--next-192x192.pngbin0 -> 19040 bytes
-rw-r--r--next-24x24.pngbin0 -> 1286 bytes
-rw-r--r--next-256x256.pngbin0 -> 30626 bytes
-rw-r--r--next-32x32.pngbin0 -> 1812 bytes
-rw-r--r--next-48x48.pngbin0 -> 3148 bytes
-rw-r--r--next-64x64.pngbin0 -> 3875 bytes
-rw-r--r--next-96x96.pngbin0 -> 7086 bytes
-rw-r--r--next.LICENSE1
-rw-r--r--next.changelog2
15 files changed, 191 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68f9e1c93b69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = next
+ pkgdesc = CGM rc Heli Flight Simulator
+ pkgver = 1.452
+ pkgrel = 1
+ url = http://www.rc-aerobatics.eu/index_e.html
+ changelog = next.changelog
+ arch = i686
+ arch = x86_64
+ license = custom
+ optdepends = joyutils: jscal, jstest, and jsattach utilities for the Linux joystick driver
+ source = http://www.cgm-online.com/secure_rc-heli-simulator/cgm-rc-heli-simulator-linux-x86-64bit.zip
+ source = next-16x16.png
+ source = next-24x24.png
+ source = next-32x32.png
+ source = next-48x48.png
+ source = next-64x64.png
+ source = next-96x96.png
+ source = next-128x128.png
+ source = next-192x192.png
+ source = next-256x256.png
+ sha256sums = 86940505aa81c0e15e679f214278b70281c533f5618537fdeda7e2af55769d60
+ sha256sums = da75a4813dfbdeb9741baf4308799732b541bab8e7628578692a89d9ff2425dd
+ sha256sums = 15e2c9a76e1900196ca8179a0a218cc8c4abd5c214960d4772e6bbf70ab45d49
+ sha256sums = 22d503b69eccea1e276b94657d9131de56486767e87f362d729366a025ef1bc8
+ sha256sums = d294ce00828ebee8c9734ab5daf343117116603f091cd62d14e23ea8787c17af
+ sha256sums = 946ecde0fb126a047ce6784714ac094b01431a57b7e2ea69217d337e2b30841e
+ sha256sums = 5bb17db20c71f6c7d026d68df6c7ab57ad768d0b44bb3e52fba678f856716611
+ sha256sums = c3ca268d88ff1ecdf20aa2aecd5bde8f5bb115af4b2e01e108c921edc5e93d49
+ sha256sums = 473c48dd726c64f4252ecb9e360b79a9e7a2fa1951d3cf52208b29e00426f4eb
+ sha256sums = db7b807ec1cb84a5d6c575eb263affd14c3ae72800a73d0571358f378b60a2e2
+
+pkgname = next
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..34e57ba2ec3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+*.xz
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..318f1137fbab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,139 @@
+# Maintainer: Rinus Remspoor <remspoor AT linuxmail DOT org>
+
+pkgname=next
+pkgver=1.452
+pkgrel=3
+pkgdesc="CGM rc Heli Flight Simulator"
+arch=('i686' 'x86_64')
+url="http://www.rc-aerobatics.eu/index_e.html"
+license=('custom')
+groups=()
+backup=()
+options=()
+install=
+changelog=${pkgname}.changelog
+#makedepends=( 'gendesk')
+depends=()
+optdepends=( 'joyutils: jscal, jstest, and jsattach utilities for the Linux joystick driver')
+source=( 'http://www.cgm-online.com/secure_rc-heli-simulator/cgm-rc-heli-simulator-linux-x86-64bit.zip'
+
+ 'next-16x16.png'
+ 'next-24x24.png'
+ 'next-32x32.png'
+ 'next-48x48.png'
+ 'next-64x64.png'
+ 'next-96x96.png'
+ 'next-128x128.png'
+ 'next-192x192.png'
+ 'next-256x256.png'
+ 'LICENSE')
+
+sha256sums=( '86940505aa81c0e15e679f214278b70281c533f5618537fdeda7e2af55769d60'
+
+ 'da75a4813dfbdeb9741baf4308799732b541bab8e7628578692a89d9ff2425dd'
+ '15e2c9a76e1900196ca8179a0a218cc8c4abd5c214960d4772e6bbf70ab45d49'
+ '22d503b69eccea1e276b94657d9131de56486767e87f362d729366a025ef1bc8'
+ 'd294ce00828ebee8c9734ab5daf343117116603f091cd62d14e23ea8787c17af'
+ '946ecde0fb126a047ce6784714ac094b01431a57b7e2ea69217d337e2b30841e'
+ '5bb17db20c71f6c7d026d68df6c7ab57ad768d0b44bb3e52fba678f856716611'
+ 'c3ca268d88ff1ecdf20aa2aecd5bde8f5bb115af4b2e01e108c921edc5e93d49'
+ '473c48dd726c64f4252ecb9e360b79a9e7a2fa1951d3cf52208b29e00426f4eb'
+ 'db7b807ec1cb84a5d6c575eb263affd14c3ae72800a73d0571358f378b60a2e2'
+ 'febb1e65a7932f2f80155078b1dd64f469433625c76cff43b239768a184729f0')
+
+_DEST_PREFIX="/opt/${pkgname}"
+
+prepare() {
+ # rename the original directory to something sane and remove an OSX directory
+ mv "Linux x86+64bit" "${pkgname}"
+ rm -r "__MACOSX"
+
+ cd "${pkgname}"
+
+ # Remove unneeded and platform dependent files
+ msg2 "Removing unneeded files..."
+ find . -name '.DS_Store' -exec rm {} \;
+
+ if [ "${CARCH}" == 'i686' ]; then
+ rm -r ./neXt_Data/Mono/x86_64
+ rm -r ./neXt_Data/Plugins/x86_64
+ rm ./neXt.x86_64
+ fi
+ if [ "${CARCH}" == "x86_64" ]; then
+ rm -r ./neXt_Data/Mono/x86
+ rm -r ./neXt_Data/Plugins/x86
+ rm ./neXt.x86
+ fi
+
+ msg2 "Creating .desktop file..."
+ #gendesk --pkgname "${pkgname}-test" --pkgdesc "${pkgdesc}" -n
+
+ if [ "${CARCH}" == 'i686' ]; then
+ cat > "${srcdir}"/${pkgname}.desktop << EOF
+[Desktop Entry]
+Encoding=UTF-8
+Name=neXt
+Version=1.0
+GenericName=A helicopter flight simulator made by CGM
+Comment=${pkgdesc}
+Exec=/opt/${pkgname}/neXt.x86
+Terminal=false
+Icon=/usr/share/icons/hicolor/96x96/apps/next.png
+#Icon=${pkgname}
+Type=Application
+StartupNotify=false
+Categories=Education;
+Keywords=simulator;rc;helicopter
+EOF
+ fi
+ if [ "${CARCH}" == "x86_64" ]; then
+ cat > "${srcdir}"/${pkgname}.desktop << EOF
+[Desktop Entry]
+Encoding=UTF-8
+Name=neXt
+Version=1.0
+GenericName=A helicopter flight simulator made by CGM
+Comment=${pkgdesc}
+Exec=/opt/${pkgname}/neXt.x86_64
+Terminal=false
+Icon=/usr/share/icons/hicolor/96x96/apps/next.png
+#Icon=${pkgname}
+Type=Application
+StartupNotify=false
+Categories=Education;
+Keywords=simulator;rc;helicopter
+EOF
+ fi
+}
+
+#build() {
+#
+#}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ # Install files to ${pkgdir}
+ install -dm755 "${pkgdir}${_DEST_PREFIX}"
+
+ msg2 "Copying files to package directory..."
+ cp -dr --no-preserve=ownership . ${pkgdir}/${_DEST_PREFIX}
+
+ msg2 "Copying icon files to package directory..."
+ cd ${srcdir}
+ # Find all files with extension .png, extract the icon size and install into the right directory
+ for i in *.png; do
+ # Bad hack, could this be done in one line?
+ ii="${i##*-}"
+ iconsize="${ii%.*}"
+ iconext="${i##*.}"
+ iconname="${i%%-*}"
+ install -Dm644 ${i} "${pkgdir}/usr/share/icons/hicolor/${iconsize}/apps/${iconname}.${iconext}"
+ done
+
+ msg2 "Installing .desktop file..."
+ install -Dm644 "${srcdir}"/${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Install license file, can't find one right now, maybe ask the author of the software later.
+ install -Dm644 ${pkgname}.LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..7928cf6ae678
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# aur-next
+Arch linux AUR package: next
diff --git a/next-128x128.png b/next-128x128.png
new file mode 100644
index 000000000000..23c92f3c3d20
--- /dev/null
+++ b/next-128x128.png
Binary files differ
diff --git a/next-16x16.png b/next-16x16.png
new file mode 100644
index 000000000000..9c1ad5291e42
--- /dev/null
+++ b/next-16x16.png
Binary files differ
diff --git a/next-192x192.png b/next-192x192.png
new file mode 100644
index 000000000000..af0f66de65ec
--- /dev/null
+++ b/next-192x192.png
Binary files differ
diff --git a/next-24x24.png b/next-24x24.png
new file mode 100644
index 000000000000..4cd0e2105f04
--- /dev/null
+++ b/next-24x24.png
Binary files differ
diff --git a/next-256x256.png b/next-256x256.png
new file mode 100644
index 000000000000..d6892cfa667b
--- /dev/null
+++ b/next-256x256.png
Binary files differ
diff --git a/next-32x32.png b/next-32x32.png
new file mode 100644
index 000000000000..038fa3acb9af
--- /dev/null
+++ b/next-32x32.png
Binary files differ
diff --git a/next-48x48.png b/next-48x48.png
new file mode 100644
index 000000000000..d01f47673ded
--- /dev/null
+++ b/next-48x48.png
Binary files differ
diff --git a/next-64x64.png b/next-64x64.png
new file mode 100644
index 000000000000..b8432bd1dbed
--- /dev/null
+++ b/next-64x64.png
Binary files differ
diff --git a/next-96x96.png b/next-96x96.png
new file mode 100644
index 000000000000..32aba062342c
--- /dev/null
+++ b/next-96x96.png
Binary files differ
diff --git a/next.LICENSE b/next.LICENSE
new file mode 100644
index 000000000000..9985e1114636
--- /dev/null
+++ b/next.LICENSE
@@ -0,0 +1 @@
+License unknown, please point me in the right direction
diff --git a/next.changelog b/next.changelog
new file mode 100644
index 000000000000..28f96fd42cb4
--- /dev/null
+++ b/next.changelog
@@ -0,0 +1,2 @@
+20161015: remspoor AT linuxmail DOT org
+ Initial package created