summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordreieck2023-03-10 13:11:03 +0100
committerdreieck2023-03-10 13:11:03 +0100
commite0a9329cb2ab83a440d82d781d073a497131934e (patch)
treeca544347597db341baab7d48d3869251fba410de
parenta5225e6af86da609e5fc6b5abf336d27a0b2e44a (diff)
downloadaur-e0a9329cb2ab83a440d82d781d073a497131934e.tar.gz
* Fixed upstream source location: Now works again.
* Updated `pkgver()` to contain official version * updated license extraction script to include "BSD-2-Clause". * Specified custom license to be "BSD".
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a1a9be864f0..538d25136b1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = arandr-indicator-git
pkgdesc = Quick and simple tray icon menu for changing the monitor layout.
- pkgver = r16.20200824.189890e
- pkgrel = 6
+ pkgver = 2.0.0+11.r26.20220728.aac95e3
+ pkgrel = 1
epoch = 2
- url = https://github.com/AdrianVollmer/arandr-indicator/tree/port-python3
+ url = https://github.com/denilsonsa/arandr-indicator
arch = any
- license = custom
+ license = custom: BSD
makedepends = git
depends = pygtk
depends = python>=3
depends = python-gobject
optdepends = arandr: To configure monitor layouts.
optdepends = python-xdg: For Freedesktop.org directory specifications.
- provides = arandr-indicator=r16.20200824.189890e
+ provides = arandr-indicator=2.0.0+11.r26.20220728.aac95e3
conflicts = arandr-indicator
- source = arandr-indicator::git+https://github.com/AdrianVollmer/arandr-indicator#branch=port-python3
+ source = arandr-indicator::git+https://github.com/denilsonsa/arandr-indicator.git
source = license-info.txt
sha256sums = SKIP
sha256sums = e4f6da5d674b36b60640901d1a01a5deec77fd41ef31f713b1fc533c25d14f6d
diff --git a/PKGBUILD b/PKGBUILD
index 474197c3ebd8..79ef5f7c4401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,12 @@
_pkgname=arandr-indicator
pkgname="${_pkgname}-git"
epoch=2
-pkgver=r16.20200824.189890e
-pkgrel=6
+pkgver=2.0.0+11.r26.20220728.aac95e3
+pkgrel=1
pkgdesc="Quick and simple tray icon menu for changing the monitor layout."
arch=('any')
-# url="https://github.com/denilsonsa/arandr-indicator" # original project (Python 2)
-url="https://github.com/AdrianVollmer/arandr-indicator/tree/port-python3" # Python 3 port
-license=('custom')
+url="https://github.com/denilsonsa/arandr-indicator" # original project
+license=('custom: BSD')
depends=(
'pygtk'
'python>=3'
@@ -25,8 +24,7 @@ provides=("${_pkgname}=${pkgver}")
replaces=()
conflicts=("${_pkgname}")
source=(
- # "${_pkgname}::git+https://github.com/denilsonsa/arandr-indicator.git" # original project (Python 2)
- "${_pkgname}::git+https://github.com/AdrianVollmer/arandr-indicator#branch=port-python3" # Python 3 port
+ "${_pkgname}::git+https://github.com/denilsonsa/arandr-indicator.git" # original project (Python 2)
'license-info.txt'
)
sha256sums=(
@@ -37,20 +35,21 @@ sha256sums=(
prepare() {
cd "${srcdir}/${_pkgname}"
msg2 "Extract copyright information, building license.txt ..."
- cat arandr-indicator.py | tr -d '\a' | tr '\n' '\a' | sed 's|^.*\(# Copyright.*$\)|\1|g' | sed 's|\a[^#][^\a]*.*$|\a|g' | tr '\a' '\n' > "${srcdir}/license.txt"
+ cat arandr-indicator.py | tr -d '\a' | tr '\n' '\a' | sed 's|^.*\(# BSD-2-Clause.*$\)|\1|g' | sed 's|\a[^#][^\a]*.*$|\a|g' | tr '\a' '\n' > "${srcdir}/license.txt"
}
pkgver () {
cd "${srcdir}/${_pkgname}"
+ _ver="$(git describe --tags | sed -E -e 's|^[vV]||' -e 's|\-g[0-9a-f]*$||' | tr '-' '+')"
_rev="$(git rev-list --count HEAD)"
_date="$(git log -1 --date=format:"%Y%m%d" --format="%ad")"
_hash="$(git rev-parse --short HEAD)"
- if [ -z "${_rev}" ]; then
- error "Commit count could not be determined."
+ if [ -z "${_ver}" ]; then
+ error "Version could not be determined."
return 1
else
- printf '%s' "r${_rev}.${_date}.${_hash}"
+ printf '%s' "${_ver}.r${_rev}.${_date}.${_hash}"
fi
}
@@ -58,6 +57,7 @@ package() {
cd "${srcdir}/${_pkgname}"
install -Dvm755 "${_pkgname}.py" "${pkgdir}/usr/bin/${_pkgname}"
install -Dvm644 README.md "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -Dvm644 TODO.md "${pkgdir}/usr/share/doc/${_pkgname}/TODO.md"
install -Dvm644 "${srcdir}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
install -Dvm644 "${srcdir}/license-info.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license-info.txt"
}