summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-12-18 18:31:02 +0100
committerFabioLolix2020-12-18 18:31:02 +0100
commite1088cab3aba8033d2fa1fc41a5dde863a60bf22 (patch)
treeee6fbb345860d19af77bcd9465efa674aa4f4e5f
parent101c866541cd2681bed522550a3dd6f6d8209b2f (diff)
downloadaur-e1088cab3aba8033d2fa1fc41a5dde863a60bf22.tar.gz
revision
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD53
2 files changed, 35 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 059c91fb7bc3..9bd25ba10c38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu Dec 1 22:24:42 UTC 2016
pkgbase = opendht-git
- pkgdesc = A C++11 implementation of the Kademlia DHT (Distributed Hash Table)
- pkgver = 20161110
+ pkgdesc = C++14 implementation of the Kademlia DHT (Distributed Hash Table)
+ pkgver = 2.1.9.5.r1.ga77dc855
pkgrel = 1
+ epoch = 1
url = https://github.com/savoirfairelinux/opendht
- arch = i686
arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL3
makedepends = git
makedepends = msgpack-c
@@ -15,6 +19,9 @@ pkgbase = opendht-git
depends = gnutls
depends = nettle
depends = readline
+ depends = asio
+ depends = jsoncpp
+ depends = argon2
optdepends = python: to use the Python bindings
provides = opendht
conflicts = opendht
diff --git a/PKGBUILD b/PKGBUILD
index e17d729714f5..faae2419b796 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,35 @@
-# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
pkgname=opendht-git
-pkgver=20161110
+pkgver=2.1.9.5.r1.ga77dc855
pkgrel=1
-pkgdesc="A C++11 implementation of the Kademlia DHT (Distributed Hash Table)"
-arch=('i686' 'x86_64')
-depends=('gnutls' 'nettle' 'readline')
-makedepends=('git' 'msgpack-c' 'cmake' 'cython')
-optdepends=('python: to use the Python bindings')
+epoch=1
+pkgdesc="C++14 implementation of the Kademlia DHT (Distributed Hash Table)"
+arch=(x86_64 i686 pentium4 arm armv6h armv7h aarch64)
url="https://github.com/savoirfairelinux/opendht"
-license=('GPL3')
+license=(GPL3)
+depends=(gnutls nettle readline asio jsoncpp argon2)
+makedepends=(git msgpack-c cmake cython)
+optdepends=('python: to use the Python bindings')
+provides=(opendht)
+conflicts=(opendht)
source=("git+https://github.com/savoirfairelinux/opendht")
sha256sums=('SKIP')
-provides=('opendht')
-conflicts=('opendht')
pkgver() {
cd "${pkgname%-git}"
- git log -1 --format="%cd" --date=short | sed "s|-||g"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd "${pkgname%-git}"
+prepare() {
+ cd "${srcdir}/${pkgname%-*}"
+ install -d build
+}
- msg2 'Building...'
- mkdir -p build
- cd build
+build() {
+ cd "${srcdir}/${pkgname%-git}/build"
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DOPENDHT_PYTHON=ON \
@@ -35,19 +39,8 @@ build() {
}
package() {
- cd "${pkgname%-git}"
-
- msg2 'Installing...'
- cd build
- make DESTDIR="$pkgdir" install
- cd ..
-
- msg2 'Installing documentation...'
- install -D -m644 README.md "${pkgdir}/usr/share/doc/opendht/README.md"
-
- msg2 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+ cd "${srcdir}/${pkgname%-git}/build"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 ../README.md "${pkgdir}/usr/share/doc/opendht/README.md"
}
-# vim:set ts=2 sw=2 et: