summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlague Doctor2019-11-09 11:32:36 +1100
committerPlague Doctor2019-11-09 11:32:36 +1100
commite318abd149ccf82050c41dfe14d8fab5f5665fd2 (patch)
treece72e9e11ae1cccffbc895ef6033b2c01fb72d97
parent44459bf220563e8877819d1e03782b442fb57b15 (diff)
downloadaur-e318abd149ccf82050c41dfe14d8fab5f5665fd2.tar.gz
Fix (sym)links.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD5
-rw-r--r--vscodium-bin.desktop2
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6925f919660..aa83a399fc75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vscodium-bin
pkgdesc = Binary releases of VS Code without MS branding/telemetry/licensing.
pkgver = 1.40.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/VSCodium/vscodium
arch = x86_64
license = MIT
@@ -21,10 +21,10 @@ pkgbase = vscodium-bin
optdepends = libdbusmenu-glib: For KDE global menu
provides = code
conflicts = code
- noextract = vscodium-bin-1.40.0-1.tar.gz
+ noextract = vscodium-bin-1.40.0-2.tar.gz
source = vscodium-bin.desktop
- source = vscodium-bin-1.40.0-1.tar.gz::https://github.com/VSCodium/vscodium/releases/download/1.40.0/VSCodium-linux-x64-1.40.0.tar.gz
- sha256sums = 7275ddd94fc356374ca2a883bd1210863a8f2e5ad2f3e6194a42240941d119a4
+ source = vscodium-bin-1.40.0-2.tar.gz::https://github.com/VSCodium/vscodium/releases/download/1.40.0/VSCodium-linux-x64-1.40.0.tar.gz
+ sha256sums = 31fbf764608b74abedaa4dbb5bf8b7d62570345e2a7079bdbc156e5f7c2357ff
sha256sums = 4482f533bc639d0462a0b98f1a5a13f0adf50a4e7bb75102280bee18297c217a
pkgname = vscodium-bin
diff --git a/PKGBUILD b/PKGBUILD
index 78f3aa6b35dd..9f0db9842ae6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vscodium-bin
pkgver=1.40.0
-pkgrel=1
+pkgrel=2
pkgdesc="Binary releases of VS Code without MS branding/telemetry/licensing."
arch=('x86_64')
url="https://github.com/VSCodium/vscodium"
@@ -22,7 +22,7 @@ source=(
${pkgname}-${pkgver}-${pkgrel}.tar.gz::${url}/releases/download/${pkgver}/VSCodium-linux-x64-${pkgver}.tar.gz
)
noextract=("${pkgname}-${pkgver}-${pkgrel}.tar.gz")
-sha256sums=('7275ddd94fc356374ca2a883bd1210863a8f2e5ad2f3e6194a42240941d119a4'
+sha256sums=('31fbf764608b74abedaa4dbb5bf8b7d62570345e2a7079bdbc156e5f7c2357ff'
'4482f533bc639d0462a0b98f1a5a13f0adf50a4e7bb75102280bee18297c217a')
prepare() {
@@ -34,6 +34,7 @@ package() {
install -d -m755 ${pkgdir}/usr/bin
install -d -m755 ${pkgdir}/usr/share/{${pkgname},applications,pixmaps}
cp -r ${srcdir}/${pkgname} ${pkgdir}/usr/share
+ ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/code
ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/codium
ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/vscodium
install -D -m644 vscodium-bin.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
diff --git a/vscodium-bin.desktop b/vscodium-bin.desktop
index 200ce9ecabfb..8bb619892f6e 100644
--- a/vscodium-bin.desktop
+++ b/vscodium-bin.desktop
@@ -14,5 +14,5 @@ Keywords=vscode;
[Desktop Action new-empty-window]
Name=New Empty Window
-Exec=/usr/share/vscodium-bin/codium --new-window %F
+Exec=/usr/share/vscodium-bin/bin/codium --new-window %F
Icon=vscodium