summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustKidding2023-12-01 23:41:39 -0500
committerJustKidding2023-12-01 23:41:39 -0500
commite3d1da55c36658947b2b574dde767d1522641e46 (patch)
treed5ce1cc05c1d899ec094060ef74bd291bea2417f
parentfe8e0ca027fa206d63dbff435c503957545dfed6 (diff)
downloadaur-e3d1da55c36658947b2b574dde767d1522641e46.tar.gz
upgpkg: mongodb 7.0.4-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD2
-rw-r--r--extrapatch-sconstruct.patch16
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29b4a6980b46..6c4a4ba287a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mongodb
pkgdesc = A high-performance, open source, schema-free document-oriented database
- pkgver = 7.0.3
+ pkgver = 7.0.4
pkgrel = 1
url = https://www.mongodb.com/
arch = x86_64
@@ -24,16 +24,16 @@ pkgbase = mongodb
depends = libunwind
optdepends = mongodb-tools: mongoimport, mongodump, mongotop, etc
optdepends = mongosh: interactive shell to connect with MongoDB
- provides = mongodb=7.0.3
+ provides = mongodb=7.0.4
options = !debug
backup = etc/mongodb.conf
- source = https://fastdl.mongodb.org/src/mongodb-src-r7.0.3.tar.gz
+ source = https://fastdl.mongodb.org/src/mongodb-src-r7.0.4.tar.gz
source = mongodb.sysusers
source = mongodb.tmpfiles
source = mongodb-5.0.2-skip-reqs-check.patch
source = mongodb-5.0.2-no-compass.patch
source = mongodb-7.0.2-sconstruct.patch
- sha256sums = 90e4f5b9fbe50851069d3909671c35aea02ce3931c7f264bd1c6252b8eb0d927
+ sha256sums = 8d4fa3c01a1dc97f04e2e51d2a9e661e60bfddb674a8902336ba00e09d74c123
sha256sums = 3757d548cfb0e697f59b9104f39a344bb3d15f802608085f838cb2495c065795
sha256sums = b7d18726225cd447e353007f896ff7e4cbedb2f641077bce70ab9d292e8f8d39
sha256sums = 4ff40320e04bf8c3e05cbc662f8ea549a6b8494d1fda64b1de190c88587bfafd
diff --git a/PKGBUILD b/PKGBUILD
index 7f82eb47ba8e..36f9d65f0320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,6 +39,8 @@ sha256sums=('8d4fa3c01a1dc97f04e2e51d2a9e661e60bfddb674a8902336ba00e09d74c123'
'4ff40320e04bf8c3e05cbc662f8ea549a6b8494d1fda64b1de190c88587bfafd'
'41b75d19ed7c4671225f08589e317295b7abee934b876859c8777916272f3052'
'078d94d712c3bb86a77d13bf2021299f4db2332c9d5346dba1ceb0cce1ba8492')
+source_aarch64=(extrapatch-sconstruct.patch)
+sha256sums_aarch64=('6dd9f20e153ff2a3e185d9411e9d9ec54ba8ed29a0a1489828ccb047205cceac')
_scons_args=(
CC="${CC:-gcc}"
diff --git a/extrapatch-sconstruct.patch b/extrapatch-sconstruct.patch
new file mode 100644
index 000000000000..21c09bc5c9a1
--- /dev/null
+++ b/extrapatch-sconstruct.patch
@@ -0,0 +1,16 @@
+--- a/SConstruct
++++ b/SConstruct
+@@ -3217,8 +3205,12 @@ if not env.TargetOSIs('windows', 'macOS') and (env.Too
+ # setting it for both C and C++ by setting both of CFLAGS and
+ # CXXFLAGS.
+
++ arm_march_flag = "armv8-a"
++ if get_option('use-hardware-crc32') == "on":
++ arm_march_flag += "+crc"
++
+ default_targeting_flags_for_architecture = {
+- "aarch64": {"-march=": "armv8.2-a", "-mtune=": "generic"},
++ "aarch64": {"-march=": arm_march_flag, "-mtune=": "generic"},
+ "i386": {"-march=": "nocona", "-mtune=": "generic"},
+ "ppc64le": {"-mcpu=": "power8", "-mtune=": "power8", "-mcmodel=": "medium"},
+ "s390x": {"-march=": "z196", "-mtune=": "zEC12"},