summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2023-10-31 19:52:08 +0600
committerMubashshir2023-10-31 19:52:08 +0600
commite5463cc25b811b6d6544f1a6edb8ef08367cc6f8 (patch)
tree25ea411c6085e03ba678136036c8b321bc40b1ae
parente36bf3763f99d8397dd1e6f5447115fcc3ac60a3 (diff)
downloadaur-e5463cc25b811b6d6544f1a6edb8ef08367cc6f8.tar.gz
whatpulse: Release v5.5.2
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cd6bb6b668e..a5af17670c8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = whatpulse
pkgdesc = Measures your keyboard, mouse and application usage, network traffic and uptime.
- pkgver = 5.4
- pkgrel = 4
+ pkgver = 5.5.2
+ pkgrel = 1
url = http://www.whatpulse.org
arch = x86_64
license = custom:whatpulse_tos
@@ -33,7 +33,7 @@ pkgbase = whatpulse
sha256sums = 5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d
sha256sums = f3d16ee6e325a3c657e7af1ebc9f6e35d09ff5c03b0a8b0450611e610c5d6d32
sha256sums = cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619
- source_x86_64 = whatpulse-5.4-amd64.AppImage::https://releases.whatpulse.org/latest/linux/whatpulse-linux-latest_amd64.AppImage
- sha256sums_x86_64 = 533b1b28120a25f3db625425f42dfbc559180a3dfb4e1f9c6156cf27b4a646f4
+ source_x86_64 = whatpulse-5.5.2-amd64.AppImage::https://releases-dev.whatpulse.org/5.5.2/linux/whatpulse-linux-5.5.2_amd64.AppImage
+ sha256sums_x86_64 = 6ca9b04c567113140441a552f91b38bfc68a74b3c7a8cb8e537e7fc1aa7611c4
pkgname = whatpulse
diff --git a/PKGBUILD b/PKGBUILD
index 1051eb7c8375..d519d35e501b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Pieter Kokx <pieter $at$ kokx $dot$ .nl>
_tag=latest
pkgname=whatpulse
-pkgver=5.4
-pkgrel=4
+pkgver=5.5.2
+pkgrel=1
pkgdesc="Measures your keyboard, mouse and application usage, network traffic and uptime."
arch=('x86_64')
@@ -32,16 +32,25 @@ source=(
'whatpulse.sh'
LICENSE
)
-source_x86_64=("${pkgname}-${pkgver}-amd64.AppImage::https://releases.whatpulse.org/${_tag:-$pkgver}/linux/whatpulse-linux-${_tag:-$pkgver}_amd64.AppImage")
+source_x86_64=("${pkgname}-${pkgver}-amd64.AppImage::https://releases-dev.whatpulse.org/$pkgver/linux/whatpulse-linux-${pkgver}_amd64.AppImage")
+
sha256sums=('5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d'
'f3d16ee6e325a3c657e7af1ebc9f6e35d09ff5c03b0a8b0450611e610c5d6d32'
'cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619')
-sha256sums_x86_64=('533b1b28120a25f3db625425f42dfbc559180a3dfb4e1f9c6156cf27b4a646f4')
+sha256sums_x86_64=('6ca9b04c567113140441a552f91b38bfc68a74b3c7a8cb8e537e7fc1aa7611c4')
_extract() {
./"${pkgname}-${pkgver}-amd64.AppImage" --appimage-extract "$1"
}
+__check_update() {
+ if ! curl --disable -Ls "$url/releasenotes/?beta=false" \
+ | xmllint --nowarning --html \
+ --xpath 'normalize-space(//div[@id="page-content"]//li[contains(concat(" ",normalize-space(@class)," ")," task-info ")][1]//h3/text()[1])' - 2> /dev/null
+ then echo $pkgver
+ fi
+}
+
prepare() {
chmod +x "${pkgname}-${pkgver}-amd64.AppImage"
_extract usr/bin/whatpulse