summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2023-05-13 16:39:33 +0200
committerMartin Rys2023-05-13 16:39:33 +0200
commite6c29dba1a82e63239b4e6019b3de6da359060c3 (patch)
tree030faa466a68b660d2fad698234a119923b9e7b1
parent559e11e5489990fce9d20d656d42db873c3a5eb3 (diff)
downloadaur-e6c29dba1a82e63239b4e6019b3de6da359060c3.tar.gz
Update patch file against actual upstream commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--tbb.patch18
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28afa922fef4..edf46bfdb6ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = loot
pkgdesc = A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games.
pkgver = 0.19.1
- pkgrel = 4
+ pkgrel = 5
url = https://loot.github.io
arch = x86_64
license = GPL3
@@ -30,6 +30,6 @@ pkgbase = loot
sha256sums = 832c0a44f8f33963a90987d880e2527f0ae9a175b29451c47d486dfdf4d41df1
sha256sums = 819c0c8a6986a612c81729cccf51a848dac7d83f46a75d93cfbb87587f86635e
sha256sums = 3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb
- sha256sums = 333e1c20367124242ebc8cf1153ca6925574a1b8de8f595e75d56fb3d83aa01e
+ sha256sums = 4c94372e800f764fb21218b7cbbf8421cadc60acd532e8ba66b734395f1bb343
pkgname = loot
diff --git a/PKGBUILD b/PKGBUILD
index b7b537300921..1e15589d7b7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=loot
pkgver=0.19.1
_pkglibver=0.19.4
-pkgrel=4
+pkgrel=5
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
url="https://loot.github.io"
@@ -19,7 +19,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$
sha256sums=('832c0a44f8f33963a90987d880e2527f0ae9a175b29451c47d486dfdf4d41df1'
'819c0c8a6986a612c81729cccf51a848dac7d83f46a75d93cfbb87587f86635e'
'3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb'
- '333e1c20367124242ebc8cf1153ca6925574a1b8de8f595e75d56fb3d83aa01e'
+ '4c94372e800f764fb21218b7cbbf8421cadc60acd532e8ba66b734395f1bb343'
)
diff --git a/tbb.patch b/tbb.patch
index f9a63f3e7cdc..541b9f942012 100644
--- a/tbb.patch
+++ b/tbb.patch
@@ -1,19 +1,33 @@
--- a/src/gui/state/game/game.h
+++ b/src/gui/state/game/game.h
-@@ -26,6 +26,8 @@
+@@ -26,6 +26,18 @@
#ifndef LOOT_GUI_STATE_GAME_GAME
#define LOOT_GUI_STATE_GAME_GAME
++#ifndef _WIN32
++#ifdef emit
++// The TBB library is used on Linux to provide the implementation of the
++// standard library parallel execution algorithms, but oneTBB 2021.8.0 defines
++// an emit() function that clashes with Qt's emit macro, which may be defined
++// when this header is included. As such, undefine the macro before including
++// the standard library headers, and redefine it afterwards.
+#undef emit
++#define LOOT_SHOULD_REDEFINE_EMIT
++#endif
++#endif
+
#include <execution>
#include <filesystem>
#include <functional>
-@@ -34,6 +36,8 @@
+@@ -34,6 +46,12 @@
#include <string>
#include <variant>
++#ifdef LOOT_SHOULD_REDEFINE_EMIT
++// Assume emit was Qt's emit macro, which is empty.
+#define emit
++#undef LOOT_SHOULD_REDEFINE_EMIT
++#endif
+
#include "gui/state/game/game_settings.h"
#include "gui/state/logging.h"