summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-07-15 01:37:07 +0000
committerDaniel Bermond2019-07-15 01:37:07 +0000
commite7e7782b010fbf55e20591113ac137c084ed70fd (patch)
treeb4163d02f3445cc6d67e9cf61925b4f2ca5e3e4c
parent4d164df7bc5dfbc64a6cdf0ec8349a5787eab1de (diff)
downloadaur-e7e7782b010fbf55e20591113ac137c084ed70fd.tar.gz
Improve pkgver(). Cosmetic changes.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f61ca0c9be8..07f42e55770b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-qsv-git
pkgdesc = Complete solution to record, convert and stream audio and video (with Intel Quick Sync Video hardware acceleration, git version)
- pkgver = 4.2.r92486.g8f875a90c4
+ pkgver = 4.2.r94300.gaf5f770113
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 14ea4dad084f..cd6807ef34a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-qsv-git
-_srcname=ffmpeg
-pkgver=4.2.r92486.g8f875a90c4
+pkgver=4.2.r94300.gaf5f770113
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (with Intel Quick Sync Video hardware acceleration, git version)'
arch=('x86_64')
@@ -35,13 +34,13 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git')
sha256sums=('SKIP')
pkgver() {
- cd "$_srcname"
+ cd ffmpeg
local _version
local _revision
local _shorthash
- _version="$( git describe --tags --long | awk -F'-' '{ printf $1 }' | sed 's/^n//')"
+ _version="$( git describe --tags --long | awk -F'-' '{ sub(/^n/, "", $1); print $1 }')"
_revision="$( git describe --tags --match 'N' | awk -F'-' '{ printf $2 }')"
_shorthash="$(git rev-parse --short HEAD)"
@@ -49,7 +48,7 @@ pkgver() {
}
build() {
- cd "$_srcname"
+ cd ffmpeg
export PKG_CONFIG_PATH="${PKG_CONFIG_PATH:+${PKG_CONFIG_PATH}:}/opt/intel/mediasdk/lib64/pkgconfig"
@@ -107,7 +106,7 @@ build() {
}
package() {
- cd "$_srcname"
+ cd ffmpeg
make DESTDIR="$pkgdir" install