summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMédéric Boquien2021-05-22 07:43:00 -0400
committerMédéric Boquien2021-05-22 07:43:00 -0400
commitea0e51efc859077442df260568f28ae33bb7e4d0 (patch)
treea901f7a8505c063c69237cbc05ce9aeff74dc23f
parentedc8a7906fe6fa8416325454c55173affa784de2 (diff)
downloadaur-ea0e51efc859077442df260568f28ae33bb7e4d0.tar.gz
New maintainer. Small improvements to the PKGBUILD. Update to version 0.4.2.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD15
2 files changed, 22 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e33a04305821..163f253f8766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,25 @@
pkgbase = python-astroquery
pkgdesc = Set of tools for querying astronomical web forms and databases
- pkgver = 0.4.1
+ pkgver = 0.4.2
pkgrel = 1
url = http://astroquery.readthedocs.org/en/latest/
arch = x86_64
license = BSD
makedepends = cython
- depends = python>=3.4
- depends = python-numpy>=1.9
- depends = python-astropy>=1.0
+ depends = python>=3.6
+ depends = python-numpy>=1.14
+ depends = python-astropy>=3.1.2
depends = python-requests
depends = python-keyring
depends = python-beautifulsoup4
depends = python-html5lib
- source = https://files.pythonhosted.org/packages/source/a/astroquery/astroquery-0.4.1.tar.gz
- md5sums = 838d4ae08b19fb0d8d408fbb65d8d505
+ optdepends = python-aplpy: required for the full functionality of the alma module
+ optdepends = python-astropy-healpix: required for the full functionality of the cds module
+ optdepends = python-pyregion: required for the full functionality of the alma module
+ optdepends = python-regions: required for the full functionality of the cds module
+ optdepends = python-boto3: required for the full functionality of the mast module
+ source = https://files.pythonhosted.org/packages/source/a/astroquery/astroquery-0.4.2.tar.gz
+ sha512sums = 2e9ff23d4b21e8b5c8bc6fb089a76834b4d45d13114b4760ccd9eb4c9a0a8e2098b92dcb59b48a2fdb21e7cb7ea8a558e34f9cc72bef1e181a0feca8f828d7c2
pkgname = python-astroquery
diff --git a/PKGBUILD b/PKGBUILD
index 5bf930082ab5..5f967744b855 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,24 @@
-# Maintainer: Miguel de Val-Borro <miguel dot deval at gmail dot com>
+# Creator: Miguel de Val-Borro <miguel dot deval at gmail dot com>
+# Maintainer: Médéric boquien <mboquien@free.fr>
pkgname=python-astroquery
-pkgver=0.4.1
+pkgver=0.4.2
pkgrel=1
pkgdesc="Set of tools for querying astronomical web forms and databases"
arch=('x86_64')
url="http://astroquery.readthedocs.org/en/latest/"
license=('BSD')
-depends=('python>=3.4' 'python-numpy>=1.9' 'python-astropy>=1.0' 'python-requests' 'python-keyring' 'python-beautifulsoup4' 'python-html5lib')
+depends=('python>=3.6' 'python-numpy>=1.14' 'python-astropy>=3.1.2' 'python-requests' 'python-keyring' 'python-beautifulsoup4' 'python-html5lib')
+optdepends=('python-aplpy: required for the full functionality of the alma module'
+ 'python-astropy-healpix: required for the full functionality of the cds module'
+ 'python-pyregion: required for the full functionality of the alma module'
+ 'python-regions: required for the full functionality of the cds module'
+ 'python-boto3: required for the full functionality of the mast module'
+)
conflicts=()
makedepends=('cython')
source=("https://files.pythonhosted.org/packages/source/a/astroquery/astroquery-${pkgver}.tar.gz")
-md5sums=('838d4ae08b19fb0d8d408fbb65d8d505')
+sha512sums=('2e9ff23d4b21e8b5c8bc6fb089a76834b4d45d13114b4760ccd9eb4c9a0a8e2098b92dcb59b48a2fdb21e7cb7ea8a558e34f9cc72bef1e181a0feca8f828d7c2')
build() {
cd ${srcdir}/astroquery-${pkgver}