summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReza Jahanbakhshi2022-08-14 12:11:37 +0200
committerReza Jahanbakhshi2022-08-14 12:11:37 +0200
commitea75f3382927d5df2cd23452e1f6fdf887b35530 (patch)
tree4caaacf8c0a4389fad66861cd0a81e4cd615647d
parentc78d2d7f3f29e6befaa025fae0c3fdc45bec1c00 (diff)
downloadaur-ea75f3382927d5df2cd23452e1f6fdf887b35530.tar.gz
ocaml-stdlib-shims added to makedepends
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b5f1cf3f368..f9501936ec0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 14.0.0_r413047.c703d77a61ac
+ pkgver = 16.0.0_r432910.6b6e9d22684d
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -28,6 +28,7 @@ pkgbase = llvm-git
makedepends = opencl-headers
makedepends = z3
makedepends = jsoncpp
+ makedepends = ocaml-stdlib-shims
options = staticlibs
source = llvm-project::git+https://github.com/llvm/llvm-project.git
source = llvm-config.h
@@ -38,7 +39,7 @@ pkgbase = llvm-git
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=14.0.0_r413047.c703d77a61ac-1
+ depends = llvm-libs-git=16.0.0_r432910.6b6e9d22684d-1
depends = perl
optdepends = python: for scripts
optdepends = python-setuptools: for using lit = LLVM Integrated Tester
@@ -77,7 +78,7 @@ pkgname = llvm-libs-git
pkgname = llvm-ocaml-git
pkgdesc = OCaml bindings for LLVM
- depends = llvm-git=14.0.0_r413047.c703d77a61ac-1
+ depends = llvm-git=16.0.0_r432910.6b6e9d22684d-1
depends = ocaml
depends = ocaml-ctypes
provides = llvm-ocaml
diff --git a/PKGBUILD b/PKGBUILD
index 4449fd6951bf..a8b0174d45e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgname=('llvm-git' 'llvm-libs-git' 'llvm-ocaml-git')
-pkgver=14.0.0_r413047.c703d77a61ac
+pkgver=16.0.0_r432910.6b6e9d22684d
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -24,7 +24,7 @@ license=('custom:Apache 2.0 with LLVM Exception')
makedepends=('git' 'cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2' 'python-sphinx'
'python-sphinx-automodapi' 'lldb' 'ocaml' 'ocaml-ctypes' 'ocaml-findlib'
'python-sphinx' 'python-recommonmark' 'swig' 'python' 'python-six' 'lua53'
- 'ocl-icd' 'opencl-headers' 'z3' 'jsoncpp')
+ 'ocl-icd' 'opencl-headers' 'z3' 'jsoncpp' 'ocaml-stdlib-shims')
checkdepends=("python-psutil")
source=("llvm-project::git+https://github.com/llvm/llvm-project.git"
"llvm-config.h")