summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMédéric Boquien2021-11-20 08:48:47 -0300
committerMédéric Boquien2021-11-20 08:48:47 -0300
commiteb9e37b83b0257172d0e48bc07f678c855783d1d (patch)
treecc46ba2880acc959c3bb798a5dbae176b8f460b6
parent86216233327bc78659c6ace44e4c1b1e60cf099b (diff)
downloadaur-eb9e37b83b0257172d0e48bc07f678c855783d1d.tar.gz
Update to version 0.4.4.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e3b54399aca..ddea01dd24d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = python-astroquery
pkgdesc = Set of tools for querying astronomical web forms and databases
- pkgver = 0.4.3
+ pkgver = 0.4.4
pkgrel = 1
url = http://astroquery.readthedocs.org/en/latest/
arch = x86_64
license = BSD
makedepends = cython
- depends = python>=3.6
- depends = python-numpy>=1.14
- depends = python-astropy>=3.1.2
+ depends = python>=3.7
+ depends = python-numpy>=1.16
+ depends = python-astropy>=4.0
depends = python-requests
depends = python-keyring
depends = python-beautifulsoup4
depends = python-html5lib
optdepends = python-aplpy: required for the full functionality of the alma module
- optdepends = python-astropy-healpix: required for the full functionality of the cds module
optdepends = python-pyregion: required for the full functionality of the alma module
+ optdepends = python-astropy-healpix: required for the full functionality of the cds module
optdepends = python-regions: required for the full functionality of the cds module
optdepends = python-boto3: required for the full functionality of the mast module
- source = https://files.pythonhosted.org/packages/source/a/astroquery/astroquery-0.4.3.tar.gz
- sha512sums = 80ea34e86919b6442e92f59f1dd759c482f72e1d9ccad69ed25b8dfafc8d7fe30c192539a0a104981279d3966eff0fdd6272022f320b93f9a8ba29745f64de8f
+ source = https://files.pythonhosted.org/packages/source/a/astroquery/astroquery-0.4.4.tar.gz
+ sha512sums = b8d96cacb901c3bab00103408d24694fad31f3fefa73c9c33accef671e6b7e253ea69912a3e3bd71c98a0fe5125fd6cfe4c5c52086b61a4fe4c864e9012f81a6
pkgname = python-astroquery
diff --git a/PKGBUILD b/PKGBUILD
index a3ee7473bf32..edfc5027b9e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,28 @@
# Maintainer: Médéric boquien <mboquien@free.fr>
pkgname=python-astroquery
-pkgver=0.4.3
+pkgver=0.4.4
pkgrel=1
pkgdesc="Set of tools for querying astronomical web forms and databases"
arch=('x86_64')
url="http://astroquery.readthedocs.org/en/latest/"
license=('BSD')
-depends=('python>=3.6' 'python-numpy>=1.14' 'python-astropy>=3.1.2' 'python-requests' 'python-keyring' 'python-beautifulsoup4' 'python-html5lib')
+depends=('python>=3.7' 'python-numpy>=1.16' 'python-astropy>=4.0' 'python-requests' 'python-keyring' 'python-beautifulsoup4' 'python-html5lib')
optdepends=('python-aplpy: required for the full functionality of the alma module'
- 'python-astropy-healpix: required for the full functionality of the cds module'
'python-pyregion: required for the full functionality of the alma module'
+ 'python-astropy-healpix: required for the full functionality of the cds module'
'python-regions: required for the full functionality of the cds module'
'python-boto3: required for the full functionality of the mast module'
)
conflicts=()
makedepends=('cython')
source=("https://files.pythonhosted.org/packages/source/a/astroquery/astroquery-${pkgver}.tar.gz")
-sha512sums=('80ea34e86919b6442e92f59f1dd759c482f72e1d9ccad69ed25b8dfafc8d7fe30c192539a0a104981279d3966eff0fdd6272022f320b93f9a8ba29745f64de8f')
+sha512sums=('b8d96cacb901c3bab00103408d24694fad31f3fefa73c9c33accef671e6b7e253ea69912a3e3bd71c98a0fe5125fd6cfe4c5c52086b61a4fe4c864e9012f81a6')
build() {
cd ${srcdir}/astroquery-${pkgver}
- python setup.py build --use-system-libraries --offline
+
+ PYTHONHASHSEED=0 python setup.py build
}
package() {
@@ -30,5 +31,5 @@ package() {
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
- python setup.py install --offline --root=${pkgdir} --prefix=/usr --optimize=1
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}