summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Whitwell2020-02-13 14:50:19 +0000
committerTom Whitwell2020-02-13 14:53:08 +0000
commited612ae84b7d73321effd63ae9de4937298cc47f (patch)
tree29a9eb28009bc55981c0d3d296091f4f2e7aed90
parentc65f5c19ffb60bca4ce8340824e785be3f815fc7 (diff)
downloadaur-ed612ae84b7d73321effd63ae9de4937298cc47f.tar.gz
Add concourse pipeline to auto-build aur package
-rw-r--r--release-pipeline.yml70
1 files changed, 70 insertions, 0 deletions
diff --git a/release-pipeline.yml b/release-pipeline.yml
new file mode 100644
index 000000000000..2b459c4d6ec4
--- /dev/null
+++ b/release-pipeline.yml
@@ -0,0 +1,70 @@
+meta:
+ containers:
+ ruby: &makepkg-image-resource
+ type: docker-image
+ source:
+ repository: whynothugo/makepkg
+ tag: latest
+jobs:
+ - name: Trigger
+ plan:
+ - in_parallel:
+ - get: gds-cli-src
+ trigger: true
+
+ - name: Build
+ plan:
+ - in_parallel:
+ - get: gds-cli-src
+ passed: [Trigger]
+ trigger: true
+ - get: gds-cli-aur
+ - task: Run Make job
+ config:
+ platform: linux
+ image_resource: *makepkg-image-resource
+ inputs:
+ - name: gds-cli-aur
+ outputs:
+ - name: gds-cli-aur_updated
+ run:
+ path: sh
+ args:
+ - -exc
+ - |
+ sudo chown -R notroot.notroot .
+ git clone gds-cli-aur gds-cli-aur_updated
+ cd gds-cli-aur_updated
+ set +x
+ git config --global credential.helper store
+ git config --global push.default simple
+ git config --global user.email "concourse@whitwell.dev"
+ git config --global user.name "Concourse"
+ git config --global credential.https://github.com.username ((concourse-github-username))
+ echo "https://((concourse-github-username)):((concourse-github-token))@github.com" > ${HOME}/.git-credentials
+ set -x
+ make all
+ VERSION=$(sed -n 's/pkgver\=\(.*\)/\1/p' PKGBUILD)
+ git add PKGBUILD .SRCINFO
+ git commit -m "Update gds-cli to ${VERSION}"
+ on_success:
+ put: gds-cli-aur
+ params:
+ repository: gds-cli-aur_updated
+
+resources:
+ - name: gds-cli-aur
+ type: git
+ source:
+ uri: ssh://aur@aur.archlinux.org/gds-cli-git.git
+ branch: master
+ private_key: |
+ ((concourse-ssh-key.id_rsa))
+
+ - name: gds-cli-src
+ type: git
+ source:
+ uri: git@github.com:alphagov/gds-cli.git
+ branch: master
+ private_key: |
+ ((concourse-ssh-key.id_rsa))