summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikołaj "D1SoveR" Banasik2021-09-25 11:43:18 +0100
committerMikołaj "D1SoveR" Banasik2021-09-25 11:43:25 +0100
commitee5088eb9ccb616ef569f7a2befbe362844a9a2a (patch)
tree5f55b310146fbf76fce84e895c80817e39b331c6
parentdedee69a944cfd198204fcf3703cb82519af8650 (diff)
downloadaur-ee5088eb9ccb616ef569f7a2befbe362844a9a2a.tar.gz
Moved the size optimisations above dependencies list.
This should stop the patch from becoming inapplicable when new dependencies are added. Also, removed the --locked flag as it was actually breaking the build (likely due to stale lockfile).
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--reproducible-build.patch20
-rw-r--r--size-optimisations.patch15
4 files changed, 13 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 876df1d29f17..7390543a7377 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = luxtorpeda-git
pkgdesc = Steam Play compatibility tool to run games using native Linux engines
- pkgver = 30.0.0.r270.415ad45
+ pkgver = 36.0.0.r289.0253e5c
pkgrel = 1
url = https://github.com/luxtorpeda-dev/luxtorpeda
arch = x86_64
@@ -14,10 +14,8 @@ pkgbase = luxtorpeda-git
provides = luxtorpeda
conflicts = luxtorpeda
source = git+https://github.com/luxtorpeda-dev/luxtorpeda.git
- source = reproducible-build.patch
source = size-optimisations.patch
sha256sums = SKIP
- sha256sums = e97cf95dedcf60c97edb3a693052964e4ce6da795631ca5c9f04182462f67895
- sha256sums = 2bd6a8b0586cf5f382d4e98ed8803bc34af2b5227f31a3f219957b4d6f50ada3
+ sha256sums = 1aea00fecd857e8d7b8a3d4c3a5d2f9ef18007bb9366461b4f16878d64a7bf40
pkgname = luxtorpeda-git
diff --git a/PKGBUILD b/PKGBUILD
index f23f81ed1301..8fadb6869ae0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mikołaj "D1SoveR" Banasik <d1sover@gmail.com>
pkgname='luxtorpeda-git'
-pkgver=30.0.0.r270.415ad45
+pkgver=36.0.0.r289.0253e5c
pkgrel=1
pkgdesc='Steam Play compatibility tool to run games using native Linux engines'
arch=('x86_64' 'i686')
@@ -13,11 +13,9 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+${url}.git"
- 'reproducible-build.patch'
'size-optimisations.patch')
sha256sums=('SKIP'
- 'e97cf95dedcf60c97edb3a693052964e4ce6da795631ca5c9f04182462f67895'
- '2bd6a8b0586cf5f382d4e98ed8803bc34af2b5227f31a3f219957b4d6f50ada3')
+ '1aea00fecd857e8d7b8a3d4c3a5d2f9ef18007bb9366461b4f16878d64a7bf40')
pkgver() {
cd "${pkgname%-git}"
@@ -29,7 +27,6 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- patch -Np1 -i "$srcdir/reproducible-build.patch"
patch -Np1 -i "$srcdir/size-optimisations.patch"
}
diff --git a/reproducible-build.patch b/reproducible-build.patch
deleted file mode 100644
index 1ec6caeec3ea..000000000000
--- a/reproducible-build.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 475c85b..2800d44 100644
---- a/Makefile
-+++ b/Makefile
-@@ -37,13 +37,13 @@ build:
- cargo build
-
- release:
-- cargo build --release
-+ cargo build --release --locked
-
- lint:
- cargo clippy -- -D warnings
-
- test:
-- cargo test
-+ cargo test --release --locked
-
- clean:
- cargo clean
diff --git a/size-optimisations.patch b/size-optimisations.patch
index 92f572061ecb..e60f9e6d960f 100644
--- a/size-optimisations.patch
+++ b/size-optimisations.patch
@@ -1,13 +1,16 @@
diff --git a/Cargo.toml b/Cargo.toml
-index af1bb24..e322372 100644
+index 558ceb5..913630d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
-@@ -28,3 +28,8 @@ flate2 = "1.0.16"
- futures-util = "0.3.14"
- tokio = { version = "0.2", default-features = false, features = ["full"] }
- which = "4.2.2"
-+
+@@ -6,6 +6,11 @@ edition = "2018"
+
+ # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[profile.release]
+panic = 'abort'
+opt-level = 'z'
+lto = true
++
+ [dependencies]
+ serde = { version = "1.0", features = ["derive"] }
+ serde_json = "1.0"