summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2019-09-18 10:57:31 +0200
committerLubosz Sarnecki2019-09-18 10:58:49 +0200
commitee50caf20dd4a0af6a22a047e71e32f7842110e5 (patch)
treef06cb1f5a3b58ec64b23d3126e6f0ec27e4fc515
parent08f8a85274dab678ae54c7325f5786af6ea26e58 (diff)
downloadaur-ee50caf20dd4a0af6a22a047e71e32f7842110e5.tar.gz
Update version to 1.7.15, update patchset. Use system jsoncpp.
-rw-r--r--.SRCINFO21
-rw-r--r--0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch (renamed from 0001-also-add-pragma-pack-around-VRControllerState_t.patch)20
-rw-r--r--0002-samples-cmake-Remove-OpenVR-paths-check.patch (renamed from remove-openvrpaths-check.diff)13
-rw-r--r--0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch26
-rw-r--r--PKGBUILD36
5 files changed, 80 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5635ddb3030..0f40667e4bf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Aug 29 13:27:20 UTC 2019
+# Wed Sep 18 08:58:28 UTC 2019
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors.
- pkgver = 1.6.10b.65.52065df
+ pkgver = 1.7.15.66.5aa6c5f
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
@@ -14,19 +14,20 @@ pkgbase = openvr-git
depends = libgl
depends = sdl2
depends = glew
+ depends = jsoncpp
optdepends = steam: SteamVR must be installed through Steam, also contains vive udev rules
provides = openvr
options = !strip
source = git+https://github.com/ValveSoftware/openvr.git
- source = 0001-also-add-pragma-pack-around-VRControllerState_t.patch
- source = remove-openvrpaths-check.diff
- source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/594.patch
- source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1177.patch
+ source = 0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
+ source = 0002-samples-cmake-Remove-OpenVR-paths-check.patch
+ source = 0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch
+ source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1178.patch
md5sums = SKIP
- md5sums = 8a9379f8cdf9a38f21942f46378714a5
- md5sums = 904a532900792e7273702a9b45d304f2
- md5sums = 7350517830b1a0038d30c6ad33b4bb39
- md5sums = 8aaa5723852e5ee81ba910235743fde2
+ md5sums = 177ad5ec0b0714a522c3242fbe312fac
+ md5sums = d3dc9d20967362a2e92e3fb1c7f82b57
+ md5sums = e68ff412ff73b1ca75f8b17ab6c7069a
+ md5sums = bd5a473153106325233f00b3f35c46d8
pkgname = openvr-git
diff --git a/0001-also-add-pragma-pack-around-VRControllerState_t.patch b/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
index daedc8a56f5c..cd13f06c1e63 100644
--- a/0001-also-add-pragma-pack-around-VRControllerState_t.patch
+++ b/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
@@ -1,7 +1,7 @@
-From 1fd28b735d8abcc3fde9a4f5493407b5c0fcb91e Mon Sep 17 00:00:00 2001
+From 82e34cf8220853396a4494ab16431ab7a9d87e34 Mon Sep 17 00:00:00 2001
From: Christoph Haag <christoph.haag@collabora.com>
Date: Wed, 8 Aug 2018 01:06:29 +0200
-Subject: [PATCH] also add pragma pack around VRControllerState_t
+Subject: [PATCH 1/3] openvr_capi: Add pragma pack around VRControllerState_t.
See https://github.com/ValveSoftware/SteamVR-for-Linux/issues/35
---
@@ -9,31 +9,31 @@ See https://github.com/ValveSoftware/SteamVR-for-Linux/issues/35
1 file changed, 8 insertions(+)
diff --git a/headers/openvr_capi.h b/headers/openvr_capi.h
-index 66da364..97906eb 100644
+index f6743de..5893e6e 100644
--- a/headers/openvr_capi.h
+++ b/headers/openvr_capi.h
-@@ -1206,6 +1206,11 @@ typedef struct VRControllerAxis_t
+@@ -1995,6 +1995,11 @@ typedef struct VRControllerAxis_t
float y;
} VRControllerAxis_t;
-+#if defined(__linux__) || defined(__APPLE__)
-+// This structure was originally defined mis-packed on Linux, preserved for
-+// compatibility.
++#if defined(__linux__) || defined(__APPLE__)
++// This structure was originally defined mis-packed on Linux, preserved for
++// compatibility.
+#pragma pack( push, 4 )
+#endif
typedef struct VRControllerState_t
{
uint32_t unPacketNum;
-@@ -1213,6 +1218,9 @@ typedef struct VRControllerState_t
+@@ -2002,6 +2007,9 @@ typedef struct VRControllerState_t
uint64_t ulButtonTouched;
struct VRControllerAxis_t rAxis[5]; //struct vr::VRControllerAxis_t[5]
} VRControllerState_t;
-+#if defined(__linux__) || defined(__APPLE__)
++#if defined(__linux__) || defined(__APPLE__)
+#pragma pack( pop )
+#endif
typedef struct Compositor_OverlaySettings
{
--
-2.18.0
+2.23.0
diff --git a/remove-openvrpaths-check.diff b/0002-samples-cmake-Remove-OpenVR-paths-check.patch
index f7683dc7d8d6..aea87c7a6f88 100644
--- a/remove-openvrpaths-check.diff
+++ b/0002-samples-cmake-Remove-OpenVR-paths-check.patch
@@ -1,3 +1,13 @@
+From 9e1e1f6682d225a9028f4f902c0eb701cf7b9abb Mon Sep 17 00:00:00 2001
+From: Lubosz Sarnecki <lubosz.sarnecki@collabora.com>
+Date: Wed, 18 Sep 2019 10:42:59 +0200
+Subject: [PATCH 2/3] samples/cmake: Remove OpenVR paths check.
+
+Original patch by Christoph Haag.
+---
+ samples/CMakeLists.txt | 9 ---------
+ 1 file changed, 9 deletions(-)
+
diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt
index a573f83..ae09188 100644
--- a/samples/CMakeLists.txt
@@ -18,3 +28,6 @@ index a573f83..ae09188 100644
# Default output directory.
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/bin/${ARCH_TARGET})
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/bin/${ARCH_TARGET})
+--
+2.23.0
+
diff --git a/0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch b/0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch
new file mode 100644
index 000000000000..0c333c5e417e
--- /dev/null
+++ b/0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch
@@ -0,0 +1,26 @@
+From e06cb0ae61e0fa0ad4c1bc96392211284633ae0a Mon Sep 17 00:00:00 2001
+From: Christoph Haag <haagch@frickel.club>
+Date: Tue, 25 Jul 2017 02:07:09 +0200
+Subject: [PATCH 3/3] samples/compat: Use correct definition for vsprintf_s.
+
+Defining it to sprintf actually segfaults in a release build.
+---
+ samples/shared/compat.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/samples/shared/compat.h b/samples/shared/compat.h
+index 154f8b0..28002d9 100644
+--- a/samples/shared/compat.h
++++ b/samples/shared/compat.h
+@@ -12,7 +12,7 @@
+ #include <unistd.h>
+
+ #define sprintf_s snprintf
+-#define vsprintf_s sprintf
++#define vsprintf_s vsprintf
+ #define _stricmp strcmp
+ #define stricmp strcmp
+ #define strnicmp strncasecmp
+--
+2.23.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 6f8949996ed7..56567dbcb8cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
pkgname=openvr-git
-pkgver=1.6.10b.65.52065df
+pkgver=1.7.15.66.5aa6c5f
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors."
arch=('x86_64')
url="https://github.com/ValveSoftware/openvr"
license=('custom')
-depends=('libgl' 'sdl2' 'glew')
+depends=('libgl' 'sdl2' 'glew' 'jsoncpp')
optdepends=('steam: SteamVR must be installed through Steam, also contains vive udev rules')
makedepends=('git' 'cmake' 'vulkan-headers' 'qt5-base') #qt5 for the overlayexample
provides=("openvr")
options=('!strip')
source=("git+https://github.com/ValveSoftware/openvr.git"
- '0001-also-add-pragma-pack-around-VRControllerState_t.patch'
- 'remove-openvrpaths-check.diff'
- 'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/594.patch'
- 'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1177.patch')
+ '0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch' # openvr_capi: Add pragma pack around VRControllerState_t.
+ '0002-samples-cmake-Remove-OpenVR-paths-check.patch' # samples/cmake: Remove OpenVR paths check.
+ '0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch' # Use correct C++11 definition for vsprintf_s
+ 'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1178.patch' # Add ability to build with system installed jsoncpp
+ )
md5sums=('SKIP'
- '8a9379f8cdf9a38f21942f46378714a5'
- '904a532900792e7273702a9b45d304f2'
- '7350517830b1a0038d30c6ad33b4bb39'
- '8aaa5723852e5ee81ba910235743fde2')
+ '177ad5ec0b0714a522c3242fbe312fac'
+ 'd3dc9d20967362a2e92e3fb1c7f82b57'
+ 'e68ff412ff73b1ca75f8b17ab6c7069a'
+ 'bd5a473153106325233f00b3f35c46d8')
install_examples=false
@@ -42,11 +43,10 @@ pkgver() {
prepare() {
cd "$srcdir/openvr"
- git apply ../0001-also-add-pragma-pack-around-VRControllerState_t.patch
- git apply ../remove-openvrpaths-check.diff
- git apply ../594.patch
- git apply ../1177.patch
-
+ git apply "../0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch"
+ git apply "../0002-samples-cmake-Remove-OpenVR-paths-check.patch"
+ git apply "../0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch"
+ git apply "../1178.patch"
}
build() {
@@ -60,7 +60,11 @@ build() {
cd openvr
# libopenvr_api.so
- cmake -DBUILD_SHARED=1 -DCMAKE_INSTALL_PREFIX=/usr/ -DCMAKE_BUILD_TYPE=Release .
+ cmake -DBUILD_SHARED=1 \
+ -DCMAKE_INSTALL_PREFIX=/usr/ \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_SYSTEM_JSONCPP=True \
+ .
make
# hellovr_vulkan and hellovr_opengl