summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Timms2023-01-24 10:38:31 -0500
committerLiam Timms2023-01-24 10:38:31 -0500
commitefdbaf50ad24c02f807e6cb7f55e34b71a4a8a71 (patch)
treed7b09bba2c24372e181cced09cca3ef18d6e01ee
parentc245400c24eb3f499279d9e6051d044d4bbd9351 (diff)
downloadaur-efdbaf50ad24c02f807e6cb7f55e34b71a4a8a71.tar.gz
attempt to fix dependencies
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 25 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adf6683bb3de..d92a35fbbb7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = python-nibabel
pkgdesc = Python library for reading and writing of some common neuroimaging file formats
pkgver = 5.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://nipy.org/nibabel
arch = any
license = MIT
- checkdepends = python-pytest
- makedepends = python-setuptools
- makedepends = python-setuptools-scm
makedepends = python-packaging
makedepends = python-hatch-vcs
- depends = python
+ makedepends = python-build
+ makedepends = python-installer
depends = python-numpy>=1.19
depends = python-six>=1.3
+ depends = python-setuptools
+ depends = python-setuptools-scm
optdepends = python-scipy: for full SPM-ANALYZE support
+ optdepends = python-memory-profiler
+ optdepends = python-fuse
optdepends = python-pydicom: for DICOM support
optdepends = python-pillow: for PNG conversion in DICOMFS
optdepends = python-h5py: for MINC2 support
- optdepends = python-indexed-gzip
+ optdepends = python-indexed-gzip: for faster reading of NIFTI files
source = nibabel-5.0.0.tar.gz::https://github.com/nipy/nibabel/archive/5.0.0.tar.gz
sha512sums = 844d2ef7c04376068dcc8ac2daaa2842d2a06812c283bc97dd8fe6b0c6dfa03b03f4413e2061feefffcb257396e1481e4419cf82a0e108149cbdca1336e16e64
diff --git a/PKGBUILD b/PKGBUILD
index a93fa83649ac..ac83068e919a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,28 @@
pkgname=python-nibabel
_pkgname=nibabel
pkgver=5.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Python library for reading and writing of some common neuroimaging file formats'
arch=('any')
url='http://nipy.org/nibabel'
license=('MIT')
-depends=('python' 'python-numpy>=1.19' 'python-six>=1.3')
+depends=('python-numpy>=1.19'
+ 'python-six>=1.3'
+ 'python-setuptools'
+ 'python-setuptools-scm')
# building documentation may not work properly, since authors tell to use sphinx <=1.5.6, because "Sphinx >= 1.6 breaks the math_dollar extension"
-makedepends=('python-setuptools' 'python-setuptools-scm' 'python-packaging' 'python-hatch-vcs')
-checkdepends=('python-pytest')
-optdepends=('python-scipy: for full SPM-ANALYZE support' 'python-pydicom: for DICOM support' 'python-pillow: for PNG conversion in DICOMFS' 'python-h5py: for MINC2 support' 'python-indexed-gzip')
+makedepends=('python-packaging'
+ 'python-hatch-vcs'
+ 'python-build'
+ 'python-installer')
+# checkdepends=('python-pytest')
+optdepends=('python-scipy: for full SPM-ANALYZE support'
+ 'python-memory-profiler'
+ 'python-fuse'
+ 'python-pydicom: for DICOM support'
+ 'python-pillow: for PNG conversion in DICOMFS'
+ 'python-h5py: for MINC2 support'
+ 'python-indexed-gzip: for faster reading of NIFTI files')
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/nipy/${_pkgname}/archive/${pkgver}.tar.gz")
sha512sums=('844d2ef7c04376068dcc8ac2daaa2842d2a06812c283bc97dd8fe6b0c6dfa03b03f4413e2061feefffcb257396e1481e4419cf82a0e108149cbdca1336e16e64')