summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2023-03-27 03:30:17 +0200
committerChristian Schendel2023-03-27 03:30:17 +0200
commitf0796facb2b82634ecdc1ce93abf328edbb090bc (patch)
tree2d6a2637a1612cb6c745b2b0fcaddae3ad6035fb
parent70b0bd55994aff129cd68262759db01325070c1d (diff)
downloadaur-f0796facb2b82634ecdc1ce93abf328edbb090bc.tar.gz
removed .install file
removed glib2 makedepends removed stripping removed redundant permission switch in install removed gschema directory moved locale to /usr/locale
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
-rwxr-xr-xgnome-shell-extension-applications-overview-tooltip.install30
3 files changed, 12 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a5e5d8ec3cc..69ae2ef87774 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = gnome-shell-extension-applications-overview-tooltip-git
pkgdesc = Shows a tooltip over applications icons on applications overview
pkgver = 16.r0.gdac0b90
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/RaphaelRochet/applications-overview-tooltip
- install = gnome-shell-extension-applications-overview-tooltip.install
arch = any
license = unknown
makedepends = git
- makedepends = glib2
depends = gnome-shell>=1:40
provides = gnome-shell-extension-applications-overview-tooltip
conflicts = gnome-shell-extension-applications-overview-tooltip
- options = !strip
source = gnome-shell-extension-applications-overview-tooltip::git+https://github.com/RaphaelRochet/applications-overview-tooltip.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8de36cc94914..d57423083493 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,17 @@
# Maintainer: Christian Schendel <doppelhelix@gmail.com>
pkgname=gnome-shell-extension-applications-overview-tooltip-git
pkgver=16.r0.gdac0b90
-pkgrel=2
+pkgrel=3
pkgdesc="Shows a tooltip over applications icons on applications overview"
arch=(any)
url="https://github.com/RaphaelRochet/applications-overview-tooltip"
-install=${pkgname%-git}.install
license=('unknown')
depends=('gnome-shell>=1:40')
-makedepends=('git'
- 'glib2')
+makedepends=('git')
conflicts=("${pkgname%-git}")
provides=(${pkgname%-git})
source=("${pkgname%-git}::git+${url}.git")
sha256sums=('SKIP')
-options=('!strip')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -26,13 +23,15 @@ package() {
local uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
local schema=$(grep -Po '(?<="settings-schema": ")[^"]*' metadata.json).gschema.xml
local destdir="${pkgdir}/usr/share/gnome-shell/extensions/${uuid}"
- install -dm755 "${destdir}"
- find . -regextype posix-egrep -regex ".*\.(js|json|xml|css|mo|compiled)$" -exec \
- install -Dm 644 {} ${destdir}/{} \;
+ install -d "${destdir}"
+ find . -regextype posix-egrep -regex ".*\.(js|json|xml|css|md|png|compiled)$" -exec \
+ install -Dm644 {} ${destdir}/{} \;
install -Dm644 "${srcdir}/${pkgname%-git}/schemas/${schema}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
-# rebuild compiled GSettings schemas if missing
- if [[ ! -f "${destdir}/schemas/gschemas.compiled" ]]; then
- glib-compile-schemas "${destdir}/schemas"
- fi
+
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/${uuid}/schemas/"
+
+ find . -regextype posix-egrep -regex ".*\.(mo)$" -exec \
+ install -Dm644 {} ${pkgdir}/usr/share/{} \;
+
}
diff --git a/gnome-shell-extension-applications-overview-tooltip.install b/gnome-shell-extension-applications-overview-tooltip.install
deleted file mode 100755
index 7f4546e45017..000000000000
--- a/gnome-shell-extension-applications-overview-tooltip.install
+++ /dev/null
@@ -1,30 +0,0 @@
-post_install() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_install
-}
-
-post_upgrade() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_upgrade
-}
-
-post_remove() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
-}
-
-instructions_install() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r).
-Activate the extension with gnome-tweak-tool.
-
-EOF
-}
-
-instructions_upgrade() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
-
-EOF
-}