summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn A Ginis2018-01-20 13:44:32 +0200
committerJohn A Ginis2018-01-20 13:44:32 +0200
commitf150ec9fc70261b7119494646f2953934ab02a75 (patch)
tree60d28b1d6a0cc42dee9804bb0d2c5eeb06edde13
parent9a7476c226d6b7bb4bbc19a8de0feb26f3008a65 (diff)
downloadaur-f150ec9fc70261b7119494646f2953934ab02a75.tar.gz
New package commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD14
-rwxr-xr-xprepare4uploadpkg.sh2
4 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5cd048ac7c..9784df51878a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-lua-archers
pkgdesc = A free, light-weight system monitor for X with lua enabled for Arch based distros
- pkgver = 1.10.6
- pkgrel = 3
+ pkgver = 1.10.7
+ pkgrel = 1
url = https://github.com/brndnmtthws/conky
arch = i686
arch = x86_64
@@ -27,7 +27,7 @@ pkgbase = conky-lua-archers
depends = lua51
depends = tolua++
depends = wireless_tools
- provides = conky=1.10.6
+ provides = conky=1.10.7
conflicts = conky
conflicts = conky-lua
conflicts = conky-lua-arch
@@ -37,12 +37,8 @@ pkgbase = conky-lua-archers
replaces = conky
options = strip
options = !debug
- source = https://github.com/brndnmtthws/conky/archive/v1.10.6.tar.gz
- source = asciime.patch
- source = include.patch
- sha1sums = 54cb3322dc3a969f1fda03383012c61d57261345
- sha1sums = b07407c2be11cee7bd50e046024b89cf2579c448
- sha1sums = 0efe24eab88c48cc1fef0dae001ce935f743c131
+ source = https://github.com/brndnmtthws/conky/archive/v1.10.7.tar.gz
+ sha256sums = 23bb9609c522f248cba287146943a872cc045b45cecfa5668bca76e95ecc06ac
pkgname = conky-lua-archers
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e50d7f964192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.diff
+!*.install
+!*.service
diff --git a/PKGBUILD b/PKGBUILD
index b438f3cbe603..2c39ee64c696 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=conky-lua-archers
_pkgname=conky
-pkgver=1.10.6
-pkgrel=3
+pkgver=1.10.7
+pkgrel=1
pkgdesc="A free, light-weight system monitor for X with lua enabled for Arch based distros"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky"
@@ -37,18 +37,12 @@ makedepends=(
'perl-xml-libxml'
'perl-xml-sax-expat'
)
-source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
- 'asciime.patch'
- 'include.patch')
-sha1sums=('54cb3322dc3a969f1fda03383012c61d57261345'
- 'b07407c2be11cee7bd50e046024b89cf2579c448'
- '0efe24eab88c48cc1fef0dae001ce935f743c131')
+source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('23bb9609c522f248cba287146943a872cc045b45cecfa5668bca76e95ecc06ac')
options=('strip' '!debug')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 -i ../asciime.patch # db2x_manxml fails on non-ascii chars
- patch -p1 -i ../include.patch # Build fails with gcc7 due to missing include
}
build() {
diff --git a/prepare4uploadpkg.sh b/prepare4uploadpkg.sh
index 934309fc5e6d..1e00c9a35b71 100755
--- a/prepare4uploadpkg.sh
+++ b/prepare4uploadpkg.sh
@@ -1,7 +1,7 @@
#!/usr/bin/env bash
namcap PKGBUILD && makepkg --printsrcinfo > .SRCINFO || exit 1
-git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
+git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
git commit -am "New package commit" || exit 1
git push --set-upstream origin master || exit 1