summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCocaine Johnsson2021-04-14 15:36:03 +0200
committerCocaine Johnsson2021-04-14 15:36:03 +0200
commitf203ecd7be42f77c595024224ed18120a739f787 (patch)
treed94b62c4ae2af773336476c3b386c747ff2e1cd6
parentccb1f4aa2033e241e34a6d0c43706545cf89dbf9 (diff)
downloadaur-f203ecd7be42f77c595024224ed18120a739f787.tar.gz
Okay, fixed the issue with the patch, for whatever reason I messed it up as a symlink. It's definitely working now
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--[l---------]ddb_discord_presence-makefile.patch14
3 files changed, 15 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4eb2200ec038..1c577e87f4a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = deadbeef-plugin-discord-git
source = ddb_discord_presence::git+https://github.com/kuba160/ddb_discord_presence
source = ddb_discord_presence-makefile.patch
sha256sums = SKIP
- sha256sums = 137e78e144b6f43bd3469758c5b0f6d82fe3fc08c2121903b98dd8e4e3a9498d
+ sha256sums = 5f9f2a604c20f0ea877542c2dcc7cc3d5372b026f310bdfd65214664452683a9
pkgname = deadbeef-plugin-discord-git
diff --git a/PKGBUILD b/PKGBUILD
index ade22022f05f..08482d43ccdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ makedepends=('git' 'wget')
source=("${_pkgname}::git+https://github.com/kuba160/${_pkgname}"
"${_pkgname}-makefile.patch")
sha256sums=('SKIP'
- '137e78e144b6f43bd3469758c5b0f6d82fe3fc08c2121903b98dd8e4e3a9498d')
+ '5f9f2a604c20f0ea877542c2dcc7cc3d5372b026f310bdfd65214664452683a9')
pkgver() {
cd "${_pkgname}"
diff --git a/ddb_discord_presence-makefile.patch b/ddb_discord_presence-makefile.patch
index 9d92c2ca41c1..5631dc5c16b8 120000..100644
--- a/ddb_discord_presence-makefile.patch
+++ b/ddb_discord_presence-makefile.patch
@@ -1 +1,13 @@
-/home/cocaine/.cache/pacaur/deadbeef-plugin-discord-git/ddb_discord_presence-makefile.patch \ No newline at end of file
+--- ddb_discord_presence/Makefile 2021-04-14 15:29:00.819911000 +0200
++++ ddb_discord_presence/Makefile_f 2021-04-14 15:29:06.353262000 +0200
+@@ -14,8 +14,8 @@
+ CC?=gcc
+ CXX?=g++
+ STD?=gnu99
+-CFLAGS+=-fPIC -I /usr/local/include -I discord-rpc/include -I . -Wall
+-CXXFLAGS+=-fPIC -I /usr/local/include -I . -Wall
++CFLAGS+=$(COPT) -fPIC -I /usr/local/include -I discord-rpc/include -I . -Wall
++CXXFLAGS+=$(CXXOPT) -fPIC -I /usr/local/include -I . -Wall
+ ifeq ($(UNAME_S),Darwin)
+ CFLAGS+=-I $(DEADBEEF_OSX)/Contents/Headers
+ CXXFLAGS+=-I $(DEADBEEF_OSX)/Contents/Headers