aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2017-11-27 14:30:55 -1000
committerGaetan Bisson2017-11-27 14:30:55 -1000
commitf299b58c8099163120b46d8c2e920a0dc49dd133 (patch)
tree5dfe05f232e4b884a561e19047f0c94c8593803f
parent90dd32be5a271e64b578e780cdddeb3be4e9834b (diff)
downloadaur-f299b58c8099163120b46d8c2e920a0dc49dd133.tar.gz
simplify stuff
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD9
-rw-r--r--README6
-rwxr-xr-xarch.install5
-rwxr-xr-xproxy.cgi42
5 files changed, 10 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5081f70e967..af8d5345faa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = buildstuff
pkgdesc = Stuff to build packages in virtual machines
- pkgver = 0.9
- pkgrel = 4
+ pkgver = 1.2
+ pkgrel = 1
url = http://arch.vesath.org/
arch = any
license = custom:ISC
@@ -12,14 +12,12 @@ pkgbase = buildstuff
depends = arch-install-scripts
source = README
source = LICENSE
- source = proxy.cgi
source = arch.build
source = arch.install
- sha1sums = 9065a73d67c5c021ae9d0624b973ca93053ee1dc
- sha1sums = 6ecd04bec1630ddd9ceb947e330b9624c3fa8d64
- sha1sums = 3849f76c61806e4fdcbeeb20b237d6723079c70b
- sha1sums = b30c0e4ba2c5628b210593d5e2d348ce1c84c6f1
- sha1sums = 39d491e77bb573ef17d3a41dc149735c2c107b6c
+ sha256sums = 6225e9cd7dbd46692d3b3ebde37a182c05863459879e99dbca5b3a4125e5eb1d
+ sha256sums = acf683446e1162104759b1a75d18859b1a36ac6f3eeabb241025d0e6c37c7960
+ sha256sums = 72307901efa866bdedf86c00dde6578cf5ce16ec801880f562d5fa57a82ad0d6
+ sha256sums = fce69f6429e05953fd964ab531f1b2d320385f5fa34d00d0a6d186e3fffa54f9
pkgname = buildstuff
diff --git a/PKGBUILD b/PKGBUILD
index f4869b9a0196..dadcaaf7ef25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
pkgname=buildstuff
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc='Stuff to build packages in virtual machines'
url='http://arch.vesath.org/'
@@ -11,7 +11,6 @@ depends=('qemu-headless' 'openssh' 'e2fsprogs' 'parted'
'arch-install-scripts')
source=('README'
'LICENSE'
- 'proxy.cgi'
'arch.build'
'arch.install')
@@ -21,12 +20,10 @@ package() {
install arch.* "${pkgdir}/usr/bin"
install -d "${pkgdir}/var/lib/buildstuff"
install -Dm644 README "${pkgdir}/usr/share/${pkgname}/README"
- install -Dm755 proxy.cgi "${pkgdir}/usr/share/${pkgname}/proxy.cgi"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-sha256sums=('386c1300cf5ce851a7532d8ee903c077193f61e2c01007c7991283b887228faf'
+sha256sums=('6225e9cd7dbd46692d3b3ebde37a182c05863459879e99dbca5b3a4125e5eb1d'
'acf683446e1162104759b1a75d18859b1a36ac6f3eeabb241025d0e6c37c7960'
- '8db3fcc4ac6d7d4238b921c4a28b1802426868be58111006340d101718c15a98'
'72307901efa866bdedf86c00dde6578cf5ce16ec801880f562d5fa57a82ad0d6'
- '9be8c53b30e3029d0ae7ff7765c182105b0b3773420c69da69024ef5d8398c41')
+ 'fce69f6429e05953fd964ab531f1b2d320385f5fa34d00d0a6d186e3fffa54f9')
diff --git a/README b/README
index 051685202605..e540523ec14b 100644
--- a/README
+++ b/README
@@ -19,11 +19,7 @@ Enable hardware virtualization.
Make /tmp a tmpfs. (This is where the copy-on-write drive is stored.)
-Make the host and guest share their pacman package cache using the proxy.cgi
-script:
-- install any HTTP server on the host
-- make this sript run as CGI when called as http://10.0.2.2/proxy.cgi
-- make /var/cache/pacman/pkg writeable by this CGI instance
+Install a caching pacman mirror proxy on your local network and use it.
REQUIREMENTS FOR ARCH.INSTALL
diff --git a/arch.install b/arch.install
index e7ef0bd57bc5..1a95efa01c10 100755
--- a/arch.install
+++ b/arch.install
@@ -85,12 +85,7 @@ EOF
sfdisk --activate ${loop} 1
-# To use the pacman cache from the host system, arrange for
-# /usr/share/buildstuff/proxy.cgi to be run as CGI when called as
-# http://10.0.2.2/proxy.cgi and make /var/cache/pacman/pkg writeable by it.
-
install -Dm644 /etc/pacman.d/mirrorlist etc/pacman.d/mirrorlist
-sed -i etc/pacman.d/mirrorlist -e '1i Server = http://10.0.2.2/proxy.cgi/$repo/os/$arch/'
umount boot
popd
diff --git a/proxy.cgi b/proxy.cgi
deleted file mode 100755
index 6847224f51ba..000000000000
--- a/proxy.cgi
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/usr/bin/bash
-
-set -e
-
-# This CGI script is a caching Arch Linux mirror proxy: it forwards new package
-# requests to an actual mirror while caching contents to /var/cache/pacman/pkg.
-# Use in pacman.conf with:
-#
-# Server = http://server/path/to/proxy.cgi/$repo/os/$arch/
-
-[[ $REMOTE_ADDR = 127.0.0.1 ]]
-
-cd /var/cache/pacman/pkg
-touch used-by-proxy
-
-MIR=$(awk -F '[$=]' '(!/^#/){print$2;exit}' /etc/pacman.d/mirrorlist)
-MIR=${MIR# }
-MIR=${MIR%/}
-
-PKG=${PATH_INFO##*/}
-
-if [[ $PATH_INFO = /vesath/* ]]; then
- MIR='http://arch.vesath.org/'
- PATH_INFO=${PATH_INFO#/vesath/os/}
-fi
-
-[[ $PKG = *.db* ]] &&
-exec curl --silent --include "$MIR$PATH_INFO"
-
-cat <<EOF
-Content-Type: application/octet-stream
-Connection: close
-
-EOF
-
-[[ -s $PKG ]] &&
-exec cat "$PKG"
-
-curl --silent "$MIR$PATH_INFO" |
-tee "$PKG.part"
-
-mv "$PKG.part" "$PKG"