summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMateusz Galazyn2022-01-17 20:37:20 +0100
committerMateusz Galazyn2022-01-18 12:26:15 +0100
commitf3abbcd0c9dafda1f92e4e70acf78df095622e1a (patch)
tree7fe3d1d06fe8c7494bf139e15db22954a194e664
parente3a39a676e78a56a434ed86df38f5381ff38466f (diff)
downloadaur-f3abbcd0c9dafda1f92e4e70acf78df095622e1a.tar.gz
1.7.0 fix
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--zim.install18
-rw-r--r--zimfw.zsh.patch27
4 files changed, 36 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e054660f718..383186e9bd03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zsh-zim-git
pkgdesc = ZIM - Zsh IMproved
- pkgver = r588.de7d2b1
+ pkgver = r606.bd765df
pkgrel = 1
url = https://github.com/zimfw/zimfw
install = zim.install
@@ -11,18 +11,17 @@ pkgbase = zsh-zim-git
depends = zsh
optdepends = otf-powerline-symbols-git: for eriner prompt
options = !strip
- backup = etc/zsh/zlogin
backup = etc/zsh/zimrc
backup = etc/zsh/zshrc
- source = git://github.com/zimfw/zimfw.git
- source = git://github.com/zimfw/install.git
+ source = git+https://github.com/zimfw/zimfw.git
+ source = git+https://github.com/zimfw/install.git
source = zim.install
source = zimfw.zsh.patch
source = zshrc
md5sums = SKIP
md5sums = SKIP
- md5sums = 6e5ffd11ddfc72d74afb105829821f28
- md5sums = 775a924bf0c8c86677d52e9389b2b408
+ md5sums = 344a011e44e34549568e8aee31c8e8be
+ md5sums = a1a7242bb1b9c3ee6f799ab7d4f9ac7c
md5sums = 0cb8764ba7f67c37c3c6452cc06751af
pkgname = zsh-zim-git
diff --git a/PKGBUILD b/PKGBUILD
index 0d342801a873..ad7824873b69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Mateusz Galazyn <carbolymer at gmail.com>
pkgrel=1
-pkgver=r588.de7d2b1
+pkgver=r606.bd765df
pkgname=zsh-zim-git
pkgdesc="ZIM - Zsh IMproved"
url="https://github.com/zimfw/zimfw"
@@ -10,20 +10,20 @@ license=('MIT')
depends=('zsh')
makedepends=('git' 'patch')
optdepends=('otf-powerline-symbols-git: for eriner prompt')
-source=('git://github.com/zimfw/zimfw.git'
- 'git://github.com/zimfw/install.git'
+source=('git+https://github.com/zimfw/zimfw.git'
+ 'git+https://github.com/zimfw/install.git'
'zim.install'
'zimfw.zsh.patch'
'zshrc')
md5sums=('SKIP'
'SKIP'
- '6e5ffd11ddfc72d74afb105829821f28'
- '775a924bf0c8c86677d52e9389b2b408'
+ '344a011e44e34549568e8aee31c8e8be'
+ 'a1a7242bb1b9c3ee6f799ab7d4f9ac7c'
'0cb8764ba7f67c37c3c6452cc06751af')
options=('!strip')
install='zim.install'
_gitname='zimfw'
-backup=('etc/zsh/zlogin' 'etc/zsh/zimrc' 'etc/zsh/zshrc')
+backup=('etc/zsh/zimrc' 'etc/zsh/zshrc')
pkgver() {
cd "$srcdir/$_gitname"
@@ -39,11 +39,13 @@ package() {
ZIM_TPL_DIR="${pkgdir}/usr/lib/zim/templates"
mkdir -p $ZIM_TPL_DIR
- rcfiles=('zshenv' 'zshrc' 'zlogin' 'zimrc')
+ rcfiles=('zshrc' 'zimrc')
for entry in "${rcfiles[@]}"; do
cp -L "${srcdir}/install/src/templates/${entry}" $ZIM_TPL_DIR
done
cp ${srcdir}/$_gitname/zimfw.zsh ${pkgdir}/usr/lib/zim/
+ # correct ZIM_HOME in the template
+ sed -i "s#^ZIM_HOME=.*#ZIM_HOME=/usr/lib/zim#" "$ZIM_TPL_DIR/zshrc"
# zimfw.zsh generates hardcoded reference to .zimrc, so for packaging purpose we fake it
( cd $ZIM_TPL_DIR ; ln -s ./zimrc .zimrc )
@@ -54,7 +56,6 @@ package() {
# Prepare /etc/zsh/ contents
mkdir -p $pkgdir/etc/zsh
- echo "source /usr/lib/zim/templates/zlogin" >> "$pkgdir/etc/zsh/zlogin"
cp -f $ZIM_TPL_DIR/zimrc $pkgdir/etc/zsh/zimrc
cp -f zshrc "$pkgdir/etc/zsh/zshrc"
diff --git a/zim.install b/zim.install
index 5809b32c7c93..3f59358b6830 100644
--- a/zim.install
+++ b/zim.install
@@ -4,14 +4,16 @@ post_install() {
[[ -f ~root/.zimrc ]] || ln -s /etc/zsh/zimrc ~root/.zimrc
compile_scripts
echo
- echo "Zim is enabled for all users by default."
- echo "~/.zimrc was symlinked to /etc/zsh/zimrc for root (if it was not present)"
- echo "Global settings reside in the /etc/zsh/ directory."
- echo "To personalize Zsh and zim, edit your local ~/.zshrc and ~/.zimrc files."
- echo "A user can also have a custom, overriding Zim installation in ~/.zim/"
+ echo " Zim is enabled by default for all zsh users"
echo
- echo "Please note that zim errors are suppressed, so if you're experiencing any issues"
- echo "with zim, remove &>/dev/null from /etc/zsh/zshrc"
+ echo " ~root/.zimrc was symlinked to /etc/zsh/zimrc"
+ echo " Global settings reside in the /etc/zsh/ directory."
+ echo " To personalize Zsh and Zim, edit your local ~/.zshrc and ~/.zimrc files."
+ echo " A user can also have a custom, overriding Zim installation in ~/.zim/"
+ echo
+ echo " NOTE: Zim errors are suppressed, so if you're experiencing any issues"
+ echo " with Zim, remove &>/dev/null from /etc/zsh/zshrc"
+ echo " NOTE: /etc/zsh/zprofile is not needed by this package anymore and can be removed"
echo
}
@@ -24,7 +26,7 @@ post_remove() {
}
compile_scripts() {
- zsh -c 'export ZIM_HOME=/usr/lib/zim; source /etc/zsh/zshrc; source /usr/lib/zim/templates/zlogin;'
+ zsh -c 'export ZIM_HOME=/usr/lib/zim; source /etc/zsh/zshrc;'
}
remove_compiled_scripts() {
diff --git a/zimfw.zsh.patch b/zimfw.zsh.patch
index 3c7ccc23496b..9b463517c7bc 100644
--- a/zimfw.zsh.patch
+++ b/zimfw.zsh.patch
@@ -1,7 +1,9 @@
---- zimfw.zsh 2021-09-21 16:26:34.034179638 +1000
-+++ zimfw.zsh 2021-09-21 16:30:58.546504098 +1000
-@@ -53,10 +53,6 @@
-
+diff --git a/zimfw.zsh b/zimfw.zsh
+index fe05e46..8251aff 100644
+--- a/zimfw.zsh
++++ b/zimfw.zsh
+@@ -52,10 +52,6 @@ _zimfw_mv() {
+
_zimfw_build_init() {
local -r ztarget=${ZIM_HOME}/init.zsh
- # Force update of init.zsh if it's older than .zimrc
@@ -11,29 +13,24 @@
_zimfw_mv =(
print -R "zimfw() { source ${ZIM_HOME}/zimfw.zsh \"\${@}\" }"
print -R "zmodule() { source ${ZIM_HOME}/zimfw.zsh \"\${@}\" }"
-@@ -65,16 +61,13 @@
- if (( ${#_zfunctions} )) print -R 'autoload -Uz '${_zfunctions#${~zpre}}
+@@ -65,18 +61,16 @@ _zimfw_build_init() {
+ if (( ${#_zfunctions} )) print -R 'autoload -Uz -- '${_zfunctions#${~zpre}}
print -R ${(F)_zcmds#${~zpre}}
) ${ztarget}
+ chmod -R u+rX,g+rX,o+rX "${ZIM_HOME}" &>/dev/null
}
-
+
_zimfw_build_login_init() {
- # Array with unique dirs. ${ZIM_HOME} or any subdirectory should only occur once.
- local -Ur zscriptdirs=(${ZIM_HOME} ${${_zdirs##${ZIM_HOME}/*}:A})
- local -r zscriptglob=("${^zscriptdirs[@]}/(^*test*/)#*.zsh(|-theme)(N-.)") ztarget=${ZIM_HOME}/login_init.zsh
+ local -r ztarget=${ZIM_HOME}/login_init.zsh
- # Force update of login_init.zsh if it's older than .zimrc
- if [[ ${ztarget} -ot ${ZDOTDIR:-${HOME}}/.zimrc ]]; then
- command mv -f ${ztarget}{,.old} || return 1
- fi
_zimfw_mv =(
- print -Rn "() {
- setopt LOCAL_OPTIONS CASE_GLOB EXTENDED_GLOB
-@@ -101,6 +94,7 @@
- } \"\${@}\"
+ print -nR "# Do nothing. This file is deprecated.
"
) ${ztarget}
+ chmod -R u+rX,g+rX,o+rX "${ZIM_HOME}" &>/dev/null
}
-
+
_zimfw_build() {