summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Wasylków2022-05-22 16:46:58 +0200
committerJakub Wasylków2022-05-22 16:47:04 +0200
commitf6a83209448e0317457cda173f6333d18d177e38 (patch)
treecc0eb54bf906cf598c6ba81f0791b530e24b7a0d
parent6038d1867e624dcb6ac708e24529de92291c20e9 (diff)
downloadaur-f6a83209448e0317457cda173f6333d18d177e38.tar.gz
Set correct license info
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0ea2b6f02d2..b18ea91b12a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,8 @@ pkgbase = deadbeef-plugin-discord-git
url = https://github.com/kuba160/ddb_discord_presence
arch = i686
arch = x86_64
- license = BSD
+ license = ZLIB
+ license = MIT
makedepends = git
makedepends = wget
depends = deadbeef
diff --git a/PKGBUILD b/PKGBUILD
index cd9073a948d1..4dc668a8dc90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
_pkgname=ddb_discord_presence
pkgname=deadbeef-plugin-discord-git
-pkgver=r34.g0c2fa68
+pkgver=r51.g18103a9
pkgrel=1
pkgdesc="DeaDBeeF Discord rich presence plugin"
arch=('i686' 'x86_64')
url="https://github.com/kuba160/ddb_discord_presence"
-license=('BSD')
+license=('ZLIB', 'MIT')
depends=('deadbeef')
makedepends=('git' 'wget')
source=("${_pkgname}::git+https://github.com/kuba160/${_pkgname}")
@@ -40,4 +40,6 @@ package() {
cd "${_pkgname}"
install -m0755 -d "${pkgdir}/usr/lib/deadbeef"
make PREFIX="${pkgdir}/usr/lib/deadbeef" install
+ install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSES/*
+ sed -n '/## License/,$ p' README.md > "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}