summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2024-04-13 19:03:29 +0200
committerLone_Wolf2024-04-13 19:03:29 +0200
commitf6f3dab33e45cf7ac3170b06164f9a3495f48af0 (patch)
tree416e0322a47dddf9c95ae2b2383ebce15553854a
parentf6148cf96423504c9cb1cff49f28ac183304d9a6 (diff)
downloadaur-f6f3dab33e45cf7ac3170b06164f9a3495f48af0.tar.gz
revert commit that breaks libclc
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD13
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f7f0140682a..7769a06747ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-minimal-git
- pkgver = 19.0.0_r494519.f59911615295
+ pkgver = 19.0.0_r495593.26852565a5f6
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -16,12 +16,15 @@ pkgbase = llvm-minimal-git
options = !lto
options = !debug
source = git+https://github.com/llvm/llvm-project.git
+ source = libclc_Refactor_build_system_to_allow_in-tree_builds_#87622.patch::https://github.com/llvm/llvm-project/commit/72f9881c3ffcf4be6361c3e4312d91c9c8d94a98.patch
md5sums = SKIP
+ md5sums = 3e82d9fda49a7aaa983d3b78443f8de6
sha512sums = SKIP
+ sha512sums = d120e7426156115ba5338264dc3b8e48c253b0fc3cd24b14ddde3798d2bfc8f62eb06b88173d7738c72ea7a746a3b292a79af8528ade244528d1ccb35041621f
pkgname = llvm-minimal-git
pkgdesc = Collection of modular and reusable compiler and toolchain technologies, trimmed down git version
- depends = llvm-libs-minimal-git=19.0.0_r494519.f59911615295-1
+ depends = llvm-libs-minimal-git=19.0.0_r495593.26852565a5f6-1
optdepends = python: for using lit (LLVM Integrated Tester)
optdepends = python-setuptools: for using lit
provides = llvm
@@ -53,14 +56,14 @@ pkgname = clang-minimal-git
pkgname = clang-libs-minimal-git
pkgdesc = clang runtime libraries, trunk version
- depends = llvm-libs-minimal-git=19.0.0_r494519.f59911615295-1
+ depends = llvm-libs-minimal-git=19.0.0_r495593.26852565a5f6-1
provides = clang-libs
- conflicts = clang<19.0.0_r494519.f59911615295-1
+ conflicts = clang<19.0.0_r495593.26852565a5f6-1
conflicts = clang-libs
pkgname = clang-opencl-headers-minimal-git
pkgdesc = clang headers & include files for OpenCL, trunk version
- depends = clang-libs-minimal-git=19.0.0_r494519.f59911615295-1
+ depends = clang-libs-minimal-git=19.0.0_r495593.26852565a5f6-1
provides = clang-opencl-headers
- conflicts = clang<19.0.0_r494519.f59911615295-1
+ conflicts = clang<19.0.0_r495593.26852565a5f6-1
conflicts = clang-opencl-headers
diff --git a/PKGBUILD b/PKGBUILD
index bbc68dbf958b..85740c5ea02c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@
pkgbase=llvm-minimal-git
pkgname=(llvm-minimal-git llvm-libs-minimal-git clang-minimal-git clang-libs-minimal-git clang-opencl-headers-minimal-git)
-pkgver=19.0.0_r494519.f59911615295
+pkgver=19.0.0_r495593.26852565a5f6
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -26,9 +26,12 @@ makedepends=(git cmake libffi libedit ncurses libxml2
libxcrypt python python-setuptools)
# b361b5369ed4
source=("git+https://github.com/llvm/llvm-project.git"
+ "libclc_Refactor_build_system_to_allow_in-tree_builds_#87622.patch::https://github.com/llvm/llvm-project/commit/72f9881c3ffcf4be6361c3e4312d91c9c8d94a98.patch"
)
-md5sums=('SKIP')
-sha512sums=('SKIP')
+md5sums=('SKIP'
+ '3e82d9fda49a7aaa983d3b78443f8de6')
+sha512sums=('SKIP'
+ 'd120e7426156115ba5338264dc3b8e48c253b0fc3cd24b14ddde3798d2bfc8f62eb06b88173d7738c72ea7a746a3b292a79af8528ade244528d1ccb35041621f')
# explicitly disable lto & debug to reduce number of build hangs , resources needed and runtime issues
options=(!lto !debug )
@@ -88,6 +91,10 @@ make help | grep -Po 'install-\K.*(?=-stripped)' | while read -r target; do
done
}
+prepare() {
+ # revert change to libclc that causes build failure, see https://github.com/llvm/llvm-project/issues/88626
+ patch --directory=llvm-project --reverse --strip=1 --input=$srcdir/libclc_Refactor_build_system_to_allow_in-tree_builds_#87622.patch
+}
pkgver() {
cd llvm-project/cmake/Modules