summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeal2022-04-20 18:44:41 -0500
committerNeal2022-04-20 18:44:41 -0500
commitf7ba2e3346113acf9aee334e75bc6c2fdbb59c45 (patch)
tree0e15abaefcc9c24a0301e91d0f62aebc7494b8be
parent5ec1a3f1537f21c12906c1806f86b982ebcaa13c (diff)
downloadaur-f7ba2e3346113acf9aee334e75bc6c2fdbb59c45.tar.gz
Add patch to skip Italian translations so it builds. Clean up PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--0001_translations_fix.patch22
-rw-r--r--PKGBUILD16
3 files changed, 30 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f8451852b10..f3bd5731e10f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wsjtx-git
pkgdesc = Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)
pkgver = r9132.d28164e92
- pkgrel = 1
+ pkgrel = 2
url = http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
arch = i686
arch = x86_64
diff --git a/0001_translations_fix.patch b/0001_translations_fix.patch
new file mode 100644
index 000000000000..67e1c4a06780
--- /dev/null
+++ b/0001_translations_fix.patch
@@ -0,0 +1,22 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 69e3ae956..575cc1853 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1255,7 +1255,7 @@ set (LANGUAGES
+ # doesn't need to be populated)
+ en_GB # English UK
+ es # Spanish
+- it # Italian
++ #it # Italian
+ ja # Japanese
+ #no # Norwegian
+ #pt # Portuguese
+@@ -1263,7 +1263,7 @@ set (LANGUAGES
+ zh # Chinese
+ zh_HK # Chinese per Hong Kong
+ zh_TW # Chinese traditional
+- it # Italian
++ #it # Italian
+ )
+ foreach (lang_ ${LANGUAGES})
+ file (TO_NATIVE_PATH ${CMAKE_SOURCE_DIR}/translations/wsjtx_${lang_}.ts ts_)
diff --git a/PKGBUILD b/PKGBUILD
index 2c0428fc710a..c8b134a000d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wsjtx-git
pkgver=r9132.d28164e92
-pkgrel=1
+pkgrel=2
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)'
# change _wsjtx_tag to other versions such as wsjtx-2.5.0-rc1
_wsjtx_tag=master
@@ -24,18 +24,16 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
+ patch -i ../../0001_translations_fix.patch
}
build() {
- mkdir -p "$srcdir/${pkgname%-git}/build"
- cd "$srcdir/${pkgname%-git}/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
- make
+ cmake -B build -S "${pkgname%-git}" \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_BUILD_TYPE='Release'
+ cmake --build build
}
-# make pkg file and reverse patch so its ready for next update
package() {
- cd "$srcdir/${pkgname%-git}/build"
- make DESTDIR="$pkgdir/" install
- cd "$srcdir/${pkgname%-git}"
+ DESTDIR="$pkgdir" cmake --install build
}